[PATCH] Add package neovim-remote and it's dependencies

  • Done
  • quality assurance status badge
Details
3 participants
  • doron.behar
  • Jelle Licht
  • Ricardo Wurmus
Owner
unassigned
Submitted by
doron.behar
Severity
normal
D
D
doron.behar wrote on 15 May 2019 17:43
(address . guix-patches@gnu.org)
20190515154304.30290-1-doron.behar@gmail.com
From: Doron Behar <doron.behar@gmail.com>

---
gnu/packages/python-xyz.scm | 95 +++++++++++++++++++++++++++++++++++++
1 file changed, 95 insertions(+)

Toggle diff (105 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ed1ebdd3c..1b8e2325d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15665,3 +15665,98 @@ processes may share the same data.")
(description "A Sphinx extension to convert SVG images to PDF in case the builder does not support
SVG images natively (e.g. LaTeX).")
(license license:bsd-3)))
+
+(define-public python-pyuv
+ (package
+ (name "python-pyuv")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyuv" version))
+ (sha256
+ (base32
+ "1hpvjsy8zs8ifw0glzfxp3ll8a67mg413hp3pmyf2pqjs4221sna"))))
+ (inputs `(("libuv" ,libuv)))
+ (build-system python-build-system)
+ (home-page "http://github.com/saghul/pyuv")
+ (synopsis "Python interface for libuv")
+ (description "Python interface for libuv")
+ (license #f)))
+
+(define-public python-pynvim
+ (package
+ (name "python-pynvim")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynvim" version))
+ (sha256
+ (base32
+ "01dybk4vs452pljn1q3il5z2sd313ki0lgiglc0xmjc6wp290r6g"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ;; tests fail. Reported upstream: https://github.com/neovim/pynvim/issues/394
+ (propagated-inputs
+ `(("python-greenlet" ,python-greenlet)
+ ("python-msgpack" ,python-msgpack)
+ ))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page
+ "http://github.com/neovim/python-client")
+ (synopsis "Python client to neovim")
+ (description "Python client to neovim")
+ (license #f)))
+
+(define-public python-greenlet
+ (package
+ (name "python-greenlet")
+ (version "0.4.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "greenlet" version))
+ (sha256
+ (base32
+ "1g4g1wwc472ds89zmqlpyan3fbnzpa8qm48z3z1y6mlk44z485ll"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/python-greenlet/greenlet")
+ (synopsis
+ "Lightweight in-process concurrent programming")
+ (description
+ "Lightweight in-process concurrent programming")
+ (license #f)))
+
+(define-public neovim-remote
+ (package
+ (name "neovim-remote")
+ (version "2.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "neovim-remote" version))
+ (sha256
+ (base32
+ "1sw2j88w6nzjznj6b26mk0p6ka7svmlz4ccl00nszpg6j6l9j1cx"))))
+ (build-system python-build-system)
+ (inputs `(
+ ("python-psutil" ,python-psutil)
+ ("python-setuptools" ,python-setuptools)
+ ("python-pynvim" ,python-pynvim)
+ ))
+ (home-page
+ "https://github.com/mhinz/neovim-remote")
+ (synopsis
+ "Control nvim processes using \"nvr\" commandline tool")
+ (description
+ "This package provides an executable called nvr which solves these cases:
+ @itemize @bullet
+ @item
+ Controlling nvim processes from the shell. E.g. opening files in another terminal window.
+ @item
+ Opening files from within :terminal without starting a nested nvim process.
+ @end itemize")
+ (license license:expat)))
--
2.21.0
R
R
Ricardo Wurmus wrote on 18 May 2019 06:41
(address . doron.behar@gmail.com)(address . 35752@debbugs.gnu.org)
87woiocr31.fsf@elephly.net
Hi Doron,

Toggle quote (3 lines)
> gnu/packages/python-xyz.scm | 95 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 95 insertions(+)

thank you for your patches.

Here a couple of comments:

- Could you please prepare one commit for each package addition?

- Please fill the license field with appropriate license values.

- Please use complete sentences as descriptions.

- Please update the indentation and code formatting. If you’re using
Emacs you can make it reindent things for you. If not, please look at
other package definitions for inspiration.

- Please don’t put parentheses on lines all by themselves. They get
lonely.

Could you please send updated patches to 35752@debbugs.gnu.org?

--
Ricardo
J
J
Jelle Licht wrote on 20 Jun 2023 23:18
Re: bug#35752: [PATCH] Add package neovim-remote and it's dependencies
(address . 35752-done@debbugs.gnu.org)
87zg4t6de5.fsf@fsfe.org
Hi there,

python-neovim-remote@2.5.1 has been packaged on master, so I'm closing
this.

Cheers,
Jelle
Closed
?