[PATCH] gnu: Add wordpress.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • swedebugia
Owner
unassigned
Submitted by
swedebugia
Severity
normal
S
S
swedebugia wrote on 8 May 2019 16:24
(address . guix-patches@gnu.org)
f4fdf1f4-0b65-6057-f363-b552f516d378@riseup.net
From af9e41939c2f7354b6c40b4f06ef4595c10b876f Mon Sep 17 00:00:00 2001
From: swedebugia <swedebugia@riseup.net>
Date: Wed, 8 May 2019 16:19:51 +0200
Subject: [PATCH] gnu: Add wordpress.

* gnu/packages/web.scm (wordpress): Add public variable.
---
gnu/packages/web.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 756b00237e..8f8e669c3d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6618,3 +6619,39 @@ Features enabled by modules:
@item LDAP connectivity
@end itemize")
(license license:gpl3+)))
+
+(define-public wordpress
+ (package
+ (name "wordpress")
+ (version "5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://wordpress.org/" name "-"
version ".tar.gz"))
+ (sha256
+ (base32
+ "1bc6sg269bllq5w6p9dkqlbmqhmijgg61jcnq8vnkri10yj8jc31"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; No configure, build or tests
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check)
+ (replace 'install
+ ;; There's no ‘install’ target. Install files manually.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/" ,name)))
+ (copy-recursively "." lib)
+ #t))))))
+ (inputs
+ `(("php" ,php)
+ ("mariadb" ,mariadb)))
+ (home-page "https://wordpress.org/")
+ (synopsis "Content management system with a web interface")
+ (description "It features include a plugin architecture and a template
+system. It is most associated with blogging but supports other types
of web
+content including more traditional mailing lists and forums, media
galleries,
+and online stores. Many plugins are available.")
+ (license license:gpl2+)))
--
2.19.2
M
M
Maxim Cournoyer wrote on 21 Feb 2022 04:34
(name . swedebugia)(address . swedebugia@riseup.net)(address . 35634@debbugs.gnu.org)
87k0doq4dn.fsf@gmail.com
Hi swedebugia,

swedebugia <swedebugia@riseup.net> writes:

Toggle quote (66 lines)
> From af9e41939c2f7354b6c40b4f06ef4595c10b876f Mon Sep 17 00:00:00 2001
> From: swedebugia <swedebugia@riseup.net>
> Date: Wed, 8 May 2019 16:19:51 +0200
> Subject: [PATCH] gnu: Add wordpress.
>
> * gnu/packages/web.scm (wordpress): Add public variable.
> ---
> gnu/packages/web.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 756b00237e..8f8e669c3d 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -32,6 +32,7 @@
> ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
> ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
> +;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -6618,3 +6619,39 @@ Features enabled by modules:
> @item LDAP connectivity
> @end itemize")
> (license license:gpl3+)))
> +
> +(define-public wordpress
> + (package
> + (name "wordpress")
> + (version "5.2")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://wordpress.org/" name "-"
> version ".tar.gz"))
> + (sha256
> + (base32
> + "1bc6sg269bllq5w6p9dkqlbmqhmijgg61jcnq8vnkri10yj8jc31"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + ;; No configure, build or tests
> + (delete 'configure)
> + (delete 'build)
> + (delete 'check)
> + (replace 'install
> + ;; There's no ‘install’ target. Install files manually.
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (lib (string-append out "/lib/" ,name)))
> + (copy-recursively "." lib)
> + #t))))))
> + (inputs
> + `(("php" ,php)
> + ("mariadb" ,mariadb)))
> + (home-page "https://wordpress.org/")
> + (synopsis "Content management system with a web interface")
> + (description "It features include a plugin architecture and a template
> +system. It is most associated with blogging but supports other types
> of web
> +content including more traditional mailing lists and forums, media
> galleries,
> +and online stores. Many plugins are available.")
> + (license license:gpl2+)))

I haven't looked at this one as closely as for Dolibarr, but I'd expect
more or less the same situation: the source needs to be cleaned of
bundled libraries and an accompanying service is necessary to make this
useful/usable.

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 21 Feb 2022 04:34
control message for bug #35634
(address . control@debbugs.gnu.org)
87ilt8q4dh.fsf@gmail.com
tags 35634 + moreinfo
quit
M
M
Maxim Cournoyer wrote on 18 Mar 2022 05:09
(address . control@debbugs.gnu.org)
87wngr6gvo.fsf@gmail.com
close 35634
quit
?