[PATCH 0/1] gnu: emacs: Add lcms as an input.

  • Done
  • quality assurance status badge
Details
5 participants
  • Brett Gilio
  • wednesday
  • Marius Bakke
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
wednesday
Severity
normal
W
W
wednesday wrote on 1 May 2019 00:25
(address . guix-patches@gnu.org)(name . wednesday)(address . jessejohngildersleve@zohomail.eu)
20190430222521.6101-1-jessejohngildersleve@zohomail.eu
There is not much of a need or reason for this, other than futher completing
the TODO, which after this and my other patches I think may be complete. What
adding this does is add a few elisp functions for converting to some formats,
and working with lcms.

wednesday (1):
gnu: emacs: Add lcms to inputs.

gnu/packages/emacs.scm | 2 ++
1 file changed, 2 insertions(+)

--
2.21.0
W
W
wednesday wrote on 1 May 2019 00:26
[PATCH 1/1] gnu: emacs: Add lcms to inputs.
(address . 35516@debbugs.gnu.org)(name . wednesday)(address . jessejohngildersleve@zohomail.eu)
20190430222637.6181-2-jessejohngildersleve@zohomail.eu
* gnu/packages/emacs.scm (emacs)[inputs]: Add lcms for some color functions.
---
gnu/packages/emacs.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7c60cc6021..ce791ca3ab 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages ghostscript) ; for lcms
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome) ; for librsvg
#:use-module (gnu packages gtk)
@@ -146,6 +147,7 @@
("ncurses" ,ncurses)
;; TODO: Add the optional dependencies.
+ ("lcms" ,lcms)
("libx11" ,libx11)
("gtk+" ,gtk+)
("libxft" ,libxft)
--
2.21.0
B
B
Brett Gilio wrote on 25 Jul 2020 03:41
Re: [bug#35516] [PATCH 0/1] gnu: emacs: Add lcms as an input.
(name . wednesday)(address . jessejohngildersleve@zohomail.eu)(address . 35516@debbugs.gnu.org)
87sgdg4bh8.fsf@gnu.org
wednesday <jessejohngildersleve@zohomail.eu> writes:

Toggle quote (11 lines)
> There is not much of a need or reason for this, other than futher completing
> the TODO, which after this and my other patches I think may be complete. What
> adding this does is add a few elisp functions for converting to some formats,
> and working with lcms.
>
> wednesday (1):
> gnu: emacs: Add lcms to inputs.
>
> gnu/packages/emacs.scm | 2 ++
> 1 file changed, 2 insertions(+)

Hi, I know this patch is quite old but our Emacs currently still does
not have LCMS support. LCMS was introduced in the 26 release, and I am
curious if anybody had any thoughts on adding this? From what I gather
27 is due to be marked as stable any week now.
M
M
Marius Bakke wrote on 25 Jul 2020 18:21
(address . 35516@debbugs.gnu.org)
87y2n7sgzs.fsf@gnu.org
Brett Gilio <brettg@gnu.org> writes:

Toggle quote (18 lines)
> wednesday <jessejohngildersleve@zohomail.eu> writes:
>
>> There is not much of a need or reason for this, other than futher completing
>> the TODO, which after this and my other patches I think may be complete. What
>> adding this does is add a few elisp functions for converting to some formats,
>> and working with lcms.
>>
>> wednesday (1):
>> gnu: emacs: Add lcms to inputs.
>>
>> gnu/packages/emacs.scm | 2 ++
>> 1 file changed, 2 insertions(+)
>
> Hi, I know this patch is quite old but our Emacs currently still does
> not have LCMS support. LCMS was introduced in the 26 release, and I am
> curious if anybody had any thoughts on adding this? From what I gather
> 27 is due to be marked as stable any week now.

No objections from me. Emacs already has 'lcms' in its closure so there
would be no size difference.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8cW/cACgkQoqBt8qM6
VPoiXQf7Bmv+dz+M+fBM1sekfkXLuX7V3GaEGwsvntLUWbXT/a8hHOJ/UgTWKa1N
aFs1Ep1AN8BF278S09tUkTcfrJXC2Io11ZhlHND7GPLsN6j3gQH7OmopFS91lWu6
d6+3lAYPQEq38LCnFjaKBcsO4C1wWJPPkKu64qGLjc718UZtyNIWy324Qy7xoPi9
rRPUWJdY2RmfMpZtDB+6E4rTLOkgznq/4y/Id+DThQ7U8TrxcAKbYiWKJSXux+AV
HN42eaBT5vWyZ7zV+9soTezQZdi8Rp5zxdDgpx/7ZV3h1ojlEsXPsIeDlNeUaj6i
L0f1TutaqsFVqKWD4W3aSJb+H4Vw9Q==
=bxKI
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 7 Apr 2022 15:00
Re: bug#35516: [PATCH 0/1] gnu: emacs: Add lcms as an input.
(name . Marius Bakke)(address . marius@gnu.org)
86zgkx120l.fsf_-_@gmail.com
Hi,

Looking at old submission, it appears that


had fallen into the cracks.


On Sat, 25 Jul 2020 at 18:21, Marius Bakke <marius@gnu.org> wrote:
Toggle quote (22 lines)
> Brett Gilio <brettg@gnu.org> writes:
>> wednesday <jessejohngildersleve@zohomail.eu> writes:
>>
>>> There is not much of a need or reason for this, other than futher completing
>>> the TODO, which after this and my other patches I think may be complete. What
>>> adding this does is add a few elisp functions for converting to some formats,
>>> and working with lcms.
>>>
>>> wednesday (1):
>>> gnu: emacs: Add lcms to inputs.
>>>
>>> gnu/packages/emacs.scm | 2 ++
>>> 1 file changed, 2 insertions(+)
>>
>> Hi, I know this patch is quite old but our Emacs currently still does
>> not have LCMS support. LCMS was introduced in the 26 release, and I am
>> curious if anybody had any thoughts on adding this? From what I gather
>> 27 is due to be marked as stable any week now.
>
> No objections from me. Emacs already has 'lcms' in its closure so there
> would be no size difference.

Marius, since you have commit access, could you push this change? And
thus close this. :-)


Cheers,
simon
M
M
Maxim Cournoyer wrote on 21 May 2022 21:50
(name . Marius Bakke)(address . marius@gnu.org)
87fsl2br6v.fsf_-_@gmail.com
Hi,

Marius Bakke <marius@gnu.org> writes:

Toggle quote (23 lines)
> Brett Gilio <brettg@gnu.org> writes:
>
>> wednesday <jessejohngildersleve@zohomail.eu> writes:
>>
>>> There is not much of a need or reason for this, other than futher completing
>>> the TODO, which after this and my other patches I think may be complete. What
>>> adding this does is add a few elisp functions for converting to some formats,
>>> and working with lcms.
>>>
>>> wednesday (1):
>>> gnu: emacs: Add lcms to inputs.
>>>
>>> gnu/packages/emacs.scm | 2 ++
>>> 1 file changed, 2 insertions(+)
>>
>> Hi, I know this patch is quite old but our Emacs currently still does
>> not have LCMS support. LCMS was introduced in the 26 release, and I am
>> curious if anybody had any thoughts on adding this? From what I gather
>> 27 is due to be marked as stable any week now.
>
> No objections from me. Emacs already has 'lcms' in its closure so there
> would be no size difference.

Applied to staging with fd5b7393a0.

Closing; thank you!

Maxim
Closed
?