[PATCH] gnu: add emacs-smart-hungry-delete.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolò Balzarotti
  • Arun Isaac
Owner
unassigned
Submitted by
Nicolò Balzarotti
Severity
normal
N
N
Nicolò Balzarotti wrote on 1 Mar 2019 09:07
(address . guix-patches@gnu.org)
20190301080758.5548-1-anothersms@gmail.com
---
gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index decab4f292..4f645dc695 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1231,7 +1231,39 @@ or XEmacs.")
a set of simplified face specifications and a user-supplied color palette")
(license license:gpl3+)))
+(define-public emacs-smart-hungry-delete
+ (package
+ (name "emacs-smart-hungry-delete")
+ (version "20170412.1343")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/smart-hungry-delete-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0x1jbzs54fcngj0ldhqsnjdn91mfywhm83dl4y9547lm1js6diy5"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/hrehfeld/emacs-smart-hungry-delete")
+ (synopsis "smart hungry deletion of whitespace")
+ (description
+ "Hungrily deletes whitespace between cursor and next word, paren or
+delimiter while honoring some rules about where space should be
+left to separate words and parentheses.
+
+Usage:
+
+with use-package:
+
+(use-package smart-hungry-delete
+ :bind ((\"<backspace>\" . smart-hungry-delete-backward-char)
+\t\t (\"C-d\" . smart-hungry-delete-forward-char)))
+")
+ (license license:gpl2+)))
+
(define-public emacs-howm
(package
(name "emacs-howm")
--
2.20.1
A
A
Arun Isaac wrote on 11 Dec 2020 07:28
87v9d8kg9u.fsf@systemreboot.net
Hi,

Thanks for the patch. Sorry this has taken forever! I have now pushed to
master after changing the commit message to follow Guix conventions,
anad building from the GitHub repo instead of MELPA.

Cheers!
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl/TEZ0bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzUocIAKghCzncjG+yYvSWG7V1
db9qUWqwkQBYtxCAhrrK/r87JnF8/v3+WxAL241TI1NJ9ehoDwU16HoQtLqn19qZ
jUfIHUWPQjDn/kKjIt1dKu73mTyjoXGZs5evBsRva7/+QztyxHmX5LPDT0WO70eK
6f5gysVWEcwRBtsnS2bleNgq9uhrLCyAgcDamg0wPdDgR0DCOVqmYYuJwMDE4kvL
gH/wnkNWt5j35C8CxqJE5QvFabF25Pa9C1QvQHF5wrbbB79KmxflZ85qbXWAejl5
Zh/6sid57Dw4mqrfB0nH8TsuV4ra6/FUXH9+A3lL5tMHO/P6ZCjqiNHEx1fyaO7O
FO0=
=w0b+
-----END PGP SIGNATURE-----

Closed
?