[PATCH] gnu: terminals: Add termbox-truecolor

  • Done
  • quality assurance status badge
Details
5 participants
  • amirouche
  • Amirouche Boubekki
  • Eric Bavier
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Amirouche Boubekki
Severity
normal
A
A
Amirouche Boubekki wrote on 9 Feb 2019 00:12
(address . guix-patches@gnu.org)
21686c5a9ff5047728ed5277a6bdd5a0@hypermove.net
From c97de00efc8dfe17a2cedda69033eaa710c42a6e Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche.boubekki@gmail.com>
Date: Sat, 9 Feb 2019 00:07:48 +0100
Subject: [PATCH] gnu: Add termbox-truecolor.

* gnu/packages/terminals.scm (termbox-truecolor): New variable.
---
gnu/packages/terminals.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7f52c6efd..0ff0eda35 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Amirouche Boubekki <amirouche@hypermove.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system waf)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -1015,3 +1017,30 @@ arbitrary programs of your choice. This is useful for browsing the history
comfortably in a pager or editor.
@end itemize")
(license license:gpl3+)))
+
+(define-public termbox-truecolor
+ (package
+ (name "termbox-truecolor")
+ (version "2019.01.06-c3afbfd")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/amirouche/termbox-truecolor.git")
+ (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "179py858dhhxkj6la84b224r2fjwavygf4daw4dgl3gvv8i07ryj"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f))
+ (synopsis "Library for writing text-based user interfaces (with true-color support)")
+ (description "Termbox is a library that provides minimalistic API which
+allows the programmer to write text-based user interfaces.
+
+It is based on a simple abstraction: viewing terminals as a table of
+fixed-size cells and input being a stream of structured messages. Copy &
+pasting and wide characters (mostly Chinese, Japanese, Korean (CJK)
+characters) are not really supported.")
+ (home-page "https://github.com/amirouche/termbox-truecolor/tree/truecolor")
+ (license license:expat)))
--
2.19.1
E
E
Eric Bavier wrote on 9 Feb 2019 05:38
(name . Amirouche Boubekki)(address . amirouche@hypermove.net)(address . 34393@debbugs.gnu.org)
20190208223830.1cdda4e3@centurylink.net
Toggle quote (5 lines)
> +(define-public termbox-truecolor
> + (package
> + (name "termbox-truecolor")
> + (version "2019.01.06-c3afbfd")

Could you include a revision number here too? (See "Version Numbers"
in the manual)

Toggle quote (14 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/amirouche/termbox-truecolor.git")
> + (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "179py858dhhxkj6la84b224r2fjwavygf4daw4dgl3gvv8i07ryj"))))
> + (build-system waf-build-system)
> + (arguments
> + `(#:tests? #f))
> + (synopsis "Library for writing text-based user interfaces (with true-color support)")

Maybe: "Text-based user interface library"

The true-color support can be mentioned in the description.

Toggle quote (2 lines)
> + (description "Termbox is a library that provides minimalistic API which

"...provides a minimalistic ..."
^

Toggle quote (4 lines)
> +allows the programmer to write text-based user interfaces.
> +
> +It is based on a simple abstraction: viewing terminals as a table of

I think the paragraph break isn't necessary here.

Toggle quote (6 lines)
> +fixed-size cells and input being a stream of structured messages. Copy &
> +pasting and wide characters (mostly Chinese, Japanese, Korean (CJK)
> +characters) are not really supported.")
> + (home-page "https://github.com/amirouche/termbox-truecolor/tree/truecolor")
> + (license license:expat)))

Otherwise looks good to me,

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlxeWUYACgkQ/XPKxxnT
JWYCmA//eIQd2l+/MnvZyJh4UARjytmAbzCaHPyOXXPAcoW7E+NBWCNjNBfw6kgF
nkdELBmD5lXdUk5ECecWxbqNATy+dayhfSQPeReqrpakCgLfF9K5ZWsg1f2VmT12
o5PF0VE4rSINYw5Rf2dUef8e2g9Gs+QJ8E8uPwRTdtAXUBD6Bk2BNxjdXrxdDsGp
FLc16w/OjJjEeFOY6+2nm+Gcxfa3CRtT5+miNLiWHqNfGRjF2t5+ngIvjGp5r7Bt
3gKiMPQBNHseweAJhBF2H8WQt/kIFNj6J0ggLBRKWBmsKq3v58GydkGiRg/Aclwr
mB65LSggTEpoiumCQ6uy/QIngFasQZq0ORYh8uJ0xOiYVkXDrvgLJ40QSpHIpGQD
OqMQ8RrpX/voO86MCWmEsyukVO/iJ9Vn8PvAyRu7Uy9bQZIQajsZjbhv/gU9VeZO
RSHeaB1OMpOMND3kNh/yFtB9RHp0r/zEA9maclGTvtiHotv0a0Zc4My2KXgt+QTa
A+JiPMGZnj5S8AIc8+u/rkwxm66dpdYAaVrKlbO1Co/3oQ/qDDLUSowrJl5C3dL9
9/7SdimVsDaPDcz8QI6SilRCubnJdtbyoQ0Kp/PQjBd1qhtVsJHXdU5rTr9gehVa
v41JkM+7G4XvKnzKSU9S8IB4QkHlVFn6MniCcHgauabN69tH1g4=
=mqfr
-----END PGP SIGNATURE-----


R
R
Ricardo Wurmus wrote on 9 Feb 2019 09:58
(name . Amirouche Boubekki)(address . amirouche@hypermove.net)(address . 34393@debbugs.gnu.org)
878sypmj8n.fsf@elephly.net
Hi Amirouche,

Toggle quote (7 lines)
> From c97de00efc8dfe17a2cedda69033eaa710c42a6e Mon Sep 17 00:00:00 2001
> From: Amirouche <amirouche.boubekki@gmail.com>
> Date: Sat, 9 Feb 2019 00:07:48 +0100
> Subject: [PATCH] gnu: Add termbox-truecolor.
>
> * gnu/packages/terminals.scm (termbox-truecolor): New variable.

Thanks for the patch!

[…]
Toggle quote (10 lines)
> +(define-public termbox-truecolor
> + (package
> + (name "termbox-truecolor")
> + (version "2019.01.06-c3afbfd")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/amirouche/termbox-truecolor.git")
> + (commit "c3afbfd8f31cce70ffb8c4ddd153489d9e363780")))

It’s better to let-bind the commit and then use (git-version "1.1.0"
commit), because the last release was 1.1.0.

“2019.01.06” is not a version string and it would always be considered a
more recent version than other releases because 2019 is larger than most
major release numbers.
Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

Could you tell us why the tests are disabled? If there are no tests
please add a comment “; there are no tests”.

Toggle quote (2 lines)
> + (synopsis "Library for writing text-based user interfaces (with true-color support)")

I think “guix lint” said something about this synopsis being too long.
Could you shorten it a bit?

Toggle quote (3 lines)
> + (home-page
> "https://github.com/amirouche/termbox-truecolor/tree/truecolor")

I think the “tree/truecolor” bit can be removed.

--
Ricardo
A
A
amirouche wrote on 1 May 2019 03:14
Notice
(address . 34393@debbugs.gnu.org)
3bc02708adb4cb3312ea9f6696793bb6@hyper.dev
I just noticed your comments. I will work on them tomorrow.

There is also the problem that upstream doesn't provide pkg-config file
: /
A
A
amirouche wrote on 1 May 2019 13:04
(address . 34393@debbugs.gnu.org)
7debf6baea2c012f2ce37ae46aef9821@hyper.dev
On 2019-05-01 03:14, amirouche@hyper.dev wrote:
Toggle quote (2 lines)
> I just noticed your comments. I will work on them tomorrow.

Here is a new patch.

This is a fork of the upstream package which add truecolor support.
From 64fb39c1d1d436eb6b044238ce3177844bdb39bc Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Wed, 1 May 2019 12:59:53 +0200
Subject: [PATCH] gnu: add termbox-truecolor

* gnu/packages/terminals.scm (termbox-truecolor): New variable.
---
gnu/packages/terminals.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index d0531b0c14..79759126ad 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018, 2019 Amirouche Boubekki <amirouche@hyper.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system waf)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -888,6 +890,32 @@ per-line fullscreen terminal rendering, and keyboard input event reporting.")
(define-public python2-curtsies
(package-with-python2 python-curtsies))
+(define-public termbox-truecolor
+ (let ((commit "962a3d8bee04df75c47187a9910464718ea840aa")
+ (revision "0"))
+ (package
+ (name "termbox-truecolor")
+ (version (git-version "1.1.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/amirouche/termbox-truecolor.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jkwczx7l36jrp11sp9yrhvgafg811ksxs7vl4ln7k6bw85qmm81"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (synopsis "Text-based user interfaces library")
+ (description "Termbox is a library that provides a minimalistic
+API which allows the programmer to write text-based user interfaces with
+true-color support. It is based on a simple abstraction: viewing terminals as
+a table of fixed-size cells and input being a stream of structured messages.")
+ (home-page "https://github.com/amirouche/termbox-truecolor/")
+ (license license:expat))))
+
(define-public tmate
(package
(name "tmate")
--
2.19.1
Z
Z
zimoun wrote on 12 Apr 2022 12:08
Re: bug#34393: [PATCH] gnu: terminals: Add termbox-truecolor
(name . Amirouche Boubekki)(address . amirouche@hypermove.net)
86sfqi3981.fsf@gmail.com
Hi,

Thanks for the submission.


What is the status of this old patch submission [1]?



Since the last interaction is from 2 years, 49 weeks, 3 days ago, I
propose to rebase or close.


Cheers,
simon
Z
Z
zimoun wrote on 19 May 2022 23:18
(name . Amirouche Boubekki)(address . amirouche@hypermove.net)
86mtfd8bn7.fsf_-_@gmail.com
Hi,

On Tue, 12 Apr 2022 at 12:08, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (8 lines)
> What is the status of this old patch submission [1]?
>
> 1: <http://issues.guix.gnu.org/issue/34393>
>
>
> Since the last interaction is from 2 years, 49 weeks, 3 days ago, I
> propose to rebase or close.

Since no one is willing to rebase, I am closing. Feel free to reopen.


Cheers,
simon
Closed
?