[PATCH]Add: mypaint

  • Done
  • quality assurance status badge
Details
7 participants
  • Björn Höfling
  • Brett Gilio
  • Danny Milosavljevic
  • Julien Lepiller
  • Yoshinori Arai
  • Maxim Cournoyer
  • swedebugia
Owner
unassigned
Submitted by
Yoshinori Arai
Severity
normal
Y
Y
Yoshinori Arai wrote on 2 Feb 2019 05:44
(address . guix-patches@gnu.org)(address . maxim.cournoyer@gmail.com)
20190202044421.44toqidrwk2f6acn@WaraToNora
Attachment: file
S
S
swedebugia wrote on 5 Feb 2019 06:43
D42588E4-A6A7-438F-9C65-7C14E525D1DE@riseup.net
Yoshinori Arai <kumagusu08@gmail.com> skrev: (2 februari 2019 05:44:21 CET)
Toggle quote (5 lines)
>Hello,
>
>I made mypaint package from git version.
>libmypaint-git,

Why the git version, is there no stable release?

Toggle quote (2 lines)
> mypaint-brushes-git may be conflict with gimp package.

Could you elaborate? What do you mean by conflict?

Toggle quote (9 lines)
>
>From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00 2001
>From: Yoshinori Arai <kumagusu08@gmail.com>
>Date: Sat, 2 Feb 2019 13:23:33 +0900
>Subject: [PATCH] Add: mypaint
>
>---
> gnu/packages/mypaint.scm | 132

Why did you create a new file? I suggest putting it in graphics.scm


Hi ?
--
Sent from my k-9 mail for Android.
M
M
Maxim Cournoyer wrote on 5 Feb 2019 06:52
Re: [PATCH] Add: mypaint
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)(address . guix-patches@gnu.org)
87d0o6aiiz.fsf@gmail.com
Hello Yoshinori!

Yoshinori Arai <kumagusu08@gmail.com> writes:

Toggle quote (5 lines)
> Hello,
>
> I made mypaint package from git version.
> libmypaint-git, mypaint-brushes-git may be conflict with gimp package.

In Guix, we can have multiple versions of the software without changing
its name (it's one of the advantages of a functional package manager
:-). In general, we package the latest release available from
upstream, unless there is a good justification to do otherwise.

Was there a reason to prefer the git snapshots over normal releases of
mypaint, libmypaint and mypaint-brushes in Guix? I see that the latest
release for mypaint-brushes was released only a couple days ago (2.0.1);
unless there is a reason, it would be preferable to use this tagged
released rather than some random commit.

In this case, since it seems the only dependent of mypaint is Gimp and
since Gimp requires a specific version, (its configure.ac [0] mentions
mypaint-brusesh 1.3.0, although Arch seems to work around it [1]), I'd
go with a public variable named mypaint-brushes-2 for the new
definition, leaving the current one in (gnu packages gimp) alone, thus
not impacting Gimp. The name field of both packages should be the same,
though, so that a user of mypaint-brushes can select the version as in:

guix package -i mypaint-brushes@2

I'd also put the new package definitions at the current location (gnu
packages gimp) so that their different versions live in the same Guile
module.


Toggle quote (57 lines)
> From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00 2001
> From: Yoshinori Arai <kumagusu08@gmail.com>
> Date: Sat, 2 Feb 2019 13:23:33 +0900
> Subject: [PATCH] Add: mypaint
>
> ---
> gnu/packages/mypaint.scm | 132 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 132 insertions(+)
> create mode 100644 gnu/packages/mypaint.scm
>
> diff --git a/gnu/packages/mypaint.scm b/gnu/packages/mypaint.scm
> new file mode 100644
> index 000000000..8c6edeffb
> --- /dev/null
> +++ b/gnu/packages/mypaint.scm
> @@ -0,0 +1,132 @@
> +(define-module (gnu packages mypaint)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix utils)
> + #:use-module (guix packages)
> + #:use-module (guix git-download)
> + #:use-module (guix build-system gnu)
> + #:use-module (guix build-system python)
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages autotools)
> + #:use-module (gnu packages gettext)
> + #:use-module (gnu packages glib)
> + #:use-module (gnu packages swig)
> + #:use-module (gnu packages gtk)
> + #:use-module (gnu packages python)
> + #:use-module (gnu packages python-xyz)
> + #:use-module (gnu packages ghostscript)
> + #:use-module (gnu packages gimp)
> + #:use-module (gnu packages gnome)
> + #:use-module (gnu packages web)
> + #:use-module (gnu packages python))
> +
> +(define-public libmypaint-git
> + (let ((commit "0c07191409bd257084d4ea7576deb832aac8868b")
> + (revision "1"))
> + (package
> + (name "libmypaint-git")
> + (version (git-version "2.0.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mypaint/libmypaint.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0x5yacdj4bfm298ijv64igv06yjr401g6giln5wrdpv0pixg8ig3"))))
> + ;;Using glib-or-gtk-build-system, I got error as follows.
> + ;;configure.ac:243: error: possibly undefined macro: AM_GLIB_GNU_GETTEXT
> + ;;If this token and others are legitimate, please use m4_pattern_allow.
> + ;;See the Autoconf documentation.

This error disappears when we leave "glib" as an input. Apparently glib
defines autoconf M4 macros; to be found by the ACLOCAL_PATH path
specification, it must be made an explicit input.

Toggle quote (19 lines)
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("intltool" ,intltool)
> + ("libtool" ,libtool)
> + ("automake" ,automake)
> + ("autoconf" ,autoconf)
> + ("python-2" ,python-2) ;need to generate headers in autogen.sh
> + ("pkg-config" ,pkg-config)))
> + ;; As needed by 'libmypaint.pc'.
> + (propagated-inputs
> + `(("json-c" ,json-c)
> + ("gobject-introspection" ,gobject-introspection)))
> + (inputs
> + `(("glib" ,glib)))
> + (home-page "http://mypaint.org/")
> + (synopsis "Brush library")
> + (description "This library used by MyPaint and other painting programs use it too")
> + (license license:isc))))

This should reuse the original libmypaint package definition through
inheritance. You'll find examples in the sources of Guix. This way, you
wouldn't need to duplicate the common fields (home page, description,
synopsis, etc.).

Toggle quote (24 lines)
> +(define-public mypaint-brushes-git
> + (let ((commit "769ec941054725a195e77d8c55080344e2ab77e4")
> + (revision "1"))
> + (package
> + (name "mypaint-brushes-git")
> + (version (git-version "2.0.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mypaint/mypaint-brushes.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0viilmad809qg12xw11p1yv0lwbgjfkcv82g2avwzdaa6wy783pf"))))
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)))
> + (home-page "http://mypaint.org/")
> + (synopsis "Brushes for MyPaint")
> + (description "Brushes used by MyPaint and other software using libmypaint")
> + (license license:cc0))))

Same for inheritance. If something is wrong with the original synopsis
or description, it should be fixed in the original package
definitions. This package could use the recently released (9 days ago)
2.0.1 tagged version instead of this commit.

Toggle quote (19 lines)
> +(define-public mypaint-git
> + (let ((commit "57685af8dbd65719d7874bc501094bade85d94e7")
> + (revision "1"))
> + (package
> + (name "mypaint-git")
> + (version (git-version "2.0.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mypaint/mypaint.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "14dmnwma8gsfd5hv3cvwkzyd3v392h4g1zp7i38295cf39yf61y6"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:python ,python-2

Why is this needed? It otherwise seem to support Python 3. Is there an
upstream issue on their tracker which we could link to in a comment?

Toggle quote (17 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-for-buildconfig-and-test
> + (lambda _
> + (for-each make-file-writable (find-files "." ".*"))
> + ;; FATAL: Cannot create cache dir '/homeless-shelter
> + (setenv "HOME" "/tmp")))
> + (replace 'install
> + (lambda _
> + (invoke "python" "setup.py" "managed_install"
> + (string-append "--prefix=" (assoc-ref %outputs "out"))))))))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("lcms" ,lcms)
> + ("libmypaint" ,libmypaint-git)
> + ("mypaint-brushes" ,mypaint-brushes-git)))

mypaint-brushes should be an input (otherwise it could be lost after
garbage collection, and is referred to by config.py).

Toggle quote (3 lines)
> + (inputs
> + `(("python2-pygobject" ,python2-pygobject)

This should go in the propagated-inputs (any run-time Python dependencies usually
must go there).

Toggle quote (2 lines)
> + ("swig" ,swig)

This can go to the native-inputs, as it is only used at build time.

Toggle quote (4 lines)
> + ("gettext" ,gettext-minimal)
> + ("python2-numpy" ,python2-numpy)
> + ("python2-pycairo" ,python2-pycairo)))

The Python dependencies should become propagated-inputs.

Toggle quote (5 lines)
> + (propagated-inputs
> + `(("gtk+" ,gtk+)
> + ("librsvg" ,librsvg)
> + ("gdk-pixbuf" ,gdk-pixbuf+svg)))

It'd be nicer to apply the extra 2 phases from the
glib-or-gtk-build-system. There are examples of hybrid build systems,
such as emacs-pdf-tools.

Toggle quote (5 lines)
> + (home-page "http://mypaint.org/")
> + (synopsis "Simple drawing an id painting program")
> + (description "MyPaint is a fast, free, and easy graphics app
> +for digital painters. MyPaint works best with a graphics tablet.")

There's no need to say "free" here, since everything is and must be in
Guix. Maybe, [...] with a tablet or similar input device.

Toggle quote (2 lines)
> + (license license:gpl2+))))

I managed to make it run a couple of times, but then it started
complaining about icons (even though I was adding the hicolor-icon-theme
to my test environment). I also tried running fc-cache -vf, but in
vain. Any ideas?

Thank you!

Maxim
Y
Y
Yoshinori Arai wrote on 5 Feb 2019 10:23
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . guix-patches@gnu.org)
20190205092305.v3nn5dj367udgrby@WaraToNora
On Tue, Feb 05, 2019 at 12:52:52AM -0500, Maxim Cournoyer wrote:
Toggle quote (36 lines)
> Hello Yoshinori!
>
> Yoshinori Arai <kumagusu08@gmail.com> writes:
>
> > Hello,
> >
> > I made mypaint package from git version.
> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
>
> In Guix, we can have multiple versions of the software without changing
> its name (it's one of the advantages of a functional package manager
> :-). In general, we package the latest release available from
> upstream, unless there is a good justification to do otherwise.
>
> Was there a reason to prefer the git snapshots over normal releases of
> mypaint, libmypaint and mypaint-brushes in Guix? I see that the latest
> release for mypaint-brushes was released only a couple days ago (2.0.1);
> unless there is a reason, it would be preferable to use this tagged
> released rather than some random commit.
>
> In this case, since it seems the only dependent of mypaint is Gimp and
> since Gimp requires a specific version, (its configure.ac [0] mentions
> mypaint-brusesh 1.3.0, although Arch seems to work around it [1]), I'd
> go with a public variable named mypaint-brushes-2 for the new
> definition, leaving the current one in (gnu packages gimp) alone, thus
> not impacting Gimp. The name field of both packages should be the same,
> though, so that a user of mypaint-brushes can select the version as in:
>
> guix package -i mypaint-brushes@2
>
> I'd also put the new package definitions at the current location (gnu
> packages gimp) so that their different versions live in the same Guile
> module.
>
> [0] https://gitlab.gnome.org/garyskeete/gimp/blob/GIMP_2_10_4/configure.ac#L73
> [1] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mypaint-brushes-git
Toggle quote (9 lines)
> I managed to make it run a couple of times, but then it started
> complaining about icons (even though I was adding the hicolor-icon-theme
> to my test environment). I also tried running fc-cache -vf, but in
> vain. Any ideas?
>
> Thank you!
>
> Maxim

Hello,

I will try to make patch of mypaint@1.3.0 in gimp package at first.
B
B
Björn Höfling wrote on 5 Feb 2019 12:42
Re: [bug#34283] [PATCH]Add: mypaint
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)(address . 34283@debbugs.gnu.org)
20190205124255.75e9f343@alma-ubu
Hi,

On Sat, 2 Feb 2019 13:44:21 +0900
Yoshinori Arai <kumagusu08@gmail.com> wrote:

Toggle quote (14 lines)
> Hello,
>
> I made mypaint package from git version.
> libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
>
> >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
> >2001
> From: Yoshinori Arai <kumagusu08@gmail.com>
> Date: Sat, 2 Feb 2019 13:23:33 +0900
> Subject: [PATCH] Add: mypaint
>
> ---
> gnu/packages/mypaint.scm | 132

I have two more notes (hope I'm not redundant):

We usually just add/modify one package per commit, unless really
necessary. Could you split your contribution into several patches?

The commit message should conform to the GNU Changelog Guides, a link
can be found here:


For examples see other commits from the git repository. Could you adapt
your commit's log messages?

Packaging can sometimes be tricky, so please ask the questions you have.

Thank you for your contribution,

Björn
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXFl2vwAKCRC/KGy2WT5f
/bItAJ47lJdFWrR75EWazUgd605crpmn6wCfeNv+x4Mmz5KmqlaBNqejW8X8U/Y=
=BHx1
-----END PGP SIGNATURE-----


Y
Y
Yoshinori Arai wrote on 6 Feb 2019 12:03
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)(address . 34283@debbugs.gnu.org)
20190206110328.mqgc5ofgif2widg6@WaraToNora
On Tue, Feb 05, 2019 at 12:42:55PM +0100, Bj�rn H�fling wrote:
Toggle quote (39 lines)
> Hi,
>
> On Sat, 2 Feb 2019 13:44:21 +0900
> Yoshinori Arai <kumagusu08@gmail.com> wrote:
>
> > Hello,
> >
> > I made mypaint package from git version.
> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
> >
> > >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
> > >2001
> > From: Yoshinori Arai <kumagusu08@gmail.com>
> > Date: Sat, 2 Feb 2019 13:23:33 +0900
> > Subject: [PATCH] Add: mypaint
> >
> > ---
> > gnu/packages/mypaint.scm | 132
>
> I have two more notes (hope I'm not redundant):
>
> We usually just add/modify one package per commit, unless really
> necessary. Could you split your contribution into several patches?
>
> The commit message should conform to the GNU Changelog Guides, a link
> can be found here:
>
> https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
>
> For examples see other commits from the git repository. Could you adapt
> your commit's log messages?
>
> Packaging can sometimes be tricky, so please ask the questions you have.
>
> Thank you for your contribution,
>
> Bj�rn


hello,

OK, I will split previous mypaint patch. Thank you.
Y
Y
Yoshinori Arai wrote on 7 Feb 2019 12:13
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)(address . 34283@debbugs.gnu.org)
20190207111352.7yczbfnjzd72xba3@WaraToNora
Attachment: file
Y
Y
Yoshinori Arai wrote on 8 Feb 2019 05:26
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)(address . 34283@debbugs.gnu.org)
20190208042643.hy3bdtj7pa6tz676@WaraToNora
On Tue, Feb 05, 2019 at 12:42:55PM +0100, Bj�rn H�fling wrote:
Toggle quote (39 lines)
> Hi,
>
> On Sat, 2 Feb 2019 13:44:21 +0900
> Yoshinori Arai <kumagusu08@gmail.com> wrote:
>
> > Hello,
> >
> > I made mypaint package from git version.
> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
> >
> > >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
> > >2001
> > From: Yoshinori Arai <kumagusu08@gmail.com>
> > Date: Sat, 2 Feb 2019 13:23:33 +0900
> > Subject: [PATCH] Add: mypaint
> >
> > ---
> > gnu/packages/mypaint.scm | 132
>
> I have two more notes (hope I'm not redundant):
>
> We usually just add/modify one package per commit, unless really
> necessary. Could you split your contribution into several patches?
>
> The commit message should conform to the GNU Changelog Guides, a link
> can be found here:
>
> https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
>
> For examples see other commits from the git repository. Could you adapt
> your commit's log messages?
>
> Packaging can sometimes be tricky, so please ask the questions you have.
>
> Thank you for your contribution,
>
> Bj�rn


Hello,

I have prepared patch series of mypaint.
Please tell me which is better to send patch series patches-guix again or another.
B
B
Brett Gilio wrote on 8 Feb 2019 05:30
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)
87zhr62979.fsf@posteo.net
Yoshinori Arai writes:

Toggle quote (45 lines)
> On Tue, Feb 05, 2019 at 12:42:55PM +0100, Björn Höfling wrote:
>> Hi,
>>
>> On Sat, 2 Feb 2019 13:44:21 +0900
>> Yoshinori Arai <kumagusu08@gmail.com> wrote:
>>
>> > Hello,
>> >
>> > I made mypaint package from git version.
>> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
>> >
>> > >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
>> > >2001
>> > From: Yoshinori Arai <kumagusu08@gmail.com>
>> > Date: Sat, 2 Feb 2019 13:23:33 +0900
>> > Subject: [PATCH] Add: mypaint
>> >
>> > ---
>> > gnu/packages/mypaint.scm | 132
>>
>> I have two more notes (hope I'm not redundant):
>>
>> We usually just add/modify one package per commit, unless really
>> necessary. Could you split your contribution into several patches?
>>
>> The commit message should conform to the GNU Changelog Guides, a link
>> can be found here:
>>
>> https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
>>
>> For examples see other commits from the git repository. Could you adapt
>> your commit's log messages?
>>
>> Packaging can sometimes be tricky, so please ask the questions you have.
>>
>> Thank you for your contribution,
>>
>> Björn
>
>
> Hello,
>
> I have prepared patch series of mypaint.
> Please tell me which is better to send patch series patches-guix again or another.

Use the mailing address for the original patch you opened.
Y
Y
Yoshinori Arai wrote on 8 Feb 2019 08:22
[PATCH-1/4]Add: mypaint@1.2.1
(address . 34283@debbugs.gnu.org)
20190208072240.sbx6xmzheyxyinkw@WaraToNora
From 9fe8e0b3cb260da2bae0de7c2c5d0963c4f543a6 Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 12:41:11 +0900
Subject: [PATCH 1/4] Add: mypaint@1.2.1

---
gnu/packages/graphics.scm | 55 +++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bf4cc89b0..6663ff7dc 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -41,7 +41,9 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gimp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -70,6 +72,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system scons)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -856,3 +859,55 @@ your terminal. It comes bundled with predefined styles:
look. The result can be uploaded on any web server without additional
requirements.")
(license license:gpl2+)))
+
+(define-public mypaint
+ (package
+ (name "mypaint")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/" name "/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1iykjvfis5y71wn9wyxpmha7vb4pgr10dbpgglymh33a5ww4j8zd"))))
+ (build-system scons-build-system)
+ (arguments
+ `(#:tests? #f ;; need graphical environment
+ #:scons ,scons-python2
+ #:scons-flags
+ (list (string-append "numpy_include="
+ (assoc-ref %build-inputs "python2-numpy")
+ "/lib/python2.7/site-packages/numpy/core/include")
+ (string-append "prefix=" (assoc-ref %outputs "out")))))
+ ;; README_LINUX.md
+ ;;-If testing outside a graphical environment (anywhere Gdk refuses
+ ;; to initialize), limit the doctests to just `lib/` and `brushlib/`.
+ ;;-There are several interactive GUI tests in the `tests/` folder
+ ;; which `nosetests` does not run - quite intentionally -
+ ;; because their executable bit is set.
+ ;;#:phases
+ ;;(modify-phases %standard-phases
+ ;; (replace 'check
+ ;; (lambda _
+ ;; (invoke "nosetests" "--with-doctest"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ("lcms" ,lcms)
+ ("swig" ,swig)))
+ ;;("python-nose" ,python2-nose))) ;; for test
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("libmypaint" ,libmypaint)
+ ("mypaint-brushes" ,mypaint-brushes)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+)
+ ("python2-pygobject" ,python2-pygobject)
+ ("python2-numpy" ,python2-numpy)
+ ("python2-pycairo" ,python2-pycairo)))
+ (home-page "http://mypaint.org/")
+ (synopsis "Simple drawing and painting program")
+ (description "MyPaint is a fast and easy graphics app for digital painters.")
+ (license license:gpl2+)))
--
2.20.1
Y
Y
Yoshinori Arai wrote on 8 Feb 2019 08:24
[PATCH-2/4]Add: libmypaint@2.0.0-alpha
(address . 34283@debbugs.gnu.org)
20190208072416.pdynd5r5po3l2ru7@WaraToNora
From 9eb0cea3a515c4bf927758578e105e1125d54c8f Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 12:53:49 +0900
Subject: [PATCH 2/4] Add: libmypaint@2.0.0-alpha

---
gnu/packages/graphics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6663ff7dc..cdccc9372 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -911,3 +911,25 @@ requirements.")
(synopsis "Simple drawing and painting program")
(description "MyPaint is a fast and easy graphics app for digital painters.")
(license license:gpl2+)))
+
+(define-public libmypaint-2
+ (package (inherit libmypaint)
+ (version "2.0.0-alpha")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mypaint/libmypaint/"
+ "archive/v" version ".0.tar.gz"))
+ (sha256
+ (base32
+ "1qbmjj7rammw4rma0jawff7q32d4gsy63f11af8dhk07bk4rkxph"))))
+ ;;MyPaint and libmypaint benefit dramatically from autovectorization
+ ;;and other compiler optimizations. from README.md
+ (arguments
+ `(#:make-flags (list "CFLAGS=-Ofast -ftree-vectorize -fopt-info-vec-optimized -march=native -mtune=native -funsafe-math-optimizations -funsafe-loop-optimizations")))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("python-2" ,python-2) ;need to generate headers in autogen.sh
+ ("pkg-config" ,pkg-config)))))
--
2.20.1
Y
Y
Yoshinori Arai wrote on 8 Feb 2019 08:25
[PATCH-3/4]Add: mypaint-blushes@2.0.1
(address . 34283@debbugs.gnu.org)
20190208072542.t56wnzcymyxmnjs4@WaraToNora
From 1b88c91f1fdec26ff604158c78861bd99bb8e40e Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 12:57:03 +0900
Subject: [PATCH 3/4] Add: mypaint-brushes@2.0.1

---
gnu/packages/graphics.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cdccc9372..03b411a50 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -933,3 +933,14 @@ requirements.")
("autoconf" ,autoconf)
("python-2" ,python-2) ;need to generate headers in autogen.sh
("pkg-config" ,pkg-config)))))
+
+(define-public mypaint-brushes-2
+ (package (inherit mypaint-brushes)
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mypaint/mypaint-brushes/"
+ "archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ap2b6n20lnvdm06x91qawk1k8jmxnf7zffxrqxw60fgqd4whwjm"))))))
--
2.20.1
Y
Y
Yoshinori Arai wrote on 8 Feb 2019 08:27
[PATCH-4/4]Add: mypaint@2.0.0-alpha.2
(address . 34283@debbugs.gnu.org)
20190208072700.6q3jtvz3lfikyjme@WaraToNora
From 624bcd336536880cf802e87bb25aeac8aac97c0a Mon Sep 17 00:00:00 2001
From: Yoshinori Arai <kumagusu08@gmail.com>
Date: Fri, 8 Feb 2019 13:07:44 +0900
Subject: [PATCH 4/4] Add: mypaint@2.0.0-alpha.2

---
gnu/packages/graphics.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 03b411a50..325a9dd51 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -944,3 +944,35 @@ requirements.")
(sha256
(base32
"0ap2b6n20lnvdm06x91qawk1k8jmxnf7zffxrqxw60fgqd4whwjm"))))))
+
+(define-public mypaint-2
+ (package (inherit mypaint)
+ (version "2.0.0-alpha.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mypaint/mypaint/"
+ "archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nmcvma2vg2iqlvg8v96d3mppc5cn46591hh8jhppgibcvifc81m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-for-buildconfig-and-test
+ (lambda _
+ (for-each make-file-writable (find-files "." ".*"))
+ ;; FATAL: Cannot create cache dir '/homeless-shelter
+ (setenv "HOME" "/tmp")))
+ (add-before 'build 'set-cflags
+ (lambda _
+ (setenv "CFLAGS" "-Ofast -ftree-vectorize -fopt-info-vec-optimized -march=native -mtune=native -funsafe-math-optimizations -funsafe-loop-optimizations")))
+ (replace 'install
+ (lambda _
+ (invoke "python" "setup.py" "managed_install"
+ (string-append "--prefix=" (assoc-ref %outputs "out"))))))))
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("libmypaint" ,libmypaint-2)
+ ("mypaint-brushes" ,mypaint-brushes-2)))))
--
2.20.1
Y
Y
Yoshinori Arai wrote on 9 Feb 2019 23:54
Re: [bug#34283] [PATCH]Add: mypaint
(name . Brett Gilio)(address . brettg@posteo.net)
20190209225416.nkr6r2pqbbmamitw@WaraToNora
On Thu, Feb 07, 2019 at 10:30:34PM -0600, Brett Gilio wrote:
Toggle quote (50 lines)
>
> Yoshinori Arai writes:
>
> > On Tue, Feb 05, 2019 at 12:42:55PM +0100, Bj�rn H�fling wrote:
> >> Hi,
> >>
> >> On Sat, 2 Feb 2019 13:44:21 +0900
> >> Yoshinori Arai <kumagusu08@gmail.com> wrote:
> >>
> >> > Hello,
> >> >
> >> > I made mypaint package from git version.
> >> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
> >> >
> >> > >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
> >> > >2001
> >> > From: Yoshinori Arai <kumagusu08@gmail.com>
> >> > Date: Sat, 2 Feb 2019 13:23:33 +0900
> >> > Subject: [PATCH] Add: mypaint
> >> >
> >> > ---
> >> > gnu/packages/mypaint.scm | 132
> >>
> >> I have two more notes (hope I'm not redundant):
> >>
> >> We usually just add/modify one package per commit, unless really
> >> necessary. Could you split your contribution into several patches?
> >>
> >> The commit message should conform to the GNU Changelog Guides, a link
> >> can be found here:
> >>
> >> https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
> >>
> >> For examples see other commits from the git repository. Could you adapt
> >> your commit's log messages?
> >>
> >> Packaging can sometimes be tricky, so please ask the questions you have.
> >>
> >> Thank you for your contribution,
> >>
> >> Bj�rn
> >
> >
> > Hello,
> >
> > I have prepared patch series of mypaint.
> > Please tell me which is better to send patch series patches-guix again or another.
>
> Use the mailing address for the original patch you opened.

I sent patch series to [bug#34283] but anything happen. Is it foolish I did?
My first patch is for gimp.scm but last patch for graphics.scm.

Do I sent patch of mypaint to patches@gnu.org again as new patch?
B
B
Brett Gilio wrote on 10 Feb 2019 02:24
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)
875zts305x.fsf@posteo.net
Yoshinori Arai writes:

Toggle quote (56 lines)
> On Thu, Feb 07, 2019 at 10:30:34PM -0600, Brett Gilio wrote:
>>
>> Yoshinori Arai writes:
>>
>> > On Tue, Feb 05, 2019 at 12:42:55PM +0100, Björn Höfling wrote:
>> >> Hi,
>> >>
>> >> On Sat, 2 Feb 2019 13:44:21 +0900
>> >> Yoshinori Arai <kumagusu08@gmail.com> wrote:
>> >>
>> >> > Hello,
>> >> >
>> >> > I made mypaint package from git version.
>> >> > libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
>> >> >
>> >> > >From c9d5b440a6affccd0852e8686482b64aaef06bea Mon Sep 17 00:00:00
>> >> > >2001
>> >> > From: Yoshinori Arai <kumagusu08@gmail.com>
>> >> > Date: Sat, 2 Feb 2019 13:23:33 +0900
>> >> > Subject: [PATCH] Add: mypaint
>> >> >
>> >> > ---
>> >> > gnu/packages/mypaint.scm | 132
>> >>
>> >> I have two more notes (hope I'm not redundant):
>> >>
>> >> We usually just add/modify one package per commit, unless really
>> >> necessary. Could you split your contribution into several patches?
>> >>
>> >> The commit message should conform to the GNU Changelog Guides, a link
>> >> can be found here:
>> >>
>> >> https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
>> >>
>> >> For examples see other commits from the git repository. Could you adapt
>> >> your commit's log messages?
>> >>
>> >> Packaging can sometimes be tricky, so please ask the questions you have.
>> >>
>> >> Thank you for your contribution,
>> >>
>> >> Björn
>> >
>> >
>> > Hello,
>> >
>> > I have prepared patch series of mypaint.
>> > Please tell me which is better to send patch series patches-guix again or another.
>>
>> Use the mailing address for the original patch you opened.
>
> I sent patch series to [bug#34283] but anything happen. Is it foolish I did?
> My first patch is for gimp.scm but last patch for graphics.scm.
>
> Do I sent patch of mypaint to patches@gnu.org again as new patch?

No, just be patient. It will be reviewed for integration upstream and
will be provided feedback by one of the maintainers when they have time
to review it.

Some things get a priority in the debbugs triage.

Best,
Brett Gilio
Y
Y
Yoshinori Arai wrote on 10 Feb 2019 03:36
(name . Brett Gilio)(address . brettg@posteo.net)
20190210023613.wk4cmip7akofem4l@WaraToNora
On Sat, Feb 09, 2019 at 07:24:58PM -0600, Brett Gilio wrote:
Toggle quote (16 lines)
> >> Use the mailing address for the original patch you opened.
> >
> > I sent patch series to [bug#34283] but anything happen. Is it foolish I did?
> > My first patch is for gimp.scm but last patch for graphics.scm.
> >
> > Do I sent patch of mypaint to patches@gnu.org again as new patch?
>
> No, just be patient. It will be reviewed for integration upstream and
> will be provided feedback by one of the maintainers when they have time
> to review it.
>
> Some things get a priority in the debbugs triage.
>
> Best,
> Brett Gilio

Thank you, I got.
D
D
Danny Milosavljevic wrote on 10 Feb 2019 20:57
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)
20190210205702.73a73d20@scratchpost.org
Hi,

On Thu, 7 Feb 2019 20:13:52 +0900
Yoshinori Arai <kumagusu08@gmail.com> wrote:

Toggle quote (2 lines)
> gimp or graphics

I think "graphics".

Toggle quote (3 lines)
> I made patch of mypaint, libmypaint, mypaint-brushes again but I am not
> accustomed to git operation. I don't know how to split patch one by one.

git format-patch -3 -o ../outgoing-mypaint will create a directory
"../outgoing-mypaint" containing multiple files.

Edit them to specify the patch version in the subject (if you change things
please add something like "v2", to make the subject: "[PATCH v2] ...".

After that, git send-email *
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxggg4ACgkQ5xo1VCww
uqX1FAf/S6T+usUA3BOpGtHHoAzDVqGuEZkovhjGBWksnqLF5jUQqZNezj+YlVXf
l3m+TxvcuGNbbgMdfgcwOK5qsm1VveWGMTwzMx+vhE3tTGUXbh2vRuXqbkBGk7+/
6UXsNbB245qKOKeUrq2zXXyCmUrTMpVzc8XYYrTmIT1dh5B/KhcBb06eGyyp6cvM
PlMMrK6oYM4CuDkLL9yrFpMr9YRCacv62vvd+Hc8oRcIs8kRrgZcnu3CAkTObipl
SS1CTR3L+2B7XfQ7f5dJIUzQxY4BzI66R3NsDq7ferXx8/HEohjG2EGQ1ZrU7mZ9
smSA/tvCNSJimeiPn6X3ZTOL3tIXDA==
=CJBA
-----END PGP SIGNATURE-----


Y
Y
Yoshinori Arai wrote on 10 Feb 2019 23:15
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190210221509.tufob7cdvhmeqcu2@WaraToNora
On Sun, Feb 10, 2019 at 08:57:02PM +0100, Danny Milosavljevic wrote:
Toggle quote (21 lines)
> Hi,
>
> On Thu, 7 Feb 2019 20:13:52 +0900
> Yoshinori Arai <kumagusu08@gmail.com> wrote:
>
> > gimp or graphics
>
> I think "graphics".
>
> > I made patch of mypaint, libmypaint, mypaint-brushes again but I am not
> > accustomed to git operation. I don't know how to split patch one by one.
>
> git format-patch -3 -o ../outgoing-mypaint will create a directory
> "../outgoing-mypaint" containing multiple files.
>
> Edit them to specify the patch version in the subject (if you change things
> please add something like "v2", to make the subject: "[PATCH v2] ...".
>
> After that, git send-email *


Hello,

Thank you for your advise. I got how to make patch series.
I made patches in guix checkout directory.
I commited patches one by one and did git format-patch ~~~~.
~ number is how many commit.
Then I did git reset --soft master/origin.
Git made patches 0001,0002,0003,0004-<commit-message>.

I don't installed git-sendmail yet.
S
S
swedebugia wrote on 28 Jun 2019 07:34
Re: [bug#34283] [PATCH-1/4]Add: mypaint@1.2.1
(address . guix-patches@gnu.org)
864f444f-f87e-595a-49c0-a5cd1b2ad415@riseup.net
On 2019-02-08 08:22, Yoshinori Arai wrote:
Toggle quote (89 lines)
> From 9fe8e0b3cb260da2bae0de7c2c5d0963c4f543a6 Mon Sep 17 00:00:00 2001
> From: Yoshinori Arai <kumagusu08@gmail.com>
> Date: Fri, 8 Feb 2019 12:41:11 +0900
> Subject: [PATCH 1/4] Add: mypaint@1.2.1
>
> ---
> gnu/packages/graphics.scm | 55 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 55 insertions(+)
>
> diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
> index bf4cc89b0..6663ff7dc 100644
> --- a/gnu/packages/graphics.scm
> +++ b/gnu/packages/graphics.scm
> @@ -41,7 +41,9 @@
> #:use-module (gnu packages flex)
> #:use-module (gnu packages fonts)
> #:use-module (gnu packages fontutils)
> + #:use-module (gnu packages gettext)
> #:use-module (gnu packages ghostscript)
> + #:use-module (gnu packages gimp)
> #:use-module (gnu packages gl)
> #:use-module (gnu packages glib)
> #:use-module (gnu packages gnome)
> @@ -70,6 +72,7 @@
> #:use-module (guix build-system cmake)
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system python)
> + #:use-module (guix build-system scons)
> #:use-module (guix download)
> #:use-module (guix git-download)
> #:use-module ((guix licenses) #:prefix license:)
> @@ -856,3 +859,55 @@ your terminal. It comes bundled with predefined styles:
> look. The result can be uploaded on any web server without additional
> requirements.")
> (license license:gpl2+)))
> +
> +(define-public mypaint
> + (package
> + (name "mypaint")
> + (version "1.2.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/" name "/" name
> + "/releases/download/v" version
> + "/" name "-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1iykjvfis5y71wn9wyxpmha7vb4pgr10dbpgglymh33a5ww4j8zd"))))
> + (build-system scons-build-system)
> + (arguments
> + `(#:tests? #f ;; need graphical environment
> + #:scons ,scons-python2
> + #:scons-flags
> + (list (string-append "numpy_include="
> + (assoc-ref %build-inputs "python2-numpy")
> + "/lib/python2.7/site-packages/numpy/core/include")
> + (string-append "prefix=" (assoc-ref %outputs "out")))))
> + ;; README_LINUX.md
> + ;;-If testing outside a graphical environment (anywhere Gdk refuses
> + ;; to initialize), limit the doctests to just `lib/` and `brushlib/`.
> + ;;-There are several interactive GUI tests in the `tests/` folder
> + ;; which `nosetests` does not run - quite intentionally -
> + ;; because their executable bit is set.
> + ;;#:phases
> + ;;(modify-phases %standard-phases
> + ;; (replace 'check
> + ;; (lambda _
> + ;; (invoke "nosetests" "--with-doctest"))))))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("python" ,python-2)
> + ("lcms" ,lcms)
> + ("swig" ,swig)))
> + ;;("python-nose" ,python2-nose))) ;; for test
> + (inputs
> + `(("gettext" ,gettext-minimal)
> + ("libmypaint" ,libmypaint)
> + ("mypaint-brushes" ,mypaint-brushes)))
> + (propagated-inputs
> + `(("gtk+" ,gtk+)
> + ("python2-pygobject" ,python2-pygobject)
> + ("python2-numpy" ,python2-numpy)
> + ("python2-pycairo" ,python2-pycairo)))
> + (home-page "http://mypaint.org/")
> + (synopsis "Simple drawing and painting program")
> + (description "MyPaint is a fast and easy graphics app for digital painters.")
> + (license license:gpl2+)))
>

This has slipped through the cracks. Can someone with gtk-knowledge
please review?

--
Cheers Swedebugia
J
J
Julien Lepiller wrote on 15 Jan 2021 20:50
Re: [bug#34283] [PATCH]Add: mypaint
(name . Yoshinori Arai)(address . kumagusu08@gmail.com)(address . 34283-close@debbugs.gnu.org)
20210115205002.2859508e@tachikoma.lepiller.eu
Le Sat, 2 Feb 2019 13:44:21 +0900,
Yoshinori Arai <kumagusu08@gmail.com> a écrit :

Toggle quote (6 lines)
> Hello,
>
> I made mypaint package from git version.
> libmypaint-git, mypaint-brushes-git may be conflict with gimp package.
>

Hello Yoshinori,

Sorry for the late reply, it seems this patch has indeed fell into the
cracks :/. In the meantime, someone pushed mypaint 2.0.1 last December.
This situation is really not great for you and I apologize.

Since we now have mypaint in Guix, I think this patch series is
obsolete, so I'm going ahead and closing. Of course, feel free to
re-open if you think that's a mistake.
?