[PATCH] gnu: Add emacs-webpaste

  • Done
  • quality assurance status badge
Details
4 participants
  • Arun Isaac
  • Brett Gilio
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal
B
B
Brett Gilio wrote on 10 Nov 2018 22:04
(address . guix-patches@gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
20181110210451.16202-1-brettg@posteo.net
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6008e6a9..72112cfc0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018 Brett Gilio <bgilio@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9837,6 +9838,31 @@ CSS, JavaScript, JSON.")
throw a shell history.")
(license license:gpl3+))))
+(define-public emacs-webpaste
+ (package
+ (name "emacs-webpaste")
+ (version "20180815.1855")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/webpaste-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0afbyrqs0hk9b5a7g75lar31v8bmmbgvcl64z0i52bi78vz7fdv8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/etu/webpaste.el")
+ (synopsis "Paste to pastebin-like services")
+ (description "This mode allows to paste whole buffers or parts of buffers to
+pastebin-like services. It supports more than one service and will
+failover if one service fails. More services can easily be added
+over time and prefered services can easily be configured.")
+ (license license:gpl3+)))
+
(define-public emacs-discover-my-major
(package
(name "emacs-discover-my-major")
--
2.19.1
B
B
Brett Gilio wrote on 10 Nov 2018 22:08
Re: bug#33338: Acknowledgement ([PATCH] gnu: Add emacs-webpaste)
(address . 33338@debbugs.gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
87o9awljy2.fsf@posteo.net
Small error in the patch. Please revise the email line to "brettg@posteo.net"
L
L
Ludovic Courtès wrote on 19 Nov 2018 22:36
Re: [bug#33338] [PATCH] gnu: Add emacs-webpaste
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33338@debbugs.gnu.org)
875zwsvjgf.fsf@gnu.org
Hi Brett, and sorry for the delay!

Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)

Could you add a commit log along the lines of what we usually do? (See
‘git log’ to get an idea.)

Toggle quote (11 lines)
> + (package
> + (name "emacs-webpaste")
> + (version "20180815.1855")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://melpa.org/packages/webpaste-"
> + version
> + ".el"))

Since files on MELPA disappear or are modified in place, it’s safer to
take them from upstream repositories. Could you send an updated patch
that fetches code from the github.com repo?

Thank you!

Ludo’.
B
B
Brett Gilio wrote on 24 Nov 2018 22:02
(name . Ludovic Courtès)(address . ludo@gnu.org)
87va4m5gup.fsf@posteo.net
Ludovic Courtès writes:

Toggle quote (30 lines)
> Hi Brett, and sorry for the delay!
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>> gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
>> 1 file changed, 26 insertions(+)
>
> Could you add a commit log along the lines of what we usually do? (See
> ‘git log’ to get an idea.)
>
>> + (package
>> + (name "emacs-webpaste")
>> + (version "20180815.1855")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://melpa.org/packages/webpaste-"
>> + version
>> + ".el"))
>
> Since files on MELPA disappear or are modified in place, it’s safer to
> take them from upstream repositories. Could you send an updated patch
> that fetches code from the github.com repo?
>
> Thank you!
>
> Ludo’.

Hi Ludo,

When I run git format-patch -1 I suppose it isn't adding the commit log
to the patch file? I think that is what you are trying to say. How then
should I add it, because I am making commits before I generate the
patch?

Brett Gilio
T
T
Tobias Geerinckx-Rice wrote on 25 Nov 2018 11:07
(name . Brett Gilio)(address . brettg@posteo.net)
87d0qtv5az.fsf@nckx
Brett,

Brett Gilio wrote:
Toggle quote (8 lines)
> When I run git format-patch -1 I suppose it isn't adding the
> commit log
> to the patch file? I think that is what you are trying to
> say. How then
> should I add it, because I am making commits before I generate
> the
> patch?

That's the normal (only?) way. ‘git format-patch’es will include
whatever commit messages you wrote during ’git commit’, and which
are displayed by ’git log’, ‘git show’, et al.

What do the latter commands show?

Kind regards,

T G-R
B
B
Brett Gilio wrote on 25 Nov 2018 16:52
(name . Tobias Geerinckx-Rice)(address . somebody@not-sent-or-endorsed-by.tobias.gr)
875zwlgnnw.fsf@posteo.net
Tobias Geerinckx-Rice writes:

Toggle quote (20 lines)
> Brett,
>
> Brett Gilio wrote:
>> When I run git format-patch -1 I suppose it isn't adding the commit
>> log
>> to the patch file? I think that is what you are trying to say. How
>> then
>> should I add it, because I am making commits before I generate the
>> patch?
>
> That's the normal (only?) way. ‘git format-patch’es will include
> whatever commit messages you wrote during ’git commit’, and which are
> displayed by ’git log’, ‘git show’, et al.
>
> What do the latter commands show?
>
> Kind regards,
>
> T G-R

The patches are including the commit in the name of the format itself,
but it seems like ludo is wanting something contained within the patch
itself which it is not doing.

Git log is showing my commit history with the messages, git show is
also. So, I am confused as to what exactly I am not doing correctly.

Brett
L
L
Ludovic Courtès wrote on 27 Nov 2018 11:58
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33338@debbugs.gnu.org)
875zwibxdg.fsf@gnu.org
Hello Brett,

Just a friendly reminder. :-)

Ludo’.

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (29 lines)
> Hi Brett, and sorry for the delay!
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>> gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
>> 1 file changed, 26 insertions(+)
>
> Could you add a commit log along the lines of what we usually do? (See
> ‘git log’ to get an idea.)
>
>> + (package
>> + (name "emacs-webpaste")
>> + (version "20180815.1855")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://melpa.org/packages/webpaste-"
>> + version
>> + ".el"))
>
> Since files on MELPA disappear or are modified in place, it’s safer to
> take them from upstream repositories. Could you send an updated patch
> that fetches code from the github.com repo?
>
> Thank you!
>
> Ludo’.
L
L
Ludovic Courtès wrote on 27 Dec 2018 12:00
control message for bug #33338
(address . control@debbugs.gnu.org)
875zvfb5ey.fsf@gnu.org
tags 33338 moreinfo
A
A
Arun Isaac wrote on 11 Dec 2020 08:34
Re: [bug#33338] [PATCH] gnu: Add emacs-webpaste
(address . 33338-done@debbugs.gnu.org)
87mtykkd7t.fsf@systemreboot.net
Hi,

I fixed this patch, packaged the tests, and pushed to master.

Cheers! :-)
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl/TIRYbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzjPoIALLYKRQZw3r2Y1XfdHj+
qaQunsHdf1LMBLn8GGT9Qjfie3l8h3tD0cr4NfA6pSco+WRv1T/k/Atp+hydM9iv
Omn7IISqGSwYIeUDM/ItHjDeCU+f8i3opz+yMkdp2TqAoBfTovy8WAcJxVfIDEqi
VVgNZMgcRSVM68coJhOsIeXhn4twH8+q9MxJdvabLm8gGrZ9HTPcswh6EsiuQOFZ
rgq8y6ip3DWydTlO0YngnJ+W8H/PsEipOoTR0Q46hJj8iBBOYbhXrrn8rqvVsafe
KSQYmd39Ja3uWOXC2khu5C52WewFiCrg4JAIaj5xwNGvTYtvY16TqoAkROvbNsry
hJ0=
=LdTD
-----END PGP SIGNATURE-----

Closed
?