[PATCH] gnu: Add soundconverter.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 14 Oct 2018 22:18
(address . guix-patches@gnu.org)
20181014201810.619-1-mail@cbaines.net
* gnu/packages/gnome.scm (soundconverter): New variable.
---
gnu/packages/gnome.scm | 61 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de938e4b14..ab7352e104 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7220,6 +7220,67 @@ It supports ripping to any audio codec supported by a GStreamer plugin, such as
mp3, Ogg Vorbis and FLAC")
(license license:gpl2+)))
+(define-public soundconverter
+ (package
+ (name "soundconverter")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/soundconverter/trunk/"
+ version "/+download/"
+ "soundconverter-" version ".tar.xz"))
+
+ (sha256
+ (base32
+ "1wrxf5py54xplrf97qp24pzbis0cvax5c6k0c7vr3z3ry8r7gd7c"))
+ (patches
+ (list
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://salsa.debian.org/multimedia-team/soundconverter"
+ "/raw/master/debian/patches/"
+ "0002-Only-fetch-profiles-if-GConf-is-still-available.patch"))
+ (sha256
+ (base32
+ "00nxpbkz7ihzrbz91ms7bd2mjgyhkbxpaa8zxj4xnkv4pjmg61hh")))))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-POTFILES.in
+ (lambda _
+ (substitute* "po/POTFILES.in"
+ (("soundconverter/gconfstore\\.py") ""))))
+ (add-after 'install 'wrap-rhythmbox
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (python-path (getenv "PYTHONPATH"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/soundconverter")
+ `("PYTHONPATH" ":" prefix (,python-path))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
+ #t)))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("python" ,python)
+ ("python-pygobject" ,python-pygobject)
+ ("gstreamer" ,gstreamer)))
+ (home-page "http://soundconverter.org/")
+ (synopsis "Audio file converter for the GNOME Desktop")
+ (description
+ "SoundConverter supports converting between many audio formats including
+Opus, Ogg Vorbis, FLAC and more. It supports parallel conversion, and
+configurable file renaming. ")
+ (license license:gpl3)))
+
(define-public workrave
(let ((commit "v1_10_21"))
(package
--
2.19.1
L
L
Leo Famulari wrote on 16 Oct 2018 18:43
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33042@debbugs.gnu.org)
20181016164327.GC25057@jasmine.lan
On Sun, Oct 14, 2018 at 09:18:10PM +0100, Christopher Baines wrote:
Toggle quote (2 lines)
> * gnu/packages/gnome.scm (soundconverter): New variable.

Thanks, it's nice to have graphical programs for this sort of task :)

Toggle quote (12 lines)
> + (patches
> + (list
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://salsa.debian.org/multimedia-team/soundconverter"
> + "/raw/master/debian/patches/"
> + "0002-Only-fetch-profiles-if-GConf-is-still-available.patch"))
> + (sha256
> + (base32
> + "00nxpbkz7ihzrbz91ms7bd2mjgyhkbxpaa8zxj4xnkv4pjmg61hh")))))))

I think it's better if we include this file in our source code, since
it's not very big and Debian's code infrastructure URLs seem to change
every few years. Also, the URL is not versioned, so maybe the patch
would change in the future.

Toggle quote (5 lines)
> + (add-after 'unpack 'fix-POTFILES.in
> + (lambda _
> + (substitute* "po/POTFILES.in"
> + (("soundconverter/gconfstore\\.py") ""))))

Please add an explanatory comment for this.

Toggle quote (12 lines)
> + (add-after 'install 'wrap-rhythmbox
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out"))
> + (python-path (getenv "PYTHONPATH"))
> + (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
> + (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
> + (wrap-program (string-append out "/bin/soundconverter")
> + `("PYTHONPATH" ":" prefix (,python-path))
> + `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
> + `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
> + #t)))))

If possible, I think it's better to use the python-build-system's wrap
phase for PYTHONPATH. The hplip package has an example.

Toggle quote (2 lines)
> + (synopsis "Audio file converter for the GNOME Desktop")

It works in i3, too :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlvGFS8ACgkQJkb6MLrK
fwjrCw/+Oewa7FHBGiKK687mke+YoZwbTrpp2sOCIvKe1E0SGliHfp27gmPpn7Ev
xFyHgyL/g10XAEgSCYdwA310/bkTf9qplZmVhuTuUXBU7d8+Mu39L4hD+UsTzivW
AVd/WrnyMUZh7pgJOKJAwJdi9YfZULv3f9t9KmC1HoWiAzCHCGmZSDtXkpyXO/kv
KiDBPbA+hqj4O7GjOhVtmDyOfTphiuMCEeZjnIpo538m0C5EycY172jPb9Kus9fY
Jjeslgal9cMbKEeBud7EWGkm6F93RyQKIXKL6bAEeGcIpTM1C5Zj3tP1FDHU+WnE
xfEVb9S5r3HvhxbscNI5DE3LWaJ1478iRj1UIJTrEEPOniDmOLt//453oHX/qfJ0
1eDTBR6YEdCV1qYn/5HvfZp2dmALbUwfKjTeFlzsTMQ6jCV9J0f7+tRV1uqWMC5z
dk4Graknh7i24aPJbkUw5toJE1SAgxaQf8cJwFlNxZUsM08n0xKr1U5O+jvi2uD8
Wom37eTMsS/UezbPZcEzuEJaCQ/tw5qSZdDZOKAwpvJqNdf6KVZQHBVuaJbQBl1h
7iYVZvCOVRHLiqrlIdVod2+H/Yaq8RrqmrRiiGUwQoAz+u2XDvSm87OK8MPPXmUr
aF8HYoJlAxifAwkMnF73aJu95u1vHePGw0rm3JuPeArXOM+f7XQ=
=SMoI
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 19 Oct 2018 15:43
[PATCH] gnu: Add soundconverter.
(address . 33042@debbugs.gnu.org)
20181019134325.22400-1-mail@cbaines.net
* gnu/packages/gnome.scm (soundconverter): New variable.
* gnu/packages/patches/soundconverter-remove-gconf-dependency.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 65 +++++++++++++++
...undconverter-remove-gconf-dependency.patch | 83 +++++++++++++++++++
3 files changed, 149 insertions(+)
create mode 100644 gnu/packages/patches/soundconverter-remove-gconf-dependency.patch

Toggle diff (179 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index af3773c893..6108ba8b82 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1146,6 +1146,7 @@ dist_patch_DATA = \
%D%/packages/patches/slim-reset.patch \
%D%/packages/patches/slim-login.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
+ %D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
%D%/packages/patches/soundtouch-CVE-2018-14044-14045.patch \
%D%/packages/patches/soundtouch-CVE-2018-1000223.patch \
%D%/packages/patches/steghide-fixes.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de938e4b14..2b75439a95 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7220,6 +7220,71 @@ It supports ripping to any audio codec supported by a GStreamer plugin, such as
mp3, Ogg Vorbis and FLAC")
(license license:gpl2+)))
+(define-public soundconverter
+ (package
+ (name "soundconverter")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/soundconverter/trunk/"
+ version "/+download/"
+ "soundconverter-" version ".tar.xz"))
+
+ (sha256
+ (base32
+ "1wrxf5py54xplrf97qp24pzbis0cvax5c6k0c7vr3z3ry8r7gd7c"))
+ (patches
+ (search-patches
+ "soundconverter-remove-gconf-dependency.patch"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:imported-modules ((guix build python-build-system)
+ (guix build glib-or-gtk-build-system)
+ ,@%gnu-build-system-modules)
+
+ #:modules ((guix build glib-or-gtk-build-system)
+ (guix build utils)
+ ((guix build gnu-build-system) #:prefix gnu:)
+ ((guix build python-build-system) #:prefix python:))
+
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-POTFILES.in
+ (lambda _
+ (substitute* "po/POTFILES.in"
+ ;; This file doesn't exist, so without removing it, the 'check
+ ;; phase fails for the po directory
+ (("soundconverter/gconfstore\\.py") ""))))
+ (add-after 'install 'wrap-soundconverter-for-python
+ (assoc-ref python:%standard-phases 'wrap))
+ (add-after 'install 'wrap-soundconverter
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/soundconverter")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
+ #t)))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("python" ,python)
+ ("python-pygobject" ,python-pygobject)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)))
+ (home-page "http://soundconverter.org/")
+ (synopsis "Audio file converter for the GNOME Desktop")
+ (description
+ "SoundConverter supports converting between many audio formats including
+Opus, Ogg Vorbis, FLAC and more. It supports parallel conversion, and
+configurable file renaming. ")
+ (license license:gpl3)))
+
(define-public workrave
(let ((commit "v1_10_21"))
(package
diff --git a/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch b/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch
new file mode 100644
index 0000000000..f065b9a3d4
--- /dev/null
+++ b/gnu/packages/patches/soundconverter-remove-gconf-dependency.patch
@@ -0,0 +1,83 @@
+From: Sebastian Ramacher <sebastian@ramacher.at>
+Date: Fri, 6 Apr 2018 13:25:35 +0200
+Subject: Only fetch profiles if GConf is still available
+
+---
+ bin/soundconverter.py | 1 -
+ soundconverter/gstreamer.py | 44 ++++++++++++++++++++++++--------------------
+ 2 files changed, 24 insertions(+), 21 deletions(-)
+
+diff --git a/bin/soundconverter.py b/bin/soundconverter.py
+index 39055ce..5198443 100644
+--- a/bin/soundconverter.py
++++ b/bin/soundconverter.py
+@@ -66,7 +66,6 @@ def _check_libs():
+ import gi
+ gi.require_version('Gst', '1.0')
+ gi.require_version('Gtk', '3.0')
+- gi.require_version('GConf', '2.0')
+ from gi.repository import GObject
+ # force GIL creation - see https://bugzilla.gnome.org/show_bug.cgi?id=710447
+ import threading
+diff --git a/soundconverter/gstreamer.py b/soundconverter/gstreamer.py
+index 23aaa9b..211b052 100644
+--- a/soundconverter/gstreamer.py
++++ b/soundconverter/gstreamer.py
+@@ -25,7 +25,7 @@ from urllib.parse import urlparse
+ from gettext import gettext as _
+
+ import gi
+-from gi.repository import Gst, Gtk, GObject, GConf, Gio
++from gi.repository import Gst, Gtk, GObject, Gio
+
+ from soundconverter.fileoperations import vfs_encode_filename, file_encode_filename
+ from soundconverter.fileoperations import unquote_filename, vfs_makedirs, vfs_unlink
+@@ -66,25 +66,29 @@ _GCONF_PROFILE_LIST_PATH = "/system/gstreamer/1.0/audio/global/profile_list"
+ audio_profiles_list = []
+ audio_profiles_dict = {}
+
+-_GCONF = GConf.Client.get_default()
+-profiles = _GCONF.all_dirs(_GCONF_PROFILE_LIST_PATH)
+-for name in profiles:
+- if _GCONF.get_bool(_GCONF_PROFILE_PATH + name + "/active"):
+- # get profile
+- description = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/name")
+- extension = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/extension")
+- pipeline = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/pipeline")
+- # check profile validity
+- if not extension or not pipeline:
+- continue
+- if not description:
+- description = extension
+- if description in audio_profiles_dict:
+- continue
+- # store
+- profile = description, extension, pipeline
+- audio_profiles_list.append(profile)
+- audio_profiles_dict[description] = profile
++try:
++ from gi.repository import GConf
++ _GCONF = GConf.Client.get_default()
++ profiles = _GCONF.all_dirs(_GCONF_PROFILE_LIST_PATH)
++ for name in profiles:
++ if _GCONF.get_bool(_GCONF_PROFILE_PATH + name + "/active"):
++ # get profile
++ description = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/name")
++ extension = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/extension")
++ pipeline = _GCONF.get_string(_GCONF_PROFILE_PATH + name + "/pipeline")
++ # check profile validity
++ if not extension or not pipeline:
++ continue
++ if not description:
++ description = extension
++ if description in audio_profiles_dict:
++ continue
++ # store
++ profile = description, extension, pipeline
++ audio_profiles_list.append(profile)
++ audio_profiles_dict[description] = profile
++except ImportError:
++ pass
+
+ required_elements = ('decodebin', 'fakesink', 'audioconvert', 'typefind', 'audiorate')
+ for element in required_elements:
--
2.19.1
C
C
Christopher Baines wrote on 19 Oct 2018 16:05
(name . Leo Famulari)(address . leo@famulari.name)(address . 33042@debbugs.gnu.org)
87o9bqav68.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (5 lines)
> On Sun, Oct 14, 2018 at 09:18:10PM +0100, Christopher Baines wrote:
>> * gnu/packages/gnome.scm (soundconverter): New variable.
>
> Thanks, it's nice to have graphical programs for this sort of task :)

Yeah, thanks for taking a look. I've sent an updated patch :)

Toggle quote (17 lines)
>> + (patches
>> + (list
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://salsa.debian.org/multimedia-team/soundconverter"
>> + "/raw/master/debian/patches/"
>> + "0002-Only-fetch-profiles-if-GConf-is-still-available.patch"))
>> + (sha256
>> + (base32
>> + "00nxpbkz7ihzrbz91ms7bd2mjgyhkbxpaa8zxj4xnkv4pjmg61hh")))))))
>
> I think it's better if we include this file in our source code, since
> it's not very big and Debian's code infrastructure URLs seem to change
> every few years. Also, the URL is not versioned, so maybe the patch
> would change in the future.

Sure, I've included the file now. This patch has been merged upstream,
so hopefully it can be removed here when the next release comes out.

Toggle quote (7 lines)
>> + (add-after 'unpack 'fix-POTFILES.in
>> + (lambda _
>> + (substitute* "po/POTFILES.in"
>> + (("soundconverter/gconfstore\\.py") ""))))
>
> Please add an explanatory comment for this.

I have done. This has also been fixed upstream, so hopefully can also be
removed on the next release.

Toggle quote (15 lines)
>> + (add-after 'install 'wrap-rhythmbox
>> + (lambda* (#:key inputs outputs #:allow-other-keys)
>> + (let ((out (assoc-ref outputs "out"))
>> + (python-path (getenv "PYTHONPATH"))
>> + (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
>> + (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
>> + (wrap-program (string-append out "/bin/soundconverter")
>> + `("PYTHONPATH" ":" prefix (,python-path))
>> + `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
>> + `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
>> + #t)))))
>
> If possible, I think it's better to use the python-build-system's wrap
> phase for PYTHONPATH. The hplip package has an example.

I've changed this now.

Toggle quote (4 lines)
>> + (synopsis "Audio file converter for the GNOME Desktop")
>
> It works in i3, too :)

I couldn't quite work out how better to get across that it's a graphical
application, as compared to a command line tool. But, as you say, it's
not specific to GNOME.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvJ5K9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdYuxAAseLAJfzRvqU8g6SBmPNZghA9J49cf1mfqzFw+KerEqKkDE/TtC+iyTEQ
8F9gkqxT2YZIpG0sIoqv/FK+6RJ4+q+9RUN+G33uul5rTp56YEjDuHT2Hc+pmIR2
xQei5eJZE6ccIH8P2RzEbHUHKvuzBQB6iaCgmO3v0CPXsQTN6qwv3I+Ap1rYl0aW
HYijzgXfBX0ddgmlOqf8cmlkmTmpK8WoI9BS9imLSM+4S0r8y0x0876+RygOgtEq
J8f3MyVlbIiXOdDNk0iuiplzIn4dJ1TlOwFfzSdqiDg42loyHP3YO6zdrcKK+u1E
nypkiQ3TIEfoCjDzIDadSrxTIcP3cKTanfMeAJXSxvp71W4OEMKK1gtD9ZK4G+YA
mrEEerTZza616KiU/wi1Tdc0VQOm8eNqu+JUnvC+fi4eBZjUDrWQM4cZ0nvWqToS
ZbyAhB1kboBdDpFvS6h1HMonSVY67h1Y4rdo4n4bq2rbyCp89d1ldlsaG3h/W7z5
1P3PnM6IS5Su8bQZrzGKnY775zC2JY5afntN6bs2YclD7YwZN3Svs0tX/Cn3RDJ6
ODXnIlvuDKrNcEzpE/VpDcNvQl+CCullbU660p1x6sPJZHJLyZLPbLapu40sEdBc
Tg+RoURke9dTcwdAAakgKQv8uqooM/qfSU2YCUiAX4SAh24tRSs=
=jlYA
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 19 Oct 2018 22:08
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33042@debbugs.gnu.org)
20181019200832.GB9979@jasmine.lan
On Fri, Oct 19, 2018 at 03:05:35PM +0100, Christopher Baines wrote:
Toggle quote (8 lines)
> >> + (synopsis "Audio file converter for the GNOME Desktop")
> >
> > It works in i3, too :)
>
> I couldn't quite work out how better to get across that it's a graphical
> application, as compared to a command line tool. But, as you say, it's
> not specific to GNOME.

I would say something like this: "Convert between audio formats in a
graphical interface".

LGTM with that change!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlvKOb0ACgkQJkb6MLrK
fwjA3RAA0wTN70F4/mvvD4qlinjS6qjbjPhyksLEJpSVMqXhQKkg724KOUV16JnS
0dDDH8dPmriwdQw50DTqT+j+trgpwewCpX00r8qIN0u71OMIPUs90XMFKemmC7ch
xUFEwCR/ghC9fQ9yzQ7NIk8P4VUztY16tg4FVnwGU5F18VIuWIsNBPbiz8VzRBaN
TFEHEkjKzRkgPCvtUx0kZCdWdF4Nx9YHuqtUB4Q92fV6XktBWvTe4Q8+DiT/nZj9
IQhu9tsGXgwqzkUsaT0IKZr2GSldpBXIEH5YZ9Cmn9t63+5NuS5nMRQi/U210n6I
SzHL2VWbjDnmLUH+TMN+o6IDKfB1AgXCjWLo/Kqab0Lk793BleJWYYHIHTj9DAOA
7QcurCUMdRez6cLXNrsbEz+X1Rwnw7+xigLerW4zM7Jk5Cm01chwvJLrFOY+qWeR
FPeajeGDhp1eGg4VfIG/cPLpg0N2jT+U2I/pUu2bCHRFVGroQwR49j+QZuwMMGIZ
yQYahKtgRFDY18E5JYr4JzIGGyZ15lwswHHn1t9EaPpDATUi5UAC76hhH56IpKcN
IOBPyVaKvUXE3fLF3rzbRXRfZeAz+JURpBWwcq+54P/UpDcq9CpaLf6QuOX+c452
yBnK2jmxPTPouLjIg446gzUXOL7/8gIggXPu0GPCr7ORmBXGv3c=
=953L
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 20 Oct 2018 13:31
(name . Leo Famulari)(address . leo@famulari.name)(address . 33042-done@debbugs.gnu.org)
87lg6sc0sf.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (14 lines)
> On Fri, Oct 19, 2018 at 03:05:35PM +0100, Christopher Baines wrote:
>> >> + (synopsis "Audio file converter for the GNOME Desktop")
>> >
>> > It works in i3, too :)
>>
>> I couldn't quite work out how better to get across that it's a graphical
>> application, as compared to a command line tool. But, as you say, it's
>> not specific to GNOME.
>
> I would say something like this: "Convert between audio formats in a
> graphical interface".
>
> LGTM with that change!

Great, I went with "with a" rather than "in a" as that reads a bit
better to me, and I've pushed this to master now.

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlvLEgBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfpJg//ba+Wvt/q2MU7cT2l3onGxlZLwu4V0IAKUKBGL9kw9Con4DL/HHloPHiI
XU2GRB8ts7Tkh6RP6mvYvnwbdm6A7t/lZPcA6lvgEO6fjRURtANbLCLfy8abLa57
IwX6y3mQMNTU8uiUoKip6876DQJb4rvZZfsbkQG211tPVXZSK+v58HhHUwRpZ6Vv
U3HmbvHlR7hKAvmTw6AwJ2NTxr7mqKZ8fVQ4drlrEDp8KXaXmN7ZL0nr+ujhXF/m
prp9yjv/OzWPVjyinwB5dvZ9C2NtUKl20cCrdg63I9QJsuJmY1AHFU0lP9tMldbD
DfFWb2zg8nvzz6w3OsLU3dNgbGPdBmDX6v7PRWTmJo6eiyONwD1nrjx1209nNrwJ
lzp0TS7B8kMRlmTmg3avP2+jeAW8RnVYM/8UtCXq3ofrZ71Kyo2f0Gb+lc+PVV2Z
20oqOf9Hp5hzGCqeUWdao8bc6v6twjn3JFfa/4braAAqMCOIdkp3qUGMb+VyxKcd
LQQC7yaf1unSC4c4ULFjjQB30eKhvD0GtTt4oDrBR/9Aj7PeoCmSRkAcQSaWfZwk
Feq/S6MDB+1g5mxdQIDAe6LH7ydwVAQmCj85FpH3ybCHbS7zbl9GaM5lCe50GIqP
XLtMLiPA0C/7eYLdTgIQtMoOOVTnSZoOtRdcD12E31Opbj2C6vI=
=U9O3
-----END PGP SIGNATURE-----

Closed
L
L
Leo Famulari wrote on 21 Oct 2018 21:20
(name . Christopher Baines)(address . mail@cbaines.net)(address . 33042-done@debbugs.gnu.org)
20181021192056.GC18445@jasmine.lan
On Sat, Oct 20, 2018 at 12:31:12PM +0100, Christopher Baines wrote:
Toggle quote (3 lines)
> Great, I went with "with a" rather than "in a" as that reads a bit
> better to me, and I've pushed this to master now.

Perfect! That does sound better.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlvM0ZgACgkQJkb6MLrK
fwjAmRAAyjHKeCVv9YHOSZY8J3NzjK8zq2ZivqbK0iDJXJkXbtNIk1KP4sqrHPzp
yfBQXfkAeKYToliB2WgFOqNUiq7kU6sOATHbrETrqge0Msa8atjQzMqemeBjz13v
zrlwzTQkY4WkFou/R6VrzSp34q9XccFKh+hdK0t10liy2Rnu2fb8v7I+ma3O7ccq
6XCHVfvgpFIBIYnBJU/bcO6Wt4vrSCYlxuDTXHh9FxrmhDp9BUpEnIcmoYcLWKDG
nnXHihNJ4IQAirBJgIiYk7+lwwtsFQ+noe8VcG6WP/hp3Iql66gVSgyREAlCPdAA
KSBvQeWHl7cw3SOF4NE3cU3+jr8yEf6gNe1K15F+oHyt50q/NWLk24vQq5KEZnKo
YOxE1kL3b5AaOuyGRCxqjwTrpQNMzkGk2XvjCrQ8wwPOjIKmz15jeEmtVNVvAhXF
s0tPf2pszuz0cPsEwEwa25YL52wwB81N9st+38X5QonVY+Z5XXC+CudQWy5l69/s
VBVWHTR00YGyTaVf5G4WsowhPLjM1KwxEUxHhH0lbC5tKDvEpp4EAFUVPQ71iLK5
miTTl4eVNv6KXMOXyB2K1Kw6brNQzze3pdCJ9BS0xJj9+q+7V1OZzYKhm1OUq56T
8zURXkHYJ5kEeoT8EZPnFQjqNfg9J3gNVgrKm9Dz+NOBTJwKT1A=
=APa+
-----END PGP SIGNATURE-----


Closed
?