glibc shadows gcc's C++ headers

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Robin Templeton
Owner
unassigned
Submitted by
Robin Templeton
Severity
normal
R
R
Robin Templeton wrote on 19 Sep 2018 02:32
(address . bug-guix@gnu.org)
87efdquy26.fsf@terpri.org
When compiling C++ programs, glibc's include directory takes precedence
over gcc's for standard C headers like math.h, but glibc's headers
aren't completely compatible with C++. For example, isnan from math.h is
supposed to be a function, but glibc defines it as a macro.

This program demonstrates the problem:

#include <math.h>
int main(void) { int isnan(0); return isnan; }

It works as expected when gcc's built-in C++ headers are used, but not
if glibc is installed:

% guix environment --pure --ad-hoc gcc -- g++ -E isnan.cpp | tail -n1
int main (void) { int isnan (0); return isnan; }
% guix environment --pure --ad-hoc gcc glibc -- g++ -E isnan.cpp | tail -n1
int main (void) { int __builtin_isnan (0); return isnan; }

As a temporary workaround, I'm using the following package as a
replacement for glibc, to keep the glibc headers out of $CPATH. If it's
installed along with gcc, ld-wrapper and binutils, the test program
compiles without errors.

(use-modules (guix) (gnu))
(use-package-modules base)
(package
(inherit glibc)
(name "my-glibc")
(arguments
(substitute-keyword-arguments (package-arguments glibc)
((#:phases phases)
`(modify-phases ,phases
(add-after 'install 'move-include
(lambda _
(rename-file (string-append %output "/include")
(string-append %output "/include-glibc"))
#t)))))))
M
M
Maxim Cournoyer wrote on 9 Mar 2021 22:35
(name . Robin Templeton)(address . robin@igalia.com)(address . 32767-done@debbugs.gnu.org)
87h7lkui20.fsf@gmail.com
Hello,

Robin Templeton <robin@igalia.com> writes:

Toggle quote (38 lines)
> When compiling C++ programs, glibc's include directory takes precedence
> over gcc's for standard C headers like math.h, but glibc's headers
> aren't completely compatible with C++. For example, isnan from math.h is
> supposed to be a function, but glibc defines it as a macro.
>
> This program demonstrates the problem:
>
> #include <math.h>
> int main(void) { int isnan(0); return isnan; }
>
> It works as expected when gcc's built-in C++ headers are used, but not
> if glibc is installed:
>
> % guix environment --pure --ad-hoc gcc -- g++ -E isnan.cpp | tail -n1
> int main (void) { int isnan (0); return isnan; }
> % guix environment --pure --ad-hoc gcc glibc -- g++ -E isnan.cpp | tail -n1
> int main (void) { int __builtin_isnan (0); return isnan; }
>
> As a temporary workaround, I'm using the following package as a
> replacement for glibc, to keep the glibc headers out of $CPATH. If it's
> installed along with gcc, ld-wrapper and binutils, the test program
> compiles without errors.
>
> (use-modules (guix) (gnu))
> (use-package-modules base)
> (package
> (inherit glibc)
> (name "my-glibc")
> (arguments
> (substitute-keyword-arguments (package-arguments glibc)
> ((#:phases phases)
> `(modify-phases ,phases
> (add-after 'install 'move-include
> (lambda _
> (rename-file (string-append %output "/include")
> (string-append %output "/include-glibc"))
> #t)))))))

Thanks for the report. Nowadays the recommended way to install the
GCC-based toolchain is to use the 'gcc-toolchain' package. The 'gcc'
package is now even made hidden in Guix, which doesn't seem to have this
particular issue:

$ guix environment --pure --ad-hoc gcc-toolchain -- g++ -E /tmp/isnan.cpp | tail -n1
int main(void) { int isnan(0); return isnan; }

$ guix environment --pure --ad-hoc gcc-toolchain glibc -- g++ -E /tmp/isnan.cpp | tail -n1
int main(void) { int isnan(0); return isnan; }

I'm closing this issue, but feel free to open a fresh one if you still
encounter problems.

Thank you,

Maxim
Closed
?