[PATCH 1/5] gnu: Add go-github-com-docker-go-connections.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Rouby Pierre-Antoine
Owner
unassigned
Submitted by
Rouby Pierre-Antoine
Severity
normal
R
R
Rouby Pierre-Antoine wrote on 10 Jul 2018 18:02
(address . guix-patches@gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180710160228.30483-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-docker-go-connections): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 41d2e5ce1..609a0a8b1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1841,3 +1841,28 @@ deliver content")
store, and deliver content. It's containe Docker Registry 2.0 and libraries
to interacting with distribution components.")
(license license:asl2.0))))
+
+(define-public go-github-com-docker-go-connections
+ (let ((commit "3ede32e2033de7505e6500d6c868c2b9ed9f169d")
+ (revision "0"))
+ (package
+ (name "go-github-com-docker-go-connections")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-connections.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v1pkr8apwmhyzbjfriwdrs1ihlk6pw7izm57r24mf9jdmg3fyb0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/docker/go-connections"))
+ (home-page "https://github.com/docker/go-connections")
+ (synopsis "Provides common package to work with network connections.")
+ (description "This package provides common package to work with network
+connections in Go langage.")
+ (license license:asl2.0))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 10 Jul 2018 18:06
[PATCH 2/5] gnu: Add go-github-com-docker-machine.
(address . 32113@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180710160609.30540-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-docker-machine): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 609a0a8b1..515d99785 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1866,3 +1866,27 @@ to interacting with distribution components.")
(description "This package provides common package to work with network
connections in Go langage.")
(license license:asl2.0))))
+
+(define-public go-github-com-docker-machine
+ (let ((commit "7b7a141da84480342357c51838be142bf183b095")
+ (revision "0"))
+ (package
+ (name "go-github-com-docker-machine")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/machine.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bavk0lvs462yh0lnmnxi9psi5qv1x3nvzmd2b0drsahlp1gxi8s"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/docker/machine"))
+ (home-page "https://github.com/docker/machine")
+ (synopsis "Machine management for a container-centric world")
+ (description "Lets you create Docker hosts on your computer.")
+ (license license:asl2.0))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 10 Jul 2018 18:06
[PATCH 3/5] gnu: Add go-github-com-gorhill-cronexpr.
(address . 32113@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180710160609.30540-2-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-gorhill-cronexpr): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 515d99785..588fb8572 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1890,3 +1890,29 @@ connections in Go langage.")
(synopsis "Machine management for a container-centric world")
(description "Lets you create Docker hosts on your computer.")
(license license:asl2.0))))
+
+(define-public go-github-com-gorhill-cronexpr
+ (let ((commit "f0984319b44273e83de132089ae42b1810f4933b")
+ (revision "0"))
+ (package
+ (name "go-github-com-gorhill-cronexpr")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorhill/cronexpr.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dphhhqy3i7265znv3m8n57l80dmaq6z4hsj5kgd87qd19z8x0l2"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorhill/cronexpr"))
+ (home-page "https://github.com/gorhill/cronexpr")
+ (synopsis "Cron expression parser in Go language")
+ (description "This package is cron expression parser in Go language.
+Given a cron expression and a time stamp.")
+ (license (list license:gpl3+
+ license:asl2.0)))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 10 Jul 2018 18:06
[PATCH 4/5] gnu: Add go-gopkg-in-check-v1.
(address . 32113@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180710160609.30540-3-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-gopkg-in-check-v1): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 588fb8572..e6ef7c8d9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1916,3 +1916,27 @@ connections in Go langage.")
Given a cron expression and a time stamp.")
(license (list license:gpl3+
license:asl2.0)))))
+
+(define-public go-gopkg-in-check-v1
+ (let ((commit "20d25e2804050c1cd24a7eea1e7a6447dd0e74ec")
+ (revision "0"))
+ (package
+ (name "go-gopkg-in-check-v1")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-check/check")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0k1m83ji9l1a7ng8a7v40psbymxasmssbrrhpdv2wl4rhs0nc3np"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/check.v1"))
+ (home-page "https://gopkg.in/check.v1")
+ (synopsis "Rich testing for Go language")
+ (description "This package is rich test library for Go language.")
+ (license license:asl2.0))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 10 Jul 2018 18:06
[PATCH 5/5] gnu: Add go-gopkg-in-yaml-v2.
(address . 32113@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180710160609.30540-4-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-gopkg-in-yaml-v2): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e6ef7c8d9..6d03d6132 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1940,3 +1940,30 @@ Given a cron expression and a time stamp.")
(synopsis "Rich testing for Go language")
(description "This package is rich test library for Go language.")
(license license:asl2.0))))
+
+(define-public go-gopkg-in-yaml-v2
+ (let ((commit "14227de293ca979cf205cd88769fe71ed96a97e2")
+ (revision "0"))
+ (package
+ (name "go-gopkg-in-yaml-v2")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/yaml.v2.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "038hnrjcnjygyi3qidfrkpkakis82qg381sr495d2s40g2dwlzah"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/yaml.v2"))
+ (native-inputs
+ `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+ (home-page "https://gopkg.in/yaml.v2")
+ (synopsis "YAML support for the Go language.")
+ (description "This package is library for encode and decode YAML values
+in Go language.")
+ (license license:asl2.0))))
--
2.17.0
L
L
Ludovic Courtès wrote on 12 Jul 2018 23:58
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 32113-done@debbugs.gnu.org)
87sh4oqfps.fsf@gnu.org
Hello,

I tweaked the synopses and descriptions and applied all fives patches.

Thank you!

Ludo’.
Closed
?