[PATCH 1/4] gnu: Add go-github-com-sirupsen-logrus.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Rouby Pierre-Antoine
Owner
unassigned
Submitted by
Rouby Pierre-Antoine
Severity
normal
R
R
Rouby Pierre-Antoine wrote on 18 Jun 2018 17:15
(address . guix-patches@gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180618151543.2921-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-sirupsen-logrus): New variable.
---
gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6c21181da..3d1fc5b6d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1703,3 +1703,37 @@ incoming requests to their respective handler.")
"Pflag is library to replace Go's flag package, implementing
POSIX/GNU-style --flags.")
(license license:bsd-3))))
+
+(define-public go-github-com-sirupsen-logrus
+ (let ((commit "4b6ea7319e214d98c938f12692336f7ca9348d6b")
+ (revision "0"))
+ (package
+ (name "go-github-com-sirupsen-logrus")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sirupsen/logrus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06wnl1dkkib2zpm31aavk5c4290s64h2ss68nl1vgcbxzsfbxjaq"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-golang-org-x-crypto-ssh-terminal"
+ ,go-golang-org-x-crypto-ssh-terminal)
+ ("go-github-com-stretchr-testify"
+ ,go-github-com-stretchr-testify)
+ ("go-golang-org-x-sys-unix"
+ ,go-golang-org-x-sys-unix)))
+ (arguments
+ '(#:tests? #f ;FIXME missing dependencies
+ #:import-path "github.com/sirupsen/logrus"))
+ (home-page "https://github.com/sirupsen/logrus")
+ (synopsis "This packages is structured, pluggable logging for Go")
+ (description
+ "Logrus is a structured logger for Go, completely API compatible with
+the standard library logger.")
+ (license license:expat))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 18 Jun 2018 17:18
[PATCH 2/4] gnu: Add go-github-com-kardianos-osext.
(address . 31881@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180618151821.2972-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-kardianos-osext): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3d1fc5b6d..5bda79dc9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1737,3 +1737,29 @@ POSIX/GNU-style --flags.")
"Logrus is a structured logger for Go, completely API compatible with
the standard library logger.")
(license license:expat))))
+
+(define-public go-github-com-kardianos-osext
+ (let ((commit "c2c54e542fb797ad986b31721e1baedf214ca413")
+ (revision "0"))
+ (package
+ (name "go-github-com-kardianos-osext")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kardianos/osext.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02vmjhkx90601l5fym7c3r4d44b88h3cign86nz4yy6j8qqxvz3h"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/kardianos/osext"))
+ (home-page
+ "https://github.com/kardianos/osext")
+ (synopsis "This package is an extensions to the standard os package")
+ (description
+ "Osext is an extensions to the standard os package for Golang.")
+ (license license:bsd-3))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 18 Jun 2018 17:18
[PATCH 3/4] gnu: Add go-github-com-ayufan-golang-kardianos-service.
(address . 31881@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180618151821.2972-2-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-ayufan-golang-kardianos-service):
New variable.
---
gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5bda79dc9..f12c2b07a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1763,3 +1763,36 @@ the standard library logger.")
(description
"Osext is an extensions to the standard os package for Golang.")
(license license:bsd-3))))
+
+(define-public go-github-com-ayufan-golang-kardianos-service
+ (let ((commit "0c8eb6d8fff2e2fb884a7bfd23e183fb63c0eff3")
+ (revision "0"))
+ (package
+ (name "go-github-com-ayufan-golang-kardianos-service")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/ayufan/golang-kardianos-service.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x0cn7l5gda2khsfypix7adxd5yqighzn04mxjw6hc4ayrh7his5"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-kardianos-osext"
+ ,go-github-com-kardianos-osext)))
+ (arguments
+ '(#:tests? #f ;FIXME tests fail: Service is not running.
+ #:import-path
+ "github.com/ayufan/golang-kardianos-service"))
+ (home-page
+ "https://github.com/ayufan/golang-kardianos-service")
+ (synopsis "This package is golang library to run program as a service")
+ (description
+ "Golang kardinos service is golang library to run go program as a
+service.")
+ (license license:zlib))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 18 Jun 2018 17:18
[PATCH 4/4] gnu: Add go-github-com-docker-distribution.
(address . 31881@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180618151821.2972-3-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-docker-distribution): New variable.
---
gnu/packages/golang.scm | 45 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f12c2b07a..41d2e5ce1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1796,3 +1796,48 @@ the standard library logger.")
"Golang kardinos service is golang library to run go program as a
service.")
(license license:zlib))))
+
+(define-public go-github-com-docker-distribution
+ (let ((commit "325b0804fef3a66309d962357aac3c2ce3f4d329")
+ (revision "0"))
+ (package
+ (name "go-github-com-docker-distribution")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/distribution")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yg2zrikn3vkvkx5mn51p6bfjk840qdkn7ahhhvvcsc8mpigrjc6"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-golang-org-x-sys-unix"
+ ,go-golang-org-x-sys-unix)
+ ("go-github-com-sirupsen-logrus"
+ ,go-github-com-sirupsen-logrus)
+ ("go-golang-org-x-crypto-ssh-terminal"
+ ,go-golang-org-x-crypto-ssh-terminal)))
+ (arguments
+ '(#:import-path "github.com/docker/distribution"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (assoc-ref outputs "out")
+ ".*\\.gz$"))
+ #t)))))
+ (home-page
+ "https://github.com/docker/distribution")
+ (synopsis "This package is Docker toolset to pack, ship, store, and
+deliver content")
+ (description "Docker Distribution is Docker toolset to pack, ship,
+store, and deliver content. It's containe Docker Registry 2.0 and libraries
+to interacting with distribution components.")
+ (license license:asl2.0))))
--
2.17.0
L
L
Leo Famulari wrote on 18 Jun 2018 18:12
Re: [bug#31881] [PATCH 1/4] gnu: Add go-github-com-sirupsen-logrus.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31881@debbugs.gnu.org)
20180618161248.GB30565@jasmine.lan
On Mon, Jun 18, 2018 at 05:15:43PM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-sirupsen-logrus): New variable.

Thank you for this patch series!

Currently, it doesn't apply to the Guix git master branch. Can you
rebase the patches on the master branch and send them again?

Thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsn2gAACgkQJkb6MLrK
fwgBvhAAs8W3WYgGOliiGMs3FTTWnRHiqalZtWNQoizyFRsUGPo+A/4NQSOr1x+P
tJa8tqUOzBYtArmRkF8Ey3OLAW1uShNt6QtQ+aJaxOIsOXEQw2/iZ4Suya3BonDQ
GWdJIgbi21UgnSJQZ3WE5mHMaW1Nc5PfnecQeeSpC9uj98CUgIgkocvVPI6DREZX
AXnC52kpxgz6Y9pYWTf7NH90mhSMw8Zj041qT2MBLqh1gLVS2uBVC28iMvRvHQ5C
e+MJWcdZjRL0Msr5rCi1HW7k8XtznwxnWzYHC6xsI994S6OJ23EeQ9Pkdp3ygdT6
f7CartczW7uMN0uqi3aMq/R/bmntmTmzU74SQABP5i4omwbp9dtJCOVIF0jNh8yJ
wVtLgAdghkLGxWRd7TDFU0lOlrHkCXeiRLJSCaA/GkHNpg2F+aJiMU/4NUJKPX0Y
NehUd0jdudh9wEubTlYOkZZsVlxXT8+1iFoKjD/GUNgjP6wqpJanT7m+lALEFEGO
ziWddlLyyUDBKudli5qEXlDaGNZdLlu/Qrx/lvaMvgsez6LfwG9R+BjDNPg07for
hEvODNFMwQONWnXFGpMgOz2bxwKaEIFC/C7bFjUE0s2OQbD5oM21561UWRjO8lhF
F6dd1ZkgW+jGZYXmDCF7edbKR5kW2Q5PZsPSsb0D5Jqn8s1tw28=
=smPw
-----END PGP SIGNATURE-----


R
R
Rouby Pierre-Antoine wrote on 19 Jun 2018 10:43
[PATCH 1/4] gnu: Add go-github-com-sirupsen-logrus.
(address . leo@famulari.name)
20180619084333.8993-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-sirupsen-logrus): New variable.
---
gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a83cdcde8..1dcf12d90 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1702,3 +1702,37 @@ with the
@uref{https://www.gnu.org/software/libc/manual/html_node/Argument-Syntax.html,
GNU extensions} to the POSIX recommendations for command-line options.")
(license license:bsd-3))))
+
+(define-public go-github-com-sirupsen-logrus
+ (let ((commit "4b6ea7319e214d98c938f12692336f7ca9348d6b")
+ (revision "0"))
+ (package
+ (name "go-github-com-sirupsen-logrus")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sirupsen/logrus.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06wnl1dkkib2zpm31aavk5c4290s64h2ss68nl1vgcbxzsfbxjaq"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-golang-org-x-crypto-ssh-terminal"
+ ,go-golang-org-x-crypto-ssh-terminal)
+ ("go-github-com-stretchr-testify"
+ ,go-github-com-stretchr-testify)
+ ("go-golang-org-x-sys-unix"
+ ,go-golang-org-x-sys-unix)))
+ (arguments
+ '(#:tests? #f ;FIXME missing dependencies
+ #:import-path "github.com/sirupsen/logrus"))
+ (home-page "https://github.com/sirupsen/logrus")
+ (synopsis "This packages is structured, pluggable logging for Go")
+ (description
+ "Logrus is a structured logger for Go, completely API compatible with
+the standard library logger.")
+ (license license:expat))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 19 Jun 2018 10:43
[PATCH 2/4] gnu: Add go-github-com-kardianos-osext.
(address . leo@famulari.name)
20180619084333.8993-2-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-kardianos-osext): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1dcf12d90..bef450eb6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1736,3 +1736,29 @@ GNU extensions} to the POSIX recommendations for command-line options.")
"Logrus is a structured logger for Go, completely API compatible with
the standard library logger.")
(license license:expat))))
+
+(define-public go-github-com-kardianos-osext
+ (let ((commit "c2c54e542fb797ad986b31721e1baedf214ca413")
+ (revision "0"))
+ (package
+ (name "go-github-com-kardianos-osext")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kardianos/osext.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02vmjhkx90601l5fym7c3r4d44b88h3cign86nz4yy6j8qqxvz3h"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/kardianos/osext"))
+ (home-page
+ "https://github.com/kardianos/osext")
+ (synopsis "This package is an extensions to the standard os package")
+ (description
+ "Osext is an extensions to the standard os package for Golang.")
+ (license license:bsd-3))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 19 Jun 2018 10:43
[PATCH 3/4] gnu: Add go-github-com-ayufan-golang-kardianos-service.
(address . leo@famulari.name)
20180619084333.8993-3-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-ayufan-golang-kardianos-service):
New variable.
---
gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bef450eb6..be7b0d3f3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1762,3 +1762,36 @@ the standard library logger.")
(description
"Osext is an extensions to the standard os package for Golang.")
(license license:bsd-3))))
+
+(define-public go-github-com-ayufan-golang-kardianos-service
+ (let ((commit "0c8eb6d8fff2e2fb884a7bfd23e183fb63c0eff3")
+ (revision "0"))
+ (package
+ (name "go-github-com-ayufan-golang-kardianos-service")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/ayufan/golang-kardianos-service.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x0cn7l5gda2khsfypix7adxd5yqighzn04mxjw6hc4ayrh7his5"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-kardianos-osext"
+ ,go-github-com-kardianos-osext)))
+ (arguments
+ '(#:tests? #f ;FIXME tests fail: Service is not running.
+ #:import-path
+ "github.com/ayufan/golang-kardianos-service"))
+ (home-page
+ "https://github.com/ayufan/golang-kardianos-service")
+ (synopsis "This package is golang library to run program as a service")
+ (description
+ "Golang kardinos service is golang library to run go program as a
+service.")
+ (license license:zlib))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 19 Jun 2018 10:43
[PATCH 4/4] gnu: Add go-github-com-docker-distribution.
(address . leo@famulari.name)
20180619084333.8993-4-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-docker-distribution): New variable.
---
gnu/packages/golang.scm | 45 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index be7b0d3f3..89476411b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1795,3 +1795,48 @@ the standard library logger.")
"Golang kardinos service is golang library to run go program as a
service.")
(license license:zlib))))
+
+(define-public go-github-com-docker-distribution
+ (let ((commit "325b0804fef3a66309d962357aac3c2ce3f4d329")
+ (revision "0"))
+ (package
+ (name "go-github-com-docker-distribution")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/distribution")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yg2zrikn3vkvkx5mn51p6bfjk840qdkn7ahhhvvcsc8mpigrjc6"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-golang-org-x-sys-unix"
+ ,go-golang-org-x-sys-unix)
+ ("go-github-com-sirupsen-logrus"
+ ,go-github-com-sirupsen-logrus)
+ ("go-golang-org-x-crypto-ssh-terminal"
+ ,go-golang-org-x-crypto-ssh-terminal)))
+ (arguments
+ '(#:import-path "github.com/docker/distribution"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (assoc-ref outputs "out")
+ ".*\\.gz$"))
+ #t)))))
+ (home-page
+ "https://github.com/docker/distribution")
+ (synopsis "This package is Docker toolset to pack, ship, store, and
+deliver content")
+ (description "Docker Distribution is Docker toolset to pack, ship,
+store, and deliver content. It's containe Docker Registry 2.0 and libraries
+to interacting with distribution components.")
+ (license license:asl2.0))))
--
2.17.0
L
L
Leo Famulari wrote on 20 Jun 2018 18:56
Re: [PATCH 1/4] gnu: Add go-github-com-sirupsen-logrus.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31881@debbugs.gnu.org)
20180620165614.GA1240@jasmine.lan
On Tue, Jun 19, 2018 at 10:43:30AM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-sirupsen-logrus): New variable.

Thanks! Pushed as 7427b2c6c1e5495d551375edf0c4177ab56179d7
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsqhy4ACgkQJkb6MLrK
fwgCww//WiC1IQWJZt2jJSPLBouLqw4Hn7yDUnoszqh8qahYGClH9F5RHySHzThg
kn+udwscmLBsxkQvwuQvTOE+djUBUvc32GrCMiUFUSe73AphWWE9udy/O+89nDcb
O/7KW7L2p7X2e9jqyk1LVuUKZLEyewqZLhxPhL1ghtttk7bVaAsc2QoXVxpk0weM
MRRz+hEMb3AGE6MB4BKakE8cE2HRVlWDBiQYKg2FgM9ZQXxB6l+zYUYo57J7prtc
n3RLzoEwr6dqxXVZd8TVwBXGqm2aRTiOjuAtYtc6BUdMV89GB3BwQdsj3mV7CgiT
MBQMVKAVL+htlZA12yqOBRIK9TeJy6U0fceb3Tq4UcZaIdM8CveGXGFhOz/o9lQP
RZAS0VflbnJRFuIDitlBN2x27I0BofCgWvkH2rYL0kRxvQO4OmUl0sHs/JyXUgcd
XrmsRjO3V5EVAnkdufwICKPUcKsQf4vdtt24Cg+6nDp3PKO6DUaskKrupTrbWi4K
3QdTLoqGyru3NKkCTgl5ltaiSE2Zf9DeKlLEmQdWeLP7IZIj/ppMPBPxcxnSmG2s
dYzWh7kUn3tixTatdbvAH2EQblZFWCm7encbpqrdw9zQyDTc25zYjzt9/lQnd4af
QhT7TQheJ04/d/TvhT0G/ods+krQGlHnM5HrGW8WhLeVJfoOxbw=
=xOsK
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 20 Jun 2018 18:56
Re: [PATCH 2/4] gnu: Add go-github-com-kardianos-osext.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31881@debbugs.gnu.org)
20180620165644.GB1240@jasmine.lan
On Tue, Jun 19, 2018 at 10:43:31AM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-kardianos-osext): New variable.

We already have this package. I moved it from the Syncthing module to
the Golang module.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsqh0wACgkQJkb6MLrK
fwiyKA//YPPZUAxnSpI8DjNVXhJFCu7/H4UA9hgrPYpXUDauH3uLxTMtj8z8nPGU
D1FUiSF1U1o5HurHKOxoMLGL5cWUb3oWrSqwNm0JowV2mjyUeaRKiDDUBWd0thga
1lkeAYDUofPpq7HRWxhXakR66JMflbfLc0AAwcxyrkdfb6EgFMxgqs+cM8wwiwrX
Ye1kgBnZ/B0Lox6XDx1pGd+/F+wVHr9ugvL23qzV5CuMqUJ+eQiW3/baivIrZsQg
2yGN7lCADkBolnl1Y//JM8wpmoJJ1J3Vb567hGCo/s3BB49daooKICHlT4//U1S6
mcjaVtTITWhPPJAgnIzbv3ZkuvMM52ncSF+Lgzs3QDY72p/cX2IwAHDIRi3rhT0F
OeULiqS2HnwnfmK7u1sV4c5bRAQ0zENBbF8FeOyKQDDbdLa37QMFj31LLoak66iT
UY+88HnM//QnWrRwO9S7xIB30J2O+7dT6fuKe1xKtzGq1pTBA7NF+rmJldJlVdNZ
Zxpte5BjeV+tKZnztctNOEMqVQBKV9zIJtyVtsN2loeJkIUBF9J1EXfSJBawJWgx
eLkEaCKbeCV7infXVITjSgcQs9d+QVOpk2UFo4th23ktbSno2/Liu1oHaToo6lCi
tINxaQRF+ieSYAqvD4TndBkFDYfngQy1vip05ZPxvg4uFOD84Wo=
=vJme
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 20 Jun 2018 18:57
Re: [PATCH 3/4] gnu: Add go-github-com-ayufan-golang-kardianos-service.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31881@debbugs.gnu.org)
20180620165746.GC1240@jasmine.lan
On Tue, Jun 19, 2018 at 10:43:32AM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (3 lines)
> * gnu/packages/golang.scm (go-github-com-ayufan-golang-kardianos-service):
> New variable.

Thanks! Pushed as aed4944d51669089620d8fe13b2e63c59e722b79.

By the way, this package is a fork of
maintenance.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsqh4oACgkQJkb6MLrK
fwhyIQ//ZSTj16jxJFAIWT29D7VFIBOECNH3h/X4n95PThdEz7g5e/h5WD4DfpII
Kh2bAif6I/a76GyxSyXzcYtp2ynkQl/fGUqA+kl0wmp/WBSHYgX6ncd0yOUyoI54
rSEaH6NjSVsUINldVnVm0v59uWrsd1OHo5PKWuNZv67BljGoXdo+wCqlW/NbYjTL
e7PUm3mEg0uNXnwBMRW7iOZPu9K36jhcUO3gyEFsm4l8G78cThHRLiLU1CBw4uzy
KawpcHfTGZ2bfUdhNqBdPSlgGt5A4RS5H6bcf28pM0bmRrac5C92qAhYntRg8oA3
3nbh3XtJ2R4GY84yml3Lqw+0kPG8CoZJzz1v1s30QLGVdNEv4nXNlY5FZZ8eeWn1
/e/dymduSKsrZkaCJbT5CFrZvGit+cjI3k1KlAwHSo1wW8WG5UMzZup5BaUB4NHv
ZiIApISIv0m1C5zYsipmP02aZ6GpvLGltZI96uq+t6mMqKc8iO+fsYXoe6jfgVKC
CmUpotRuGTB6e+GQabPPzIbAw9ahFUenUEm/vJaAI9cz4QOOM2XDZZvmeHd4UxQJ
vXgKlLtQljIQVN6UZYYgK97QYoVwa6j44J022+rFIJWB2sWcUd/bocJjZkmoTMfP
TaL5y70hgGEVIOzV/p4MG09fx0KbvnmWEDUhqFI7SA52Ohc2Qmg=
=DReL
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 20 Jun 2018 19:00
Re: [PATCH 4/4] gnu: Add go-github-com-docker-distribution.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31881@debbugs.gnu.org)
20180620170048.GD1240@jasmine.lan
On Tue, Jun 19, 2018 at 10:43:33AM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (9 lines)
> * gnu/packages/golang.scm (go-github-com-docker-distribution): New variable.

> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/docker/distribution")
> + (commit commit)))

This bundles its entire dependency graph, including the logrus module
you just packaged, and some other things we have packaged:


I think it's okay to add the package with the bundled code if everything
is freely licensed. Can you confirm that it is?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsqiEAACgkQJkb6MLrK
fwgnrg/7BhIR4rB8MFG5i5lhR2TZGKM6k8r34f4PJoF0rQxDXC0BGgftlSk9F5w9
yMMra4Di3RwcTh4mqwT/hvzblQiGZfRAX9s1ce8MIWD7qqHUKrUQuetBOyv4iu0n
mh7ABn8mUanP9Ipcrj2Wveh02X7BQs5uvURTZ7YeVtwCP0QV4WiLRfcYt+YJ0WwK
ZhGuuU7rT0MH+Ti9cRlPPbwHjSiB+rz/kR1NquJvNZf6fykGm5ur7jeO9JTMU0Sa
89JO33r88o4hiOJP9cXcesQ/rKks0J9Q/rdsyFM3/QLQvTFCRt21G72trx3nOFk9
QdAksT80FsDcoFsSKhLtujpnA6MfTVSnIn33Q72+mSa1adFFXwPhjZtwrCCVs8YZ
XW5fZUgQXuCrGH2bFMVDuTm76TFMAiu7s28OxQq5zACpQcJbXWWScqJB0C4mLtgz
EszKFyMIREn9ixuF/fDCfixL2U1/yt4FhWKw2xfd4CluJoRUrF6ODmDgi8FZvZbF
uv51ld3KUPgI3LJ6MQwvxaft23VfGV+uobBf+hoSP1EOk3CujyJFBap5kukUWiZu
l4seKtl96U8luk4q2uQS7p/npRFUsn4wcDyIAzttAJdCidJd+MupFUSz9vy1Dp18
CrxD8B0YNWS4Ym5Gl8KpUnVh5xOy2Wf8bUDChlxByUM4sS8ILEY=
=VgPx
-----END PGP SIGNATURE-----


P
P
Pierre-Antoine Rouby wrote on 26 Jun 2018 17:20
(name . Leo Famulari)(address . leo@famulari.name)(address . 31881@debbugs.gnu.org)
1040680639.2490239.1530026409131.JavaMail.zimbra@inria.fr
Hi Leo,

Toggle quote (11 lines)
> From: "Leo Famulari" <leo@famulari.name>
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/docker/distribution")
>> + (commit commit)))
>
> This bundles its entire dependency graph, including the logrus module
> you just packaged, and some other things we have packaged:

I'm not sure vendor version is the same as package version. I have the
impression some Go package have no tag or CHANGELOG, so I'm not sure for
compatibility. Without explicit version number I thinks is more sure to
use the vendor version.

Toggle quote (3 lines)
> I think it's okay to add the package with the bundled code if everything
> is freely licensed. Can you confirm that it is?

Yes, everything is free.
L
L
Ludovic Courtès wrote on 7 Jul 2018 18:08
Re: [bug#31881] [PATCH 4/4] gnu: Add go-github-com-docker-distribution.
(name . Pierre-Antoine Rouby)(address . pierre-antoine.rouby@inria.fr)
87fu0v3u66.fsf@gnu.org
Hello!

Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr> skribis:

Toggle quote (21 lines)
>> From: "Leo Famulari" <leo@famulari.name>
>>> + (source
>>> + (origin
>>> + (method git-fetch)
>>> + (uri (git-reference
>>> + (url "https://github.com/docker/distribution")
>>> + (commit commit)))
>>
>> This bundles its entire dependency graph, including the logrus module
>> you just packaged, and some other things we have packaged:
>
> I'm not sure vendor version is the same as package version. I have the
> impression some Go package have no tag or CHANGELOG, so I'm not sure for
> compatibility. Without explicit version number I thinks is more sure to
> use the vendor version.
>
>> I think it's okay to add the package with the bundled code if everything
>> is freely licensed. Can you confirm that it is?
>
> Yes, everything is free.

Based on this I went ahead and applied it, but I added a FIXME about
bundling.

P-A, could you look into unbundling at least those that are already
packaged?

Thank you!

Ludo’.
Closed
?