[PATCH 1/6] gnu: Add go-github-com-urfave-cli.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Rouby Pierre-Antoine
Owner
unassigned
Submitted by
Rouby Pierre-Antoine
Severity
normal
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 16:59
(address . guix-patches@gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528145939.24256-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-urfave-cli): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ba180d1b3..e7fcfa379 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1472,3 +1472,30 @@ Features include:
(description "This package is atomic boolean library for Go code,
optimized for performance yet simple to use.")
(license license:expat))))
+
+(define-public go-github-com-urfave-cli
+ (let ((commit "cfb38830724cc34fedffe9a2a29fb54fa9169cd1")
+ (revision "0"))
+ (package
+ (name "go-github-com-urfave-cli")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/urfave/cli.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y6f4sbzkiiwrxbl15biivj8c7qwxnvm3zl2dd3mw4wzg4x10ygj"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/urfave/cli"))
+ (home-page "https://github.com/urfave/cli")
+ (synopsis "This package is library for building command line apps in
+Go")
+ (description "A simple, fast, and fun package for building command line
+apps in GO. The goal is to enable developers to write fast and distributable
+command line applications in an expressive way.")
+ (license license:expat))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 17:01
[PATCH 2/6] gnu: Add go-github-com-blang-semver.
(address . 31625@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528150157.24310-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-blang-semver): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e7fcfa379..d232e3040 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1499,3 +1499,30 @@ Go")
apps in GO. The goal is to enable developers to write fast and distributable
command line applications in an expressive way.")
(license license:expat))))
+
+(define-public go-github-com-blang-semver
+ (let ((commit "60ec3488bfea7cca02b021d106d9911120d25fe9")
+ (revision "0"))
+ (package
+ (name "go-github-com-blang-semver")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blang/semver.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19pli07y5592g4dyjyj0jq5rn548vc3fz0qg3624vm1j5828p1c2"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/blang/semver"))
+ (home-page "https://github.com/blang/semver")
+ (synopsis "This package is a Semantic Versioning library written in
+golang")
+ (description "Semver is library form Semantic Versioning in written
+golang.")
+ (license license:expat))))
+
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 17:02
[PATCH 3/6] gnu: Add go-github-com-emicklei-go-restful.
(address . 31625@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528150240.24400-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-emicklei-go-restful): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d232e3040..ee460c030 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1526,3 +1526,27 @@ golang")
golang.")
(license license:expat))))
+(define-public go-github-com-emicklei-go-restful
+ (let ((commit "89ef8af493ab468a45a42bb0d89a06fccdd2fb22")
+ (revision "0"))
+ (package
+ (name "go-github-com-emicklei-go-restful")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emicklei/go-restful.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rrlfcfq80fkxifpih6bq31vavb5mf4530xz51pp9pq1mn2fzjfh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emicklei/go-restful"))
+ (home-page "https://github.com/emicklei/go-restful")
+ (synopsis "Package for building rest-style web services using Golang")
+ (description "Rest asks developpers to use @code{http} methods
+explicitly and in a way that's consistent with the protocol definition.")
+ (license license:expat))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 17:03
[PATCH 4/6] gnu: Add go-github-com-google-cadvisor.
(address . 31625@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528150309.24444-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-google-cadvisor): New varaible.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ee460c030..81a494584 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1550,3 +1550,29 @@ golang.")
(description "Rest asks developpers to use @code{http} methods
explicitly and in a way that's consistent with the protocol definition.")
(license license:expat))))
+
+(define-public go-github-com-google-cadvisor
+ (let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-cadvisor")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/cadvisor.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w8p345z5j0gk3yiq5ah0znd5lfh348p2s624k5r10drz04p3f55"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/cadvisor"))
+ (home-page "https://github.com/google/cadvisor")
+ (synopsis "This package is resource usage analyzes for running
+containers")
+ (description "Cadvisor provides information about the resource usage and
+preformance characteristics of running contrainers.")
+ (license license:asl2.0))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 17:03
[PATCH 5/6] gnu: Add go-github-com-google-gofuzz.
(address . 31625@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528150339.24487-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-google-gofuzz): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 81a494584..6ace45890 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1576,3 +1576,28 @@ containers")
(description "Cadvisor provides information about the resource usage and
preformance characteristics of running contrainers.")
(license license:asl2.0))))
+
+(define-public go-github-com-google-gofuzz
+ (let ((commit "fd52762d25a41827db7ef64c43756fd4b9f7e382")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-gofuzz")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gofuzz.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yxmmr73h0lq7ryf3q9a7pcm2x5xrg4d5bxkq8n5pxwxwyq26kw8"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/gofuzz"))
+ (home-page "https://github.com/google/gofuzz")
+ (synopsis "This package is fuzz testing library for go")
+ (description "Gofuzz is a library for populationg go objects with random
+values.")
+ (license license:asl2.0))))
--
2.17.0
R
R
Rouby Pierre-Antoine wrote on 28 May 2018 17:03
[PATCH 6/6] gnu: Add go-github-com-gorilla-context.
(address . 31625@debbugs.gnu.org)(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)
20180528150356.24530-1-pierre-antoine.rouby@inria.fr
* gnu/packages/golang.scm (go-github-com-gorilla-context): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ace45890..cad6e5a60 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1601,3 +1601,28 @@ preformance characteristics of running contrainers.")
(description "Gofuzz is a library for populationg go objects with random
values.")
(license license:asl2.0))))
+
+(define-public go-github-com-gorilla-context
+ (let ((commit "08b5f424b9271eedf6f9f0ce86cb9396ed337a42")
+ (revision "0"))
+ (package
+ (name "go-github-com-gorilla-context")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/context.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03p4hn87vcmfih0p9w663qbx9lpsf7i7j3lc7yl7n84la3yz63m4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/context"))
+ (home-page "https://github.com/gorilla/context")
+ (synopsis "This packages is registry for request variables")
+ (description "Gorilla/context is a general purpose registry for global
+request variables.")
+ (license license:bsd-3))))
--
2.17.0
L
L
Leo Famulari wrote on 30 May 2018 00:40
Re: [bug#31625] [PATCH 1/6] gnu: Add go-github-com-urfave-cli.
(name . Rouby Pierre-Antoine)(address . pierre-antoine.rouby@inria.fr)(address . 31625-done@debbugs.gnu.org)
20180529224022.GA13258@jasmine.lan
On Mon, May 28, 2018 at 04:59:39PM +0200, Rouby Pierre-Antoine wrote:
Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-urfave-cli): New variable.

Thanks! I edited the synopses and descriptions and pushed the whole
series as 9cf879a5739eec505119e2dfca59490d81f5ac99.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlsN1tYACgkQJkb6MLrK
fwieGBAAyLN7wRkx2l9unw9usHK7iqkYTBEOl9gWt4OYXXdt3DGx/9oXWmggxkAk
j2K7vu8aGpIOCY3yVJx77grA4wkU/43SvWbPBbYnqCXSU8cWhQOtStDEnl9XJlHf
xinr2Yz+hG3yX56/6ifRwyKVHBaYwLOPaD3hv1jAS4Nsb/XP+Ij0GwFWjJ6fPwPb
/I9sSyOgMZIlf9KveZrp3shxpE8jrkJIypB4hz8JTMcCgUPnX6eycnBP1p5rW4+1
P8no6NuDZq1hTgSRlZKGPmDrn2YsrADeOzmYbHt4/9vxs+H3TpvKSKhl0IWii8Hi
pzciaQmiGj1ZoMg2EbtpCH4ffSDIyuEXhETKw9/8HYenu3vvRZc5eggjxqJrL9kC
h5vDHEmRfDOC6EIlWGDY8jmsqBFPTxKEOad4+vCTdFE9mY3N0d/j4m1OREY1BkoF
WgGSSnH0oobwrBcdsImMX7JVO+i4vNOxgOJVFl+PGJkX8/D+SRn2FLRDn0v98rva
hHbtQE0SnafbMvvCl3gj43G/4Pkd8KY3nEUCJiMMmLuR4aYTZ7spfnPZJz5C5TCY
l19L+Rmh6JLKZkUyF5lawHdg4y5FsDF95WENe4Hr1bx75g4dH2y+h7grDF4TuBW2
cadMk9gt1YdQrn3N1t3NJHM/TD2ueUepyGQosju9iiHuzTk8Qzs=
=leOc
-----END PGP SIGNATURE-----


Closed
?