[PATCH 12/21] gnu: emacs-helm-descbinds: New variable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Ludovic Courtès
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 18 May 2018 20:49
(address . guix-patches@gnu.org)
20180518184910.9987-17-ambrevar@gmail.com
* gnu/packages/emacs.scm (emacs-helm-descbinds): New variable.
---
gnu/packages/emacs.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9f86dd6c7..87b4acab9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10782,3 +10782,32 @@ for more details.")
(define-key company-mode-map (kbd \"C-:\") 'helm-company)
(define-key company-active-map (kbd \"C-:\") 'helm-company)))}")
(license license:gpl3+)))
+
+(define-public emacs-helm-descbinds
+ (package
+ (name "emacs-helm-descbinds")
+ (version "20180429.756")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/helm-descbinds-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0ibmxps9qmlri2m7dl05fkzm9v5mbvpqfddx713fkhzmgc3k0y33"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-helm" ,emacs-helm)))
+ (home-page
+ "https://github.com/emacs-helm/helm-descbinds")
+ (synopsis
+ "Convenient `describe-bindings' with `helm'")
+ (description
+ "This package is a replacement of @code{describe-bindings} for Helm.
+@code{describe-bindings} is replaced with @code{helm-descbinds}. As usual,
+type @code{C-h b}, or any incomplete key sequence plus @code{C-h}, to run
+@code{helm-descbinds}. The bindings are presented in a similar way as
+`describe-bindings ' does, but you can use completion to find the command you
+searched for and execute it, or view it's documentation.")
+ (license license:gpl3+)))
--
2.17.0
P
P
Pierre Neidhardt wrote on 1 Jun 2018 09:52
[PATCH 12/21] gnu: Add emacs-helm-descbinds.
(address . 31515@debbugs.gnu.org)
20180601075215.29098-1-ambrevar@gmail.com
* gnu/packages/emacs.scm (emacs-helm-descbinds): New variable.
---
gnu/packages/emacs.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b582ce992..d96016073 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10875,3 +10875,33 @@ for more details.")
(define-key company-mode-map (kbd \"C-:\") 'helm-company)
(define-key company-active-map (kbd \"C-:\") 'helm-company)))}")
(license license:gpl3+))))
+
+(define-public emacs-helm-descbinds
+ (let ((commit "033be73f21778633813264ce1634a6e1ad873d8e"))
+ (package
+ (name "emacs-helm-descbinds")
+ (version (git-version "1.13" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-descbinds")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1n89p56qwa243w1c85i5awnaf7piwjsvfi7nmnsrwm33hix5dknk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-helm" ,emacs-helm)))
+ (home-page
+ "https://github.com/emacs-helm/helm-descbinds")
+ (synopsis
+ "Convenient `describe-bindings' with `helm'")
+ (description
+ "This package is a replacement of @code{describe-bindings} for Helm.
+@code{describe-bindings} is replaced with @code{helm-descbinds}. As usual,
+type @code{C-h b}, or any incomplete key sequence plus @code{C-h}, to run
+@code{helm-descbinds}. The bindings are presented in a similar way as
+`describe-bindings ' does, but you can use completion to find the command you
+searched for and execute it, or view it's documentation.")
+ (license license:gpl3+))))
--
2.17.0
L
L
Ludovic Courtès wrote on 11 Jun 2018 14:48
control message for bug #31515
(address . control@debbugs.gnu.org)
878t7lij4v.fsf@gnu.org
tags 31515 fixed
close 31515
?