[PATCH 20/21] gnu: emacs-package-lint: New variable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Ludovic Courtès
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 18 May 2018 20:49
(address . guix-patches@gnu.org)
20180518184910.9987-13-ambrevar@gmail.com
* gnu/packages/emacs.scm (emacs-package-lint): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5a9df8fc8..1b598ea94 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11036,3 +11036,29 @@ Adjusted image when open image file: @code{M-x imagex-auto-adjust-mode}.
Or in .emacs: @code{(eval-after-load 'image+ '(imagex-auto-adjust-mode 1))}.
If you do not want error message in minibuffer: @code{(setq imagex-quiet-error t)}.")
(license license:gpl3+)))
+
+(define-public emacs-package-lint
+ (package
+ (name "emacs-package-lint")
+ (version "20180505.1828")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/package-lint-"
+ version
+ ".tar"))
+ (sha256
+ (base32
+ "0ahaipd49c4jhsjmrh35ck03g4sq37zms372w7ip1y4425qscnbp"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/purcell/package-lint")
+ (synopsis
+ "Linting library for elisp package authors")
+ (description
+ "Provides a list of issues with the package metadata of a file,
+e.g. the package dependencies it requires. See function
+@code{package-lint-buffer}. Checks will currently be enabled only if a
+\"Package-Requires:\" or \"Package-Version:\" header is present in the file. ")
+ (license license:gpl3+)))
--
2.17.0
P
P
Pierre Neidhardt wrote on 1 Jun 2018 09:55
[PATCH 20/21] gnu: Add emacs-package-lint.
(address . 31511@debbugs.gnu.org)
20180601075540.31140-1-ambrevar@gmail.com
* gnu/packages/emacs.scm (emacs-package-lint): New variable.
---
gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1eff953ce..f2c1c6a76 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11141,3 +11141,30 @@ Adjusted image when open image file: @code{M-x imagex-auto-adjust-mode}.
Or in .emacs: @code{(eval-after-load 'image+ '(imagex-auto-adjust-mode 1))}.
If you do not want error message in minibuffer: @code{(setq imagex-quiet-error t)}.")
(license license:gpl3+))))
+
+(define-public emacs-package-lint
+ (let ((commit "69bb89d00ba212b734c676ad056aa793c450b288"))
+ (package
+ (name "emacs-package-lint")
+ (version (git-version "0.5" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/package-lint")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1hfricsgmy3x9snnd2p4xq6vnnv94qdsxxnxp07b3hqc9bhw31rq"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/purcell/package-lint")
+ (synopsis
+ "Linting library for elisp package authors")
+ (description
+ "Provides a list of issues with the package metadata of a file,
+e.g. the package dependencies it requires. See function
+@code{package-lint-buffer}. Checks will currently be enabled only if a
+\"Package-Requires:\" or \"Package-Version:\" header is present in the file. ")
+ (license license:gpl3+))))
--
2.17.0
L
L
Ludovic Courtès wrote on 11 Jun 2018 15:17
(name . Pierre Neidhardt)(address . ambrevar@gmail.com)(address . 31511@debbugs.gnu.org)
87lgblh38u.fsf@gnu.org
Pierre Neidhardt <ambrevar@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-package-lint): New variable.

Applied.
L
L
Ludovic Courtès wrote on 11 Jun 2018 15:17
control message for bug #31511
(address . control@debbugs.gnu.org)
87k1r5h38o.fsf@gnu.org
tags 31511 fixed
close 31511
?