(address . guix-patches@gnu.org)
Hi, this patch adds an environment variable, ALSA_PLUGIN_DIR to allow
it to find its plugins. This is especially useful in GuixSD where
pulseaudio is used by most applications. When running an application
that only knows about alsa, no sound can be output because the card is
taken by pulse. One solution is to use the pulseaudio plugin from
alsa-plugins:pulseaudio and setting ~/.asoundrc:
# Default to PulseAudio
pcm.!default {
type pulse
hint {
show on
description "Default ALSA Output (currently PulseAudio Sound
Server)" }
}
ctl.!default {
type pulse
}
But this results in an error because alsa will look for plugins in its
own output directory in the store. With this patch, alsa is able to
find its plugins in ALSA_PLUGIN_DIR after exporting it (export
ALSA_PLUGIN_DIR=$HOME/.guix-profile/lib/alsa-lib).