[PATCH 1/3] guix import elpa: use https in download URLs

  • Done
  • quality assurance status badge
Details
2 participants
  • Konrad Hinsen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 16 Mar 2018 14:53
(address . guix-patches@gnu.org)
m1woycxgvp.fsf@fastmail.net
---
guix/import/elpa.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index 45a419217..7f76a13ad 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -69,9 +69,9 @@ NAMES (strings)."
(define* (elpa-url #:optional (repo 'gnu))
"Retrun the URL of REPO."
(let ((elpa-archives
- '((gnu . "http://elpa.gnu.org/packages")
- (melpa-stable . "http://stable.melpa.org/packages")
- (melpa . "http://melpa.org/packages"))))
+ '((gnu . "https://elpa.gnu.org/packages")
+ (melpa-stable . "https://stable.melpa.org/packages")
+ (melpa . "https://melpa.org/packages"))))
(assq-ref elpa-archives repo)))
(define* (elpa-fetch-archive #:optional (repo 'gnu))
--
2.16.2
L
L
Ludovic Courtès wrote on 17 Mar 2018 22:27
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 30835@debbugs.gnu.org)
87370ymlzf.fsf@gnu.org
Hi Konrad,

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

Toggle quote (4 lines)
> ---
> guix/import/elpa.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)

Applied with a commit log, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 17 Mar 2018 23:01
control message for bug #30835
(address . control@debbugs.gnu.org)
87zi36jra8.fsf@gnu.org
tags 30835 fixed
close 30835
?