[PATCH] services: cups: Add all extensions by default.

  • Done
  • quality assurance status badge
Details
5 participants
  • Danny Milosavljevic
  • Efraim Flashner
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 17 Feb 2018 15:54
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180217145411.724-1-dannym@scratchpost.org
* gnu/services/cups.scm (cups-configuration): Add all extensions by default.
---
gnu/services/cups.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (13 lines)
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 4c62e6a6f..4e7325a74 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -465,7 +465,7 @@ programs."))
(package cups)
"The CUPS package.")
(extensions
- (package-list (list cups-filters))
+ (package-list (list cups-filters escpr hplip))
"Drivers and other extensions to the CUPS package.")
(files-configuration
(files-configuration (files-configuration))
L
L
Ludovic Courtès wrote on 26 Feb 2018 18:57
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30500@debbugs.gnu.org)
87sh9ntz0l.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (16 lines)
> * gnu/services/cups.scm (cups-configuration): Add all extensions by default.
> ---
> gnu/services/cups.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
> index 4c62e6a6f..4e7325a74 100644
> --- a/gnu/services/cups.scm
> +++ b/gnu/services/cups.scm
> @@ -465,7 +465,7 @@ programs."))
> (package cups)
> "The CUPS package.")
> (extensions
> - (package-list (list cups-filters))
> + (package-list (list cups-filters escpr hplip))

Also ‘foomatic-filters’.

Toggle quote (4 lines)
> "Drivers and other extensions to the CUPS package.")
> (files-configuration
> (files-configuration (files-configuration))

I can definitely understand the usability argument. The counter
argument would be this:

Toggle snippet (6 lines)
$ guix size cups-filters | tail -1
total: 270.4 MiB
$ guix size cups-filters escpr hplip foomatic-filters | tail -1
total: 569.5 MiB

I think carrying all this could make ‘guix system reconfigure’
heavyweight for many—lots of unnecessary downloads/rebuilds, etc.

What do people think?

I suppose on Debian etc., one has to explicitly install the right
packages, no?

Ludo’.
L
L
Ludovic Courtès wrote on 2 Mar 2018 13:57
control message for bug #30500
(address . control@debbugs.gnu.org)
87efl2hby6.fsf@gnu.org
tags 30500 moreinfo
Z
Z
zimoun wrote on 19 Oct 2020 15:51
Re: [bug#30500] [PATCH] services: cups: Add all extensions by default.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87tuuqfhnz.fsf@gmail.com
Dear,

What is the status of the bug #30500 [1]? It is tagged 'moreinfo' and
now a bit old. It is about the addition of the two packages 'escpr' and
'hplip' to the service 'cups'.



On Mon, 26 Feb 2018 at 18:57, ludo@gnu.org (Ludovic Courtès) wrote:
Toggle quote (35 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> * gnu/services/cups.scm (cups-configuration): Add all extensions by default.
>> ---
>> gnu/services/cups.scm | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
>> index 4c62e6a6f..4e7325a74 100644
>> --- a/gnu/services/cups.scm
>> +++ b/gnu/services/cups.scm
>> @@ -465,7 +465,7 @@ programs."))
>> (package cups)
>> "The CUPS package.")
>> (extensions
>> - (package-list (list cups-filters))
>> + (package-list (list cups-filters escpr hplip))
>
> Also ‘foomatic-filters’.
>
>> "Drivers and other extensions to the CUPS package.")
>> (files-configuration
>> (files-configuration (files-configuration))
>
> I can definitely understand the usability argument. The counter
> argument would be this:
>
> $ guix size cups-filters | tail -1
> total: 270.4 MiB
> $ guix size cups-filters escpr hplip foomatic-filters | tail -1
> total: 569.5 MiB
>
> I think carrying all this could make ‘guix system reconfigure’
> heavyweight for many—lots of unnecessary downloads/rebuilds, etc.

What people think?


All the best,
simon
T
T
Tobias Geerinckx-Rice wrote on 19 Oct 2020 17:58
(name . zimoun)(address . zimon.toutoune@gmail.com)
877drmtdgn.fsf@nckx
zimoun ???
Toggle quote (5 lines)
>> $ guix size cups-filters | tail -1
>> total: 270.4 MiB
>> $ guix size cups-filters escpr hplip foomatic-filters | tail -1
>> total: 569.5 MiB

It's since improved. Probably thanks to hplip-minimal, whilst the
newer Samsung SpliX package adds a mere 0.2 MiB:

λ guix size cups | tail -n 1
total: 279.5 MiB
λ guix size cups-filters escpr hplip-minimal foomatic-filters
splix | tail -n 1
total: 405.4 MiB (+45%)

Toggle quote (4 lines)
>> I think carrying all this could make ‘guix system reconfigure’
>> heavyweight for many—lots of unnecessary downloads/rebuilds,
>> etc.

‘Lots’ is way overblown. This is it:

+/gnu/store/44xzcm69lmy71ydrnmv4plzxc26rk0dc-splix-2.0.0-315
+/gnu/store/amahw2r0b7fjqphisv8c0f6w77qac3c0-hplip-minimal-3.20.9
+/gnu/store/jqqf3xzs4sjdvnvddpk3pgx8g2rn9db3-foomatic-filters-4.0.17
+/gnu/store/w3rqls7rxri89xmi02yw8irycnf5zia1-escpr-1.7.7
+/gnu/store/9bfxyfqx12mnxwh715y23djnp239qh1b-libusb-1.0.23
+/gnu/store/57xj5gcy1jbl9ai2lnrqnpr0dald9i65-coreutils-8.32
+/gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2

With the last 2 (3?) almost certainly already installed, this is
not unreasonable for ‘cups-service-type actually prints, even if
you visit grandma’.

Visit grandma,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX423mA0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15AiwA/Aotbfk8XkFFqvSsawQ/d87vsypybVv5n9e1+wg9
QAiNAP9K9T+9NIZoApG3jNMdIXErscH9bnnHU8x3yXtLBrDLBA==
=eHpW
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 28 Oct 2020 18:24
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
86pn521cy5.fsf@gmail.com
Hi,

On Mon, 19 Oct 2020 at 17:58, Tobias Geerinckx-Rice <me@tobias.gr> wrote:

Toggle quote (23 lines)
> λ guix size cups | tail -n 1
> total: 279.5 MiB
> λ guix size cups-filters escpr hplip-minimal foomatic-filters splix | tail
> -n 1
> total: 405.4 MiB (+45%)
>
>>> I think carrying all this could make ‘guix system reconfigure’
>>> heavyweight for many—lots of unnecessary downloads/rebuilds, etc.
>
> ‘Lots’ is way overblown. This is it:
>
> +/gnu/store/44xzcm69lmy71ydrnmv4plzxc26rk0dc-splix-2.0.0-315
> +/gnu/store/amahw2r0b7fjqphisv8c0f6w77qac3c0-hplip-minimal-3.20.9
> +/gnu/store/jqqf3xzs4sjdvnvddpk3pgx8g2rn9db3-foomatic-filters-4.0.17
> +/gnu/store/w3rqls7rxri89xmi02yw8irycnf5zia1-escpr-1.7.7
> +/gnu/store/9bfxyfqx12mnxwh715y23djnp239qh1b-libusb-1.0.23
> +/gnu/store/57xj5gcy1jbl9ai2lnrqnpr0dald9i65-coreutils-8.32
> +/gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2
>
> With the last 2 (3?) almost certainly already installed, this is not
> unreasonable for ‘cups-service-type actually prints, even if you visit
> grandma’.

Grandma’ is lost, on one hand +45% and on the other hand not
unreasonable. :-)

Does it make sense to apply the patch? From my point of view, yes.


Cheers,
simon
Z
Z
zimoun wrote on 18 Nov 2020 00:07
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
86o8jvmvjw.fsf@gmail.com
Hi,

Does it make sense to apply the patch and close this old bug?

From my point of view, yes for the two. ;-)


All the best,
simon

On Sat, 17 Feb 2018 at 15:54, Danny Milosavljevic <dannym@scratchpost.org> wrote:
Toggle quote (18 lines)
> * gnu/services/cups.scm (cups-configuration): Add all extensions by default.
> ---
> gnu/services/cups.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
> index 4c62e6a6f..4e7325a74 100644
> --- a/gnu/services/cups.scm
> +++ b/gnu/services/cups.scm
> @@ -465,7 +465,7 @@ programs."))
> (package cups)
> "The CUPS package.")
> (extensions
> - (package-list (list cups-filters))
> + (package-list (list cups-filters escpr hplip))
> "Drivers and other extensions to the CUPS package.")
> (files-configuration
> (files-configuration (files-configuration))
E
E
Efraim Flashner wrote on 18 Nov 2020 09:28
(name . zimoun)(address . zimon.toutoune@gmail.com)
20201118082800.GY987@E5400
On Wed, Nov 18, 2020 at 12:07:47AM +0100, zimoun wrote:
Toggle quote (7 lines)
> Hi,
>
> Does it make sense to apply the patch and close this old bug?
>
> From my point of view, yes for the two. ;-)
>

I no longer have the original bug report in my main mail folder, that's
how old it is :). Lets add a couple more, printing sucks a lot as it
already is. I don't think it's any worse than, say, adding
glibc-locales@2.29 by default. Just make sure the documentation is
updated accordingly.

I vote yes

Toggle quote (27 lines)
>
> All the best,
> simon
>
> On Sat, 17 Feb 2018 at 15:54, Danny Milosavljevic <dannym@scratchpost.org> wrote:
> > * gnu/services/cups.scm (cups-configuration): Add all extensions by default.
> > ---
> > gnu/services/cups.scm | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
> > index 4c62e6a6f..4e7325a74 100644
> > --- a/gnu/services/cups.scm
> > +++ b/gnu/services/cups.scm
> > @@ -465,7 +465,7 @@ programs."))
> > (package cups)
> > "The CUPS package.")
> > (extensions
> > - (package-list (list cups-filters))
> > + (package-list (list cups-filters escpr hplip))
> > "Drivers and other extensions to the CUPS package.")
> > (files-configuration
> > (files-configuration (files-configuration))
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+02woACgkQQarn3Mo9
g1ENpBAAibB9ay4ZLeu+IKJPtBCtHSpziRBzjAwk6dve6HpOqg9uI+wAAQO/ueuv
kpKiKNN9cr4W5uTNnTNq0zoOnKUIMVIJ50GZZTYUiHvT9spvtSNW45ZZA8IACLfn
ZZsx9hMT79RbruF6Rs+HKojGBaFN4OF7TQ9251hWdI/f/irTMlCIccCC6DwdxA2Y
4Pf2uEcKyF1FakIgvcmx8NRNEOOst/TdJM1yt/1yTfLxZH39FzJ8wvZb9RfyEm8z
maDrPU1h3YhVPAXGLCXiJi1q6j2pxZ9HUaOXpucPdrITdnSKtPIsHPAbrqNc6Hj7
WBFGkYenDdt3IRcCqnhYSbAra1RKfjKAbrlGvy5juuD5pwRgOKIuxXCez1RS+M20
mkiSoJYNexfFw0ZOh4NEqNzBWnOtvTIhohO053HNSSmPKFXIfJKcMu1Ox0X1xxjM
NDFiWWTxvz6EWpRXBdQsPDvt1QfTQKTjx/W2xKt3oEEK3FlA7eY6dpw6TxAACRgJ
KLwRhtSilZZRsfQCFnQJMQ66vWaPsSW82KMkcd3n+zPsEW/Kf27SZj+c14yo4+Xj
OcxEeKNB3vqm/qDFXdnNwbyWjvxWbyrxfXhYVcaErKo81djggt0wrP5Q4Q2taQqB
PQJEZ7OUmQcwBWz4qO7EOJkvSUAeHHQNFfwlPAA4nkXhXtn4Bjs=
=Rapp
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 18 Nov 2020 09:48
(name . Efraim Flashner)(address . efraim@flashner.co.il)
865z63m4op.fsf@gmail.com
Hi,

On Wed, 18 Nov 2020 at 10:28, Efraim Flashner <efraim@flashner.co.il> wrote:

Toggle quote (8 lines)
> I no longer have the original bug report in my main mail folder, that's
> how old it is :). Lets add a couple more, printing sucks a lot as it
> already is. I don't think it's any worse than, say, adding
> glibc-locales@2.29 by default. Just make sure the documentation is
> updated accordingly.
>
> I vote yes

I could rebase the patch and add documentation. But I am not using
printing or services (foreign distro) so I would be able to test it.

Please beat me at this. :-)


Cheers,
simon
D
D
Danny Milosavljevic wrote on 18 Nov 2020 10:00
(name . zimoun)(address . zimon.toutoune@gmail.com)
20201118100047.23e2ec79@scratchpost.org
Pushed a T G-R variant of this cups-services patch to guix master as
commit 8490fa0253fa8ee5613a89851273e007494ea79b.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl+04r8ACgkQ5xo1VCww
uqVGHgf+IppEmT/QcX+IrCeYjerpSBpO8U+aw3Pk5N1d5VJWfC8CMfbeJb4XbJA5
J3E+inltoUbZStJwdgQR3mI/EnmK1UJHmQXvMJ9rcTRoLc4LGKfy2j2lkmL0zc7l
Nsook3QOdwo4gWit4NrSrq6UqQ8ckpeDpnH6aqMbRmjteBU/t52H5kdn+OYG0NtQ
jRiGBc/rjM76GAAJl08uKjSGsJ+Fw2Q6+Ot/VNO7IVSlDXkLndN/UOZqcs30dei7
Gyng2+dUIqDrvZSF0kPuumStAdBb5I4BWfQP90lFJqSXghO6conKSIeWbanQg7gW
yX8vbFF/IUOt9/CtQikah0zE0bzE6g==
=dKOu
-----END PGP SIGNATURE-----


Closed
?