[PATCH 0/2] gnu: tome4: Add fix to getself.c.

  • Done
  • quality assurance status badge
Details
4 participants
  • Gábor Boskovits
  • Oleg Pykhalov
  • Sarah Morgensen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 9 Feb 2018 22:21
(address . guix-patches@gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180209212145.6478-1-go.wigust@gmail.com
Hello Guix,

I've noticed tome4 sometimes failes:


First patch is an attempt to fix a getself.c error.
Second patch replaces 'system*' with 'invoke' Guile functions.

Oleg Pykhalov (2):
gnu: tome4: Add fix to getself.c.
gnu: tome4: Replace system* with invoke.

gnu/local.mk | 1 +
gnu/packages/games.scm | 14 ++++++-------
.../patches/tome4-patch-src-getself-c.patch | 24 ++++++++++++++++++++++
3 files changed, 32 insertions(+), 7 deletions(-)
create mode 100644 gnu/packages/patches/tome4-patch-src-getself-c.patch

--
2.15.1
O
O
Oleg Pykhalov wrote on 9 Feb 2018 22:23
[PATCH 1/2] gnu: tome4: Add fix to getself.c.
(address . 30406@debbugs.gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180209212331.6538-1-go.wigust@gmail.com
* gnu/local.mk (dist_patch_DATA): Add this.
* gnu/packages/games.scm (tome4)[source]: Add fix to getself.c.
* gnu/packages/patches/tome4-patch-src-getself-c.patch: New file.
---
gnu/local.mk | 1 +
gnu/packages/games.scm | 1 +
.../patches/tome4-patch-src-getself-c.patch | 24 ++++++++++++++++++++++
3 files changed, 26 insertions(+)
create mode 100644 gnu/packages/patches/tome4-patch-src-getself-c.patch

Toggle diff (56 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 925057dc7..24b0bf1e0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1118,6 +1118,7 @@ dist_patch_DATA = \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
+ %D%/packages/patches/tome4-patch-src-getself-c.patch \
%D%/packages/patches/tophat-build-with-later-seqan.patch \
%D%/packages/patches/totem-meson-easy-codec.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 286d0feef..a5804a87b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5208,6 +5208,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(sha256
(base32
"0v2qgdfpvdzd1bcbp9v8pfahj1bgczsq2d4xfhh5wg11jgjcwz03"))
+ (patches (search-patches "tome4-patch-src-getself-c.patch"))
(modules '((guix build utils)))
(snippet
'(substitute* '("src/music.h" "src/tSDL.h")
diff --git a/gnu/packages/patches/tome4-patch-src-getself-c.patch b/gnu/packages/patches/tome4-patch-src-getself-c.patch
new file mode 100644
index 000000000..ce4795662
--- /dev/null
+++ b/gnu/packages/patches/tome4-patch-src-getself-c.patch
@@ -0,0 +1,24 @@
+Copied from OpenBSD.
+
+Fixes: ../src/getself.c:40:1: fatal error: opening dependency file
+../obj/Release/TEngine/getself.d: No such file or directory
+
+$OpenBSD: patch-src_getself_c,v 1.3 2017/11/11 11:24:42 kirby Exp $
+
+--- a/src/getself.c
++++ b/src/getself.c
+@@ -47,13 +47,7 @@ int get_number_cpus()
+ const char *get_self_executable(int argc, char **argv)
+ {
+ static char res[PATH_MAX];
+- int mib[4];
+- mib[0] = CTL_KERN;
+- mib[1] = KERN_PROC;
+- mib[2] = KERN_PROC_PATHNAME;
+- mib[3] = -1;
+- size_t cb = sizeof(res);
+- sysctl(mib,4,res,&cb,NULL,0);
++ realpath("${GAMEDIR}/", res);
+ return res;
+ }
+
--
2.15.1
O
O
Oleg Pykhalov wrote on 9 Feb 2018 22:23
[PATCH 2/2] gnu: tome4: Replace system* with invoke.
(address . 30406@debbugs.gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20180209212331.6538-2-go.wigust@gmail.com
* gnu/packages/games.scm (tome4)[arguments]: Replace 'system*' with 'invoke'.
---
gnu/packages/games.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5804a87b..e327dbc2f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5230,8 +5230,7 @@ Crowther & Woods, its original authors, in 1995. It has been known as
#:phases (modify-phases %standard-phases
(replace 'configure
(lambda _
- (zero? (system* "premake4" "gmake"))
- #t))
+ (invoke "premake4" "gmake")))
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
@@ -5257,11 +5256,11 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(wrapper (string-append bin "/" ,name)))
;; icon
(mkdir-p pixmaps)
- (system* unzip "-j"
- (string-append
- "game/engines/te4-" ,version ".teae")
- (string-append
- "data/gfx/" icon) "-d" pixmaps)
+ (invoke unzip "-j"
+ (string-append "game/engines/te4-"
+ ,version ".teae")
+ (string-append "data/gfx/" icon)
+ "-d" pixmaps)
;; game executable
(install-file "t-engine" data)
(mkdir-p bin)
--
2.15.1
L
L
Ludovic Courtès wrote on 23 Apr 2018 14:59
Re: [bug#30406] [PATCH 1/2] gnu: tome4: Add fix to getself.c.
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 30406@debbugs.gnu.org)
87fu3m2i5l.fsf@gnu.org
Hello,

Oleg Pykhalov <go.wigust@gmail.com> skribis:

Toggle quote (4 lines)
> * gnu/local.mk (dist_patch_DATA): Add this.
> * gnu/packages/games.scm (tome4)[source]: Add fix to getself.c.
> * gnu/packages/patches/tome4-patch-src-getself-c.patch: New file.

As noted in HACKING, please feel free to go ahead if this patch fixes
something for you.

Thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 23 Apr 2018 14:59
Re: [bug#30406] [PATCH 2/2] gnu: tome4: Replace system* with invoke.
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 30406@debbugs.gnu.org)
87bmea2i4u.fsf@gnu.org
Oleg Pykhalov <go.wigust@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/games.scm (tome4)[arguments]: Replace 'system*' with 'invoke'.

Unless this has already been done in core-updates, you can definitely
push this one.

Ludo'.
G
G
Gábor Boskovits wrote on 22 Jun 2018 21:34
gnu: tome4: Add fix to getself.c.
(address . 30406@debbugs.gnu.org)(address . go.wigust@gmail.com)
CAE4v=piOG43JAYqY1grQ45nZbVLDDAcMjzfg8wqLNmzmeoU-XQ@mail.gmail.com
I'm reviewing patches before guix 0.15.0. This patchset looks like a good
candidate for inclusion, but patches do not apply cleanly on current
master. Ludo already said that these are ok to push. Can you create updated
patches, and push them, or submit them?
Attachment: file
O
O
Oleg Pykhalov wrote on 23 Jun 2018 04:06
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . 30406@debbugs.gnu.org)
87h8lujlxu.fsf@gmail.com
Hello Gábor,

Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (4 lines)
> I'm reviewing patches before guix 0.15.0. This patchset looks like a good
> candidate for inclusion, but patches do not apply cleanly on current
> master. Ludo already said that these are ok to push.

Thank you for taking your time on it.

Toggle quote (2 lines)
> Can you create updated patches, and push them, or submit them?

I've updated tome4 to 1.5.10 in 972b87b14ae54bacf2457a4d538c5495bec37176
and I'm not sure whether the patch is necessary now. I've found failed
built of the previous version on Hydra, so maybe I'll spot a failure for
the new version, too.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAlstqy4ACgkQckbhHGm3
lWlsDA/9GSjcN9HrRxBPYO59rIb/sfic4HEHkNB0xYFrStBJQ8OM5LJ+aEakXPP3
jWlltvNfLjAWvO0fDFME2UNZ9LEd65mQDvXEn5seI5xjEiR4u9z/V8T/0Vq5wTIp
nRsYRWMZnozDdpaALcBWInGL9p2jIRPNaF/97c8UP7uxO2XoJnKpgYM/yDYSsRu8
1W4FiO2IxCajPAGOefVYfoKW4iNB7h4tipuvYL3cygEk2BCPY0ezGTJZbL7Px+Vb
8ApRgga2JWOswN2c/Z41B3p1Bb6d7+TkQTpru4WrXGYCb64/rip4hl123uYqX38/
rJpwuIuSPxiN0+Wex/QVGN2IgYfdSaQEZy6jNyuESh+pylIoY6EtEsJaBCZ+/LEg
Q04yzIr5nbWjAOympbYyX5m+i4SAdctVyFe0YAxxswv3mgSD/k6pGrtURNFOTHfJ
BBEcQPOWewHdccIZ21nLaQPF9is0aGpCx4l5ch+9qZalDsxpfkZ5qX19dRxgd59d
5+KwffozuOcQqzJzzt7oR9qmHwEMfPxZe4XtReQWFW1JMEBltXK4Uy80vJskPpzc
3IplgJCIVk5jZZ2tY8U7YFfYtv5qPnbOVTHtwj6H1Y+68M2NfNNZPNC+hal05Zl1
qyVHIF1R916VHI6aAHsKd7GcEMC2LPWvhTxP7ZDCXeGIHRRzUeU=
=3pcQ
-----END PGP SIGNATURE-----

S
S
Sarah Morgensen wrote on 13 Sep 2021 02:07
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
865yv5l4nm.fsf@mgsn.dev
Hello,

I found this old bug. It looks like it's been building consistently for
some time now, so I'm closing it. Feel free to reopen if necessary.

Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (7 lines)
> I've updated tome4 to 1.5.10 in 972b87b14ae54bacf2457a4d538c5495bec37176
> and I'm not sure whether the patch is necessary now. I've found failed
> built of the previous version on Hydra, so maybe I'll spot a failure for
> the new version, too.
>
> Oleg.

--
Sarah
Closed
?