'mount -t ecryptfs ...' command refers to /bin/mount, bin/umount, etc

  • Done
  • quality assurance status badge
Details
3 participants
  • Gábor Boskovits
  • brendan.tildesley
  • Ludovic Courtès
Owner
unassigned
Submitted by
brendan.tildesley
Severity
normal
B
B
brendan.tildesley wrote on 23 Jan 2018 02:19
(address . bug-guix@gnu.org)
20180123011936.CB9054F2B09@mta-1.openmailbox.org
I noticed this a while ago but probably won't get around to fixing it, so I'm just posting a bug report.
-------------------------------------
b@ui ~$ sudo mount -t ecryptfs encrypted-dir mount-dir
Passphrase:
Select cipher:
[...]
Selection [aes]:
Select key bytes:
1) 16
2) 32
3) 24
Selection [16]:
Enable plaintext passthrough (y/n) [n]:
Enable filename encryption (y/n) [n]: y
Filename Encryption Key (FNEK) Signature [...]:
Attempting to mount with the following options:
ecryptfs_unlink_sigs
ecryptfs_fnek_sig=[...]
ecryptfs_key_bytes=16
ecryptfs_cipher=aes
ecryptfs_sig=[...]
Failed to execute /bin/mount command: No such file or directory
Error mounting eCryptfs: [-2] No such file or directory
Check your system logs; visit http://ecryptfs.org/support.html
-------------------------------------


There are many references to /bin/ in the ecryptfs source code, even including /bin/umount. for example:

-------------------------------------
b@ui ~/temp/ecryptfs-utils-111$ ag exec.*bin/
src/utils/mount.ecryptfs.c
417: execl("/bin/mount", "mount", "-i", "--no-canonicalize", "-t", "ecryptfs", fullpath_source, fullpath_target, "-o", opts, NULL);
421: perror("Failed to execute /bin/mount command");

src/desktop/ecryptfs-mount-private.desktop.in
4:Exec=/usr/bin/ecryptfs-mount-private

src/desktop/ecryptfs-setup-private.desktop.in
4:Exec=/usr/bin/ecryptfs-setup-private

src/utils/mount.ecryptfs_private.c
833: execl("/bin/umount", "umount", "-i", "-l", ".", NULL);

src/pam_ecryptfs/pam_ecryptfs.c
375: execl("/sbin/mount.ecryptfs_private",
389: execl("/sbin/umount.ecryptfs_private",

-------------------------------------
L
L
Ludovic Courtès wrote on 24 Jan 2018 15:51
control message for bug #30224
(address . control@debbugs.gnu.org)
87tvvbxqc5.fsf@gnu.org
tags 30224 easy
B
B
Brendan Tildesley wrote on 30 Jul 2018 17:43
(no subject)
(address . 30224-done@debbugs.gnu.org)
785cf642-8938-000e-8275-5f7b1e629634@openmailbox.org

Closed
G
G
Gábor Boskovits wrote on 30 Jul 2018 21:54
(address . 30224-done@debbugs.gnu.org)
CAE4v=piX2zWfvJwfey_2pZo1JV4eBcScxgPJznhiW7BGNhB6Hw@mail.gmail.com
Brendan Tildesley <brendan.tildesley@openmailbox.org> ezt írta (id?pont:
2018. júl. 30., H, 17:44):
Could you elaborate on this a bit more?
i.e. what was the commit fixing the issue?
on which branch?
or we just don't notice the behavior any more?
Also, please add the title of the bug, so we can see what bug is closed
without visiting the bugtracker.
Attachment: file
B
B
Brendan Tildesley wrote on 1 Aug 2018 07:33
(address . 30224@debbugs.gnu.org)
8ecf5014-fded-d894-4645-a79e97eb7cd0@openmailbox.org
On 07/31/18 05:54, Gábor Boskovits wrote:
Toggle quote (12 lines)
>
>
> Brendan Tildesley <brendan.tildesley@openmailbox.org
> <mailto:brendan.tildesley@openmailbox.org>> ezt írta (id?pont: 2018.
> júl. 30., H, 17:44):
>  Could you elaborate on this a bit more?
> i.e. what was the commit fixing the issue?
> on which branch?
> or we just don't notice the behavior any more?
> Also, please add the title of the bug, so we can see what bug is
> closed without visiting the bugtracker.
>
Sorry, it's the first time I've closed a bug, I just learnt it could be
done by sending and email to NUMBER-close@... and sent a blank email.

The fix is contained in the commits

17a21bcf316d11bdf54ec2483abe15f60dbd7cb0

e8ec2dda08d36f3a8d17f840980ea82585d1fc38

and include only changes to the ecryptfs-utils package. I tried my best
to find all cases in the source with hard-coded paths. Feel free to
inspect it further if you like. For me at least, I'm able to mount my
ecryptfs folder with these patches.
Attachment: file
?