Unnecessary backtrace by guix/build/download.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • zimoun
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 27 May 2017 13:36
(address . bug-guix@gnu.org)
20170527133647.2d6d8b38@scratchpost.org
guix [env]$ ./pre-inst-env guix import pypi flex
;;; note: source file /x/home/dannym/src/guix/gnu/packages/databases.scm
;;; newer than compiled /x/home/dannym/src/guix/gnu/packages/databases.go
Backtrace:
9 (primitive-load "/x/home/dannym/src/guix/scripts/guix")
In guix/ui.scm:
1264:8 8 (run-guix-command _ . _)
In guix/scripts/import.scm:
114:11 7 (guix-import . _)
In guix/scripts/import/pypi.scm:
84:19 6 (guix-import-pypi . _)
In guix/import/pypi.scm:
279:17 5 (pypi->guix-package _)
In ice-9/boot-9.scm:
837:9 4 (catch srfi-34 #<procedure 34cec00 at guix/import/json?> ?)
In guix/import/json.scm:
32:17 3 (_)
In guix/http-client.scm:
239:25 2 (http-fetch _ #:port _ #:text? _ #:buffered? _ # _ # _ # ?)
In guix/build/download.scm:
520:4 1 (open-connection-for-uri _ #:timeout _ # _)
417:6 0 (tls-wrap #<closed: file 1e2a9a0> _ # _)

guix/build/download.scm:417:6: In procedure tls-wrap:
guix/build/download.scm:417:6: X.509 certificate of 'pypi.python.org' could not be verified:
signer-not-found
invalid

Also, the most interesting information, which is which certificates it DID know and where it got them, is not printed.
D
D
Danny Milosavljevic wrote on 27 May 2017 13:40
And another unnecessary backtrace by guix/build/download.scm
(address . 27100@debbugs.gnu.org)
20170527134055.41243e40@scratchpost.org
Backtrace:
12 (primitive-load "/x/home/dannym/src/guix/scripts/guix")
In guix/ui.scm:
1264:8 11 (run-guix-command _ . _)
In guix/scripts/import.scm:
114:11 10 (guix-import . _)
In guix/scripts/import/pypi.scm:
84:19 9 (guix-import-pypi . _)
In guix/import/pypi.scm:
279:17 8 (pypi->guix-package _)
In ice-9/boot-9.scm:
837:9 7 (catch srfi-34 #<procedure 2ced7e0 at guix/import/json…> …)
In guix/import/json.scm:
32:17 6 (_)
In guix/http-client.scm:
239:25 5 (http-fetch _ #:port _ #:text? _ #:buffered? _ # _ # _ # …)
In guix/build/download.scm:
520:4 4 (open-connection-for-uri _ #:timeout _ # _)
391:34 3 (tls-wrap #<input-output: socket 16> "pypi.python.org" # …)
308:4 2 (make-credendials-with-ca-trust-files _)
In srfi/srfi-1.scm:
640:9 1 (for-each #<procedure 2cf0b60 at guix/build/download.s…> …)
In unknown file:
0 (set-certificate-credentials-x509-trust-file! #<certif…> …)

ERROR: In procedure set-certificate-credentials-x509-trust-file!:
ERROR: Throw to key `gnutls-error' with args `(#<gnutls-error-enum Fehler beim Dateilesen.> set-certificate-credentials-x509-trust-file!)'.

Again without the actual interesting information (the file in question), which is presumably cut off by the "..." in the backtrace. Btw how can I turn the cutoff off?
Z
Z
zimoun wrote on 18 Nov 2020 00:27
Re: bug#27100: Unnecessary backtrace by guix/build/download.scm
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27100@debbugs.gnu.org)
86h7pnmumd.fsf@gmail.com
Hi Danny,

On Sat, 27 May 2017 at 13:36, Danny Milosavljevic <dannym@scratchpost.org> wrote:
Toggle quote (3 lines)
> guix [env]$ ./pre-inst-env guix import pypi flex
> Backtrace:

[...] Ugly

Toggle quote (7 lines)
> guix/build/download.scm:417:6: In procedure tls-wrap:
> guix/build/download.scm:417:6: X.509 certificate of 'pypi.python.org' could not be verified:
> signer-not-found
> invalid
>
> Also, the most interesting information, which is which certificates it DID know and where it got them, is not printed.

Well, the bug #27100 [1] is solved now, I guess. First, the command

$ guix import pypi flex

works now. And the command:

$ guix import pypi kikoo
following redirection to `https://pypi.org/pypi/kikoo/json/'...
guix import: error: failed to download meta-data for package 'kikoo'

fails gracefully. What remains is “guix import pypi kikoo -r” but it is
tracked by #44115 about the recursive option of all the importers.

Otherwise, do you have example to reproduce the bug you initiated.



Thanks,
simon
Z
Z
zimoun wrote on 25 Feb 2021 00:56
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27100@debbugs.gnu.org)
86ft1lkokt.fsf@gmail.com
Hi,

On Wed, 18 Nov 2020 at 00:27, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (26 lines)
> On Sat, 27 May 2017 at 13:36, Danny Milosavljevic <dannym@scratchpost.org> wrote:
>> guix [env]$ ./pre-inst-env guix import pypi flex
>> Backtrace:
>
> [...] Ugly
>
>> guix/build/download.scm:417:6: In procedure tls-wrap:
>> guix/build/download.scm:417:6: X.509 certificate of 'pypi.python.org' could not be verified:
>> signer-not-found
>> invalid
>>
>> Also, the most interesting information, which is which certificates it DID know and where it got them, is not printed.
>
> Well, the bug #27100 [1] is solved now, I guess. First, the command
>
> $ guix import pypi flex
>
> works now. And the command:
>
> $ guix import pypi kikoo
> following redirection to `https://pypi.org/pypi/kikoo/json/'...
> guix import: error: failed to download meta-data for package 'kikoo'
>
> fails gracefully. What remains is “guix import pypi kikoo -r” but it is
> tracked by #44115 about the recursive option of all the importers.

I think this bug is now addressed and could be closed. WDYT?


All the best,
simon
D
D
Danny Milosavljevic wrote on 25 Feb 2021 02:18
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 27100-done@debbugs.gnu.org)
20210225021851.681e5681@scratchpost.org
Hi,

Toggle quote (8 lines)
>$ LC_ALL=C guix download https://192.168.10.1

>Starting download of /tmp/guix-file.Zfy7gX
>From https://192.168.10.1...
>X.509 server certificate for '192.168.10.1' does not match: C=ZZ,ST=Somewhere,L=Unknown,O=libreCMC087d391f,CN=libreCMC
>failed to download "/tmp/guix-file.Zfy7gX" from "https://192.168.10.1"
>guix download: error: https://192.168.10.1: download failed

Nice!

Yes, it's much better now! Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmA2+vsACgkQ5xo1VCww
uqWsuggAhZAg3tx9z40szA9i0BRFzsXe+m5wBsTCjRJGIPcMOBTB/Q7JLKRXnrJ5
B50ABS0nGvM1pZlfIdOgw6W2Yyzqii8pAVBSEF77+RT9RBpwSWv7FExNJTcZgckA
1qPL0kNe6cCapTYrXmEoSx9A0RB4qt35B0kjTN/M/uib46ouV7ZpKAYAGFssb0Fc
4gZDFe4tEsihSsUrXVkRThl2ncFKmipmH1wjWN2oNJQ82zBfKnQqghM4zhMqNzxo
P9NNgbQ/W7m1r3/YJDqdsBHhAOsqyYcywWGD5vCFo+tJ0E6sLH4sBSGz2dZsPVym
Nh6OGH6UyGcWq5cTLJUP/NKfTXJHvg==
=xGfz
-----END PGP SIGNATURE-----


Closed
?