bbs100

  • Done
  • quality assurance status badge
Details
5 participants
  • Christopher Baines
  • ng0
  • ng0
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
ng0
Severity
normal
N
(address . guix-patches@gnu.org)
20170512173404.dm6ndiajbpatcs42@abyayala
This adds bbs100. For possible past reviews search the guix-devel@gnu.org archive.
--
From 09746bd8021235c7c27bae10b4574011ea4e7f2b Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Sat, 17 Sep 2016 00:37:52 +0000
Subject: [PATCH] gnu: Add bbs100.

* gnu/packages/bbs.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add bbs.scm.
---
gnu/local.mk | 1 +
gnu/packages/bbs.scm | 75 ++++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 76 insertions(+)
create mode 100644 gnu/packages/bbs.scm

Toggle diff (95 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 8599e6d3a..e75058d29 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -63,6 +63,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/backup.scm \
%D%/packages/base.scm \
%D%/packages/bash.scm \
+ %D%/packages/bbs.scm \
%D%/packages/bdw-gc.scm \
%D%/packages/benchmark.scm \
%D%/packages/bioinformatics.scm \
diff --git a/gnu/packages/bbs.scm b/gnu/packages/bbs.scm
new file mode 100644
index 000000000..894c64721
--- /dev/null
+++ b/gnu/packages/bbs.scm
@@ -0,0 +1,75 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages bbs)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages perl)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public bbs100
+ (package
+ (name "bbs100")
+ (version "3.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.heiho.net/bbs100/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wjqyxw5wpxgzwx83vx2c56v0jjq62bsj1xn4livm0crjbi4mdqb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:parallel-build? #f
+ #:phases
+ ;; FIXME: the install phase creates a symlink 'bin' to 'bin-3.3.1'.
+ ;; FIXME: the log directory is hardcoded without prefix.
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-param-file
+ (lambda _
+ (substitute* "etc/param"
+ (("/usr/share/zoneinfo/") "")
+ (("^zoneinfodir")
+ (string-append "zoneinfodir "
+ (assoc-ref %build-inputs "tzdata")
+ "/share/zoneinfo")))
+ #t))
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "src")
+ #t)))))
+ (inputs
+ `(("perl" ,perl)))
+ (native-inputs
+ `(("tzdata" ,tzdata)
+ ("inetutils" ,inetutils)))
+ (home-page "http://www.heiho.net/bbs100/")
+ (synopsis "DOC style telnet BBS")
+ (description
+ "@code{bbs100} is a @dfn{Bulletin Board System} (BBS) in the style of
+DOC (which remotely resembles @code{Citadel}).
+It is a single process daemon that handles all connections at once, while
+consuming very low cpu resources (< 1%). Bbs100 can handle over a thousand
+simultaneous users, is highly customizable, easy to setup, and has
+many configurable features.")
+ (license license:gpl2+)))
--
2.12.2
N
(address . guix-patches@gnu.org)
20170512175624.lcwh74v64agdk7bc@abyayala
ng0 transcribed 4.3K bytes:
Toggle quote (83 lines)
> This adds bbs100. For possible past reviews search the guix-devel@gnu.org archive.
> --
> https://pragmatique.xyz
> PGP: https://people.pragmatique.xyz/ng0/

> From 09746bd8021235c7c27bae10b4574011ea4e7f2b Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 17 Sep 2016 00:37:52 +0000
> Subject: [PATCH] gnu: Add bbs100.
>
> * gnu/packages/bbs.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add bbs.scm.
> ---
> gnu/local.mk | 1 +
> gnu/packages/bbs.scm | 75 ++++++++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 76 insertions(+)
> create mode 100644 gnu/packages/bbs.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 8599e6d3a..e75058d29 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -63,6 +63,7 @@ GNU_SYSTEM_MODULES = \
> %D%/packages/backup.scm \
> %D%/packages/base.scm \
> %D%/packages/bash.scm \
> + %D%/packages/bbs.scm \
> %D%/packages/bdw-gc.scm \
> %D%/packages/benchmark.scm \
> %D%/packages/bioinformatics.scm \
> diff --git a/gnu/packages/bbs.scm b/gnu/packages/bbs.scm
> new file mode 100644
> index 000000000..894c64721
> --- /dev/null
> +++ b/gnu/packages/bbs.scm
> @@ -0,0 +1,75 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages bbs)
> + #:use-module (gnu packages)
> + #:use-module (gnu packages admin)
> + #:use-module (gnu packages base)
> + #:use-module (gnu packages perl)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix packages)
> + #:use-module (guix download)
> + #:use-module (guix build-system gnu))
> +
> +(define-public bbs100
> + (package
> + (name "bbs100")
> + (version "3.3.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "http://www.heiho.net/bbs100/"
> + name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1wjqyxw5wpxgzwx83vx2c56v0jjq62bsj1xn4livm0crjbi4mdqb"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:test-target "test"
> + #:parallel-build? #f
> + #:phases
> + ;; FIXME: the install phase creates a symlink 'bin' to 'bin-3.3.1'.
> + ;; FIXME: the log directory is hardcoded without prefix.

It is my understanding that we need a service to run bbs100 anyway to see if it run.
It builds and make checks alright.

Toggle quote (34 lines)
> + (modify-phases %standard-phases
> + (add-before 'configure 'patch-param-file
> + (lambda _
> + (substitute* "etc/param"
> + (("/usr/share/zoneinfo/") "")
> + (("^zoneinfodir")
> + (string-append "zoneinfodir "
> + (assoc-ref %build-inputs "tzdata")
> + "/share/zoneinfo")))
> + #t))
> + (add-before 'configure 'chdir
> + (lambda _
> + (chdir "src")
> + #t)))))
> + (inputs
> + `(("perl" ,perl)))
> + (native-inputs
> + `(("tzdata" ,tzdata)
> + ("inetutils" ,inetutils)))
> + (home-page "http://www.heiho.net/bbs100/")
> + (synopsis "DOC style telnet BBS")
> + (description
> + "@code{bbs100} is a @dfn{Bulletin Board System} (BBS) in the style of
> +DOC (which remotely resembles @code{Citadel}).
> +It is a single process daemon that handles all connections at once, while
> +consuming very low cpu resources (< 1%). Bbs100 can handle over a thousand
> +simultaneous users, is highly customizable, easy to setup, and has
> +many configurable features.")
> + (license license:gpl2+)))
> --
> 2.12.2
>


N
(address . guix-patches@gnu.org)
20170616114655.j7lbngadj5i45r4k@abyayala
Attachment: file
C
C
Christopher Baines wrote on 19 Mar 2018 09:19
control message for bug #26899
(address . control@debbugs.gnu.org)
87lgeo5vf8.fsf@cbaines.net
tags 26899 patch
Z
Z
zimoun wrote on 14 Sep 2020 18:19
Re: bug#26899: bbs100
(address . guix-patches@gnu.org)
87mu1sqqk3.fsf@gmail.com
Dear,

On Fri, 12 May 2017 at 17:34, ng0 <ng0@pragmatique.xyz> wrote:
Toggle quote (18 lines)
> This adds bbs100. For possible past reviews search the guix-devel@gnu.org archive.
> --
> https://pragmatique.xyz
> PGP: https://people.pragmatique.xyz/ng0/
>
> From 09746bd8021235c7c27bae10b4574011ea4e7f2b Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 17 Sep 2016 00:37:52 +0000
> Subject: [PATCH] gnu: Add bbs100.
>
> * gnu/packages/bbs.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add bbs.scm.
> ---
> gnu/local.mk | 1 +
> gnu/packages/bbs.scm | 75 ++++++++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 76 insertions(+)
> create mode 100644 gnu/packages/bbs.scm

What is the status of this old patch? Does it make to review it?


Toggle quote (93 lines)
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 8599e6d3a..e75058d29 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -63,6 +63,7 @@ GNU_SYSTEM_MODULES = \
> %D%/packages/backup.scm \
> %D%/packages/base.scm \
> %D%/packages/bash.scm \
> + %D%/packages/bbs.scm \
> %D%/packages/bdw-gc.scm \
> %D%/packages/benchmark.scm \
> %D%/packages/bioinformatics.scm \
> diff --git a/gnu/packages/bbs.scm b/gnu/packages/bbs.scm
> new file mode 100644
> index 000000000..894c64721
> --- /dev/null
> +++ b/gnu/packages/bbs.scm
> @@ -0,0 +1,75 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages bbs)
> + #:use-module (gnu packages)
> + #:use-module (gnu packages admin)
> + #:use-module (gnu packages base)
> + #:use-module (gnu packages perl)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix packages)
> + #:use-module (guix download)
> + #:use-module (guix build-system gnu))
> +
> +(define-public bbs100
> + (package
> + (name "bbs100")
> + (version "3.3.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "http://www.heiho.net/bbs100/"
> + name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1wjqyxw5wpxgzwx83vx2c56v0jjq62bsj1xn4livm0crjbi4mdqb"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:test-target "test"
> + #:parallel-build? #f
> + #:phases
> + ;; FIXME: the install phase creates a symlink 'bin' to 'bin-3.3.1'.
> + ;; FIXME: the log directory is hardcoded without prefix.
> + (modify-phases %standard-phases
> + (add-before 'configure 'patch-param-file
> + (lambda _
> + (substitute* "etc/param"
> + (("/usr/share/zoneinfo/") "")
> + (("^zoneinfodir")
> + (string-append "zoneinfodir "
> + (assoc-ref %build-inputs "tzdata")
> + "/share/zoneinfo")))
> + #t))
> + (add-before 'configure 'chdir
> + (lambda _
> + (chdir "src")
> + #t)))))
> + (inputs
> + `(("perl" ,perl)))
> + (native-inputs
> + `(("tzdata" ,tzdata)
> + ("inetutils" ,inetutils)))
> + (home-page "http://www.heiho.net/bbs100/")
> + (synopsis "DOC style telnet BBS")
> + (description
> + "@code{bbs100} is a @dfn{Bulletin Board System} (BBS) in the style of
> +DOC (which remotely resembles @code{Citadel}).
> +It is a single process daemon that handles all connections at once, while
> +consuming very low cpu resources (< 1%). Bbs100 can handle over a thousand
> +simultaneous users, is highly customizable, easy to setup, and has
> +many configurable features.")
> + (license license:gpl2+)))
R
R
Ricardo Wurmus wrote on 14 Sep 2020 18:57
Re: [bug#26899] bbs100
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 26899@debbugs.gnu.org)
87imcgxpmv.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (21 lines)
> On Fri, 12 May 2017 at 17:34, ng0 <ng0@pragmatique.xyz> wrote:
>> This adds bbs100. For possible past reviews search the guix-devel@gnu.org archive.
>> --
>> https://pragmatique.xyz
>> PGP: https://people.pragmatique.xyz/ng0/
>>
>> From 09746bd8021235c7c27bae10b4574011ea4e7f2b Mon Sep 17 00:00:00 2001
>> From: ng0 <ng0@we.make.ritual.n0.is>
>> Date: Sat, 17 Sep 2016 00:37:52 +0000
>> Subject: [PATCH] gnu: Add bbs100.
>>
>> * gnu/packages/bbs.scm: New file.
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Add bbs.scm.
>> ---
>> gnu/local.mk | 1 +
>> gnu/packages/bbs.scm | 75 ++++++++++++++++++++++++++++++++++++++++++++++++++++
>> 2 files changed, 76 insertions(+)
>> create mode 100644 gnu/packages/bbs.scm
>
> What is the status of this old patch? Does it make to review it?

The source code has disappeared and the home page says that it’s
deprecated.

I’m not opposed to adding it, though perhaps not in its own module.
But if the only person interested in adding it no longer cares about it,
I think we can close this issue.

--
Ricardo
Z
Z
zimoun wrote on 14 Sep 2020 19:12
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 26899-done@debbugs.gnu.org)
CAJ3okZ2doPk3YnB37P24NFm5rMh0Ne-qZcOkDczTwZ5eOa9Z-A@mail.gmail.com
Dear,

Thank you for your inputs.

On Mon, 14 Sep 2020 at 18:56, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (7 lines)
> The source code has disappeared and the home page says that it’s
> deprecated.
>
> I’m not opposed to adding it, though perhaps not in its own module.
> But if the only person interested in adding it no longer cares about it,
> I think we can close this issue.

Closing.

Cheers,
simon
Closed
?