[PATCH] python-tryton (with no modules)

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Catonano
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Catonano
Severity
normal
C
C
Catonano wrote on 8 Apr 2017 14:17
(address . guix-patches@gnu.org)
CAJ98PDw1Rxy_ag6gHgyNK5ejyqTDXuaLtsYMfEUBbc=QX7JxNw@mail.gmail.com
Tryton has modules and without any module packaged, it will do nothing

But at least you can launch it and test it, you can use it for packkaging
the missing modules.

Also a service would be useful. But in order to write a service, the server
packkage has to be in already.

This is supposedly the basis for GNUealth, a notable GNU project

Gnuealth is a collection of Tryton modules and some specific Tryton
configurations. I just have to check if the versions are compatible

Thanks
Attachment: file
Attachment: series.patch
A
A
Arun Isaac wrote on 8 May 2017 16:33
(address . 26401@debbugs.gnu.org)
285e9165.AEMAKF1MYlQAAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZEIIR@mailjet.com
Thanks for the patch set!

I haven't properly tested the package yet. The following are just my
initial reactions and questions. This patch review will take a few
iterations. Do bear with me.

Toggle quote (8 lines)
> Tryton has modules and without any module packaged, it will do nothing
>
> But at least you can launch it and test it, you can use it for packkaging
> the missing modules.
>
> Also a service would be useful. But in order to write a service, the server
> packkage has to be in already.

Agreed.

Toggle quote (2 lines)
> This is supposedly the basis for GNUealth, a notable GNU project

GNU Health usually lags behind the latest Tryon, and currently runs on
Tryton 3.8. We will have to create a package for Tryton 3.8 as
well. This can just inherit from the latest tryton package, and modify
only the `version' and `source' fields. Could you do this?

Toggle quote (5 lines)
> From e42a727312a454aeb19e07cfec6cbb03fe18e183 Mon Sep 17 00:00:00 2001
> From: humanitiesNerd <catonano@gmail.com>
> Date: Tue, 28 Mar 2017 12:25:06 +0200
> Subject: [PATCH 1/5] gnu: Add python-sql python2-sql.

It is enough to mention only python-sql here.

Toggle quote (2 lines)
> * gnu/packages/python.scm (python-sql python2-sql): New variables.

Please put a comma between python-sql and python2-sql.

Toggle quote (5 lines)
> +(define-public python-sql
> + (package
> + (name "python-sql")
> + (version "0.8")

The latest version of python-sql is 0.9.

Toggle quote (4 lines)
> + (uri (pypi-uri
> + "python-sql"
> + version))

Could you put these on the same line?

Toggle quote (12 lines)
> +(define-public python-genshi
> + (package
> + (name "python-genshi")
> + (version "0.7")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://ftp.edgewall.org/pub/genshi/Genshi-"
> + version
> + ".tar.gz"))

Please put version ".tar.gz" on the same line.

Toggle quote (14 lines)
> + (patches
> + (search-patches
> + ;; The first 4 patches are in the master branch upstream.
> + ;; see this as a reference https://genshi.edgewall.org/ticket/582
> + ;; The last 2 are NOT in any branch.
> + ;; They were sent as attachments to a ticket opened at
> + ;; https://genshi.edgewall.org/ticket/602#no1
> + "python-genshi-stripping-of-unsafe-script-tags-Python-3.4.patch"
> + "python-genshi-Disable-the-speedups-C-extension-on-CPython-3.3-sinc.patch"
> + "python-genshi-isstring-helper.patch"
> + "python-genshi-Add-support-for-Python-3.4-AST-support-for-NameConst.patch"
> + "python-genshi-fixing-the-tests-on-python35.patch"
> + "python-genshi-buildable-on-python27-too.patch"))

Why do we need these patches? Is the release tarball not sufficient?

Toggle quote (4 lines)
> + (propagated-inputs
> + `(("lxml" ,python2-lxml)
> + ("genshi" ,python2-genshi)))

Please put the full names of these inputs -- I mean "python-lxml"
instead of "lxml", "python-genshi" instead of "genshi", and so on.

Toggle quote (4 lines)
> +(define-public python-trytond
> + (package
> + (name "python-trytond")

As far as I understand, trytond is an application, not a python
library. Only python libraries should have the "python-" prefix. So,
this package would just be called "trytond".

Toggle quote (2 lines)
> + (version "4.2.3")

The latest version of tryton is 4.4.

Toggle quote (8 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri
> + "trytond"
> + version
> + ".tar.gz"))

We should use the tarballs available on the tryton website.

Toggle quote (8 lines)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-before 'check 'preparations
> + (lambda* _
> + ;; this is used in the tests
> + (setenv "DB_NAME" ":memory:"))))))

Though this is shorter, I think it would be clearer to replace the
`check' phase altogether.

Toggle quote (13 lines)
> + (propagated-inputs
> + `(("polib" ,python-polib)
> + ("dateutil" ,python-dateutil)
> + ("werkzeug" ,python-werkzeug)
> + ("wrapt" ,python-wrapt)
> + ("python-sql" ,python-sql)
> + ("genshi" ,python-genshi)
> + ("relatorio" ,python-relatorio)
> + ("lxml" ,python-lxml)
> + ;; there's no pyton-mysql in Guix right now
> + ;; so psycopg (postgresql) only for now
> + ("psycopg" ,python-psycopg2)))

If trytond is only an application, these can just be `inputs', not
`propagated-inputs'. For applications, the python build system wraps the
executables with the correct PYTHONPATH environment variable.

Toggle quote (2 lines)
> + (license license:lgpl3)))

Tryton is GPL3.

Toggle quote (3 lines)
> +(define-public python2-trytond
> + (package-with-python2 python-trytond))

No need for python2-trytond if trytond is just an application.

Toggle quote (6 lines)
> +;; this depends on pygtk that is available or python@2 only
> +(define-public python2-tryton
> + (package
> + (name "python2-tryton")
> + (version "4.2.4")

Latest version if 4.4

Toggle quote (5 lines)
> + (uri (pypi-uri
> + "tryton"
> + version
> + ".tar.gz"))

We should use the tarballs available on the tryton website.

Toggle quote (5 lines)
> + (propagated-inputs
> + `(("chardet" ,python2-chardet)
> + ("dateutil" ,python2-dateutil)
> + ("pygtk" ,python2-pygtk)))

For an application, these can just be `inputs'.
R
R
Ricardo Wurmus wrote on 10 May 2017 08:08
control message for bug #26401
(address . control@debbugs.gnu.org)
df4cc631-7e5c-4a59-b8fb-5cc5d9d9b532@HTCATWO.mdc-berlin.net
tags 26401 moreinfo
C
C
Catonano wrote on 15 May 2017 08:39
Re: bug#26401: [PATCH] python-tryton (with no modules)
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDyLt8pZBfmSK8UXpS4gpdYte5Fn_O4dRsUdq-VtBFrQcA@mail.gmail.com
2017-05-08 16:33 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (4 lines)
>
> Thanks for the patch set!
>

Thank you or reviiewing it !

Just a note: in the future please add me as a recipient o the message,
don't send iit only to the debbugs ticket.

In fact I was missing your reply and I saw it today just by chance !
I missed it for 8 days !
I'm sorry !


Toggle quote (5 lines)
> I haven't properly tested the package yet. The following are just my
> initial reactions and questions. This patch review will take a few
> iterations. Do bear with me.
>

I will bear with you !
Just give me some time to go thorugh your observations !
I'll be back to you in a while !

Thanks again !
Attachment: file
A
A
Arun Isaac wrote on 15 May 2017 15:19
(name . Catonano)(address . catonano@gmail.com)(address . 26401@debbugs.gnu.org)
6514d229.AEAAKLnhd74AAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZGasA@mailjet.com
Toggle quote (7 lines)
> Just a note: in the future please add me as a recipient o the message,
> don't send iit only to the debbugs ticket.
>
> In fact I was missing your reply and I saw it today just by chance !
> I missed it for 8 days !
> I'm sorry !

Sure, will do!
C
C
Catonano wrote on 15 May 2017 21:17
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDw=6r6zaW6ab8dqfpwK0Ce=TC8hBb5qFTiHwP+if9cESw@mail.gmail.com
2017-05-08 16:33 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (8 lines)
>
> Thanks for the patch set!
>
> I haven't properly tested the package yet. The following are just my
> initial reactions and questions. This patch review will take a few
> iterations. Do bear with me.
>

:-)


Toggle quote (20 lines)
>
> > Tryton has modules and without any module packaged, it will do nothing
> >
> > But at least you can launch it and test it, you can use it for packkaging
> > the missing modules.
> >
> > Also a service would be useful. But in order to write a service, the
> server
> > packkage has to be in already.
>
> Agreed.
>
> > This is supposedly the basis for GNUealth, a notable GNU project
>
> GNU Health usually lags behind the latest Tryon, and currently runs on
> Tryton 3.8. We will have to create a package for Tryton 3.8 as
> well. This can just inherit from the latest tryton package, and modify
> only the `version' and `source' fields. Could you do this?
>

Yes, I think I could do it.

Bt if you don't mind I'd liie to delay this.

When and if we'll have the current Tryton thhen we'll see.


Toggle quote (9 lines)
>
> > From e42a727312a454aeb19e07cfec6cbb03fe18e183 Mon Sep 17 00:00:00 2001
> > From: humanitiesNerd <catonano@gmail.com>
> > Date: Tue, 28 Mar 2017 12:25:06 +0200
> > Subject: [PATCH 1/5] gnu: Add python-sql python2-sql.
>
> It is enough to mention only python-sql here.
>

done


Toggle quote (6 lines)
>
> > * gnu/packages/python.scm (python-sql python2-sql): New variables.
>
> Please put a comma between python-sql and python2-sql.
>

done


Toggle quote (9 lines)
>
> > +(define-public python-sql
> > + (package
> > + (name "python-sql")
> > + (version "0.8")
>
> The latest version of python-sql is 0.9.
>

updated


Toggle quote (8 lines)
>
> > + (uri (pypi-uri
> > + "python-sql"
> > + version))
>
> Could you put these on the same line?
>

done


Toggle quote (16 lines)
>
> > +(define-public python-genshi
> > + (package
> > + (name "python-genshi")
> > + (version "0.7")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (string-append
> > + "https://ftp.edgewall.org/pub/genshi/Genshi-"
> > + version
> > + ".tar.gz"))
>
> Please put version ".tar.gz" on the same line.
>

done


Toggle quote (22 lines)
>
> > + (patches
> > + (search-patches
> > + ;; The first 4 patches are in the master branch upstream.
> > + ;; see this as a reference https://genshi.edgewall.org/ti
> cket/582
> > + ;; The last 2 are NOT in any branch.
> > + ;; They were sent as attachments to a ticket opened at
> > + ;; https://genshi.edgewall.org/ticket/602#no1
> > + "python-genshi-stripping-of-unsafe-script-tags-Python-3.4.p
> atch"
> > + "python-genshi-Disable-the-speedups-C-extension-on-CPython-
> 3.3-sinc.patch"
> > + "python-genshi-isstring-helper.patch"
> > + "python-genshi-Add-support-for-Python-3.4-AST-support-for-
> NameConst.patch"
> > + "python-genshi-fixing-the-tests-on-python35.patch"
> > + "python-genshi-buildable-on-python27-too.patch"))
>
> Why do we need these patches? Is the release tarball not sufficient?
>

No, the current tarball is not suficient.
Genshi builds with python 3.3 only. With python 3.4 and 3.5 it doesn't
build.

This is mainly due to a change in thhe C API so a part of Genshi tat was
written in C has to be re-written adgering to the new API

The authors claim to need more time to do this.

The Genshi issue tracker reports all this infomration, I linked the
relevant issues in the comments

Admittedly I don't understand what these patches do. They're too entrenched
in the Genshi code base

I shamelessly copied them from the Fedora package definition
See here

I understand that they made an effort to make their Genshi package
compatible with pythhon 3.4 too and that is not necessary or Guix

But it's too complicated for me to excise the support for python 3.4


Toggle quote (9 lines)
>
> > + (propagated-inputs
> > + `(("lxml" ,python2-lxml)
> > + ("genshi" ,python2-genshi)))
>
> Please put the full names of these inputs -- I mean "python-lxml"
> instead of "lxml", "python-genshi" instead of "genshi", and so on.
>

done


Toggle quote (9 lines)
>
> > +(define-public python-trytond
> > + (package
> > + (name "python-trytond")
>
> As far as I understand, trytond is an application, not a python
> library. Only python libraries should have the "python-" prefix.


Oh, I didn't know this. Thanks


Toggle quote (4 lines)
> So,
> this package would just be called "trytond".
>

done


Toggle quote (6 lines)
>
> > + (version "4.2.3")
>
> The latest version of tryton is 4.4.
>

updated


Toggle quote (13 lines)
>
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (pypi-uri
> > + "trytond"
> > + version
> > + ".tar.gz"))
>
> We should use the tarballs available on the tryton website.
> https://downloads.tryton.org/4.4/


done


Toggle quote (14 lines)
>
>
> > + (arguments
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (add-before 'check 'preparations
> > + (lambda* _
> > + ;; this is used in the tests
> > + (setenv "DB_NAME" ":memory:"))))))
>
> Though this is shorter, I think it would be clearer to replace the
> `check' phase altogether.
>

mmm I'm not sure I can do this.
I don't know much about setuptools, eggs and the such
The check phase of the python build system is quite articulated, I don't
feel like messing with it

Feel free to rearrange this yourself as you see fit.



Toggle quote (19 lines)
>
> > + (propagated-inputs
> > + `(("polib" ,python-polib)
> > + ("dateutil" ,python-dateutil)
> > + ("werkzeug" ,python-werkzeug)
> > + ("wrapt" ,python-wrapt)
> > + ("python-sql" ,python-sql)
> > + ("genshi" ,python-genshi)
> > + ("relatorio" ,python-relatorio)
> > + ("lxml" ,python-lxml)
> > + ;; there's no pyton-mysql in Guix right now
> > + ;; so psycopg (postgresql) only for now
> > + ("psycopg" ,python-psycopg2)))
>
> If trytond is only an application, these can just be `inputs', not
> `propagated-inputs'. For applications, the python build system wraps the
> executables with the correct PYTHONPATH environment variable.
>

Right, thanks.
Done



Toggle quote (6 lines)
>
> > + (license license:lgpl3)))
>
> Tryton is GPL3.
>

fixed


Toggle quote (7 lines)
>
> > +(define-public python2-trytond
> > + (package-with-python2 python-trytond))
>
> No need for python2-trytond if trytond is just an application.
>

erased


Toggle quote (10 lines)
>
> > +;; this depends on pygtk that is available or python@2 only
> > +(define-public python2-tryton
> > + (package
> > + (name "python2-tryton")
> > + (version "4.2.4")
>
> Latest version if 4.4
>

updated


Toggle quote (10 lines)
>
> > + (uri (pypi-uri
> > + "tryton"
> > + version
> > + ".tar.gz"))
>
> We should use the tarballs available on the tryton website.
> https://downloads.tryton.org/4.4/


done


Toggle quote (10 lines)
>
>
> > + (propagated-inputs
> > + `(("chardet" ,python2-chardet)
> > + ("dateutil" ,python2-dateutil)
> > + ("pygtk" ,python2-pygtk)))
>
> For an application, these can just be `inputs'.
>

done

Ok, so this is the first iteration.
I'm ready or the next one ?
Attachment: file
Attachment: series.patch
A
A
Arun Isaac wrote on 16 May 2017 19:12
(name . Catonano)(address . catonano@gmail.com)(address . 26401@debbugs.gnu.org)
34c2e718.AEMAKXA0lrEAAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZGzM6@mailjet.com
Toggle quote (8 lines)
>> GNU Health usually lags behind the latest Tryon, and currently runs on
>> Tryton 3.8. We will have to create a package for Tryton 3.8 as
>> well. This can just inherit from the latest tryton package, and modify
>> only the `version' and `source' fields. Could you do this?
>
> Yes, I think I could do it. Bt if you don't mind I'd liie to delay
> this.

Sure!

tryton, and tryton related packages (especially the server side modules,
GNU Health, etc.) are numerous and complicated enough to deserve their
own separate file. You can put them in gnu/packages/tryton.scm.

Toggle quote (23 lines)
> No, the current tarball is not suficient. Genshi builds with python
> 3.3 only. With python 3.4 and 3.5 it doesn't build.
>
> This is mainly due to a change in thhe C API so a part of Genshi tat was
> written in C has to be re-written adgering to the new API
>
> The authors claim to need more time to do this.
>
> The Genshi issue tracker reports all this infomration, I linked the
> relevant issues in the comments
>
> Admittedly I don't understand what these patches do. They're too entrenched
> in the Genshi code base
>
> I shamelessly copied them from the Fedora package definition
> See here
> http://pkgs.fedoraproject.org/cgit/rpms/python-genshi.git/snapshot/python-genshi-f25.tar.gz
>
> I understand that they made an effort to make their Genshi package
> compatible with pythhon 3.4 too and that is not necessary or Guix
>
> But it's too complicated for me to excise the support for python 3.4

For all practical purposes, I think it's best to assume that there is no
python3 genshi package. Instead, we should simply package
python2-genshi, and let the authors fix their python3 package. In any
case, tryton needs only python2-genshi. So, there is no urgent need for
the python3 genshi package. I guess, this also means that there will be
no python3 relatorio package.

Toggle quote (6 lines)
>> > + (arguments
>> > + `(#:phases
>> > + (modify-phases %standard-phases
>> > + (add-before 'check 'preparations
>> > + (lambda* _

Since you're not using any of `lambda*' features, you can just use `lambda' here.

Toggle quote (13 lines)
>> > + ;; this is used in the tests
>> > + (setenv "DB_NAME" ":memory:"))))))
>>
>> Though this is shorter, I think it would be clearer to replace the
>> `check' phase altogether.
>
> mmm I'm not sure I can do this.
> I don't know much about setuptools, eggs and the such
> The check phase of the python build system is quite articulated, I don't
> feel like messing with it
>
> Feel free to rearrange this yourself as you see fit.

Actually, this is not a big deal. We'll leave it as it is. If necessary,
I'll fix it before pushing.

Toggle quote (17 lines)
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 57a67de41..f1ef53e1a 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -14622,3 +14622,25 @@ substitute for redis.")
>
> (define-public python2-fakeredis
> (package-with-python2 python-fakeredis))
> +
> +(define-public python-sql
> + (package
> + (name "python-sql")
> + (version "0.8")
> + (source
> + (origin
> + (method url-fetch)

...

Toggle quote (4 lines)
> + (uri (pypi-uri
> + "python-sql"
> + version))

Could you put these on the same line?

Toggle quote (19 lines)
> +;; this package depends on python-genshi that
> +;; can be buit only with python-2
> +;; so providing a python33 version of this
> +;; is difficult
> +(define-public python2-relatorio
> + (package
> + (name "python-relatorio")
> + (version "0.6.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "relatorio" version))
> + (sha256
> + (base32
> + "0lincq79mzgazwd9gh41dybjh9c3n87r83pl8nk3j79aihyfk84z"))))
> + (propagated-inputs
> + `(("lxml" ,python2-lxml)
> + ("genshi" ,python2-genshi)))

Use full names here, including the python version in the package name. I
mean the full name of "lxml" is "python2-lxml", not "python-lxml". Make
similar changes wherever applicable.

Also, in several places, there was a typo saying "pyton" instead of
"python". Please fix those.

Toggle quote (7 lines)
> From b71cd2bd664e530dfabb3e558db15934f0ec204a Mon Sep 17 00:00:00 2001
> From: humanitiesNerd <catonano@gmail.com>
> Date: Thu, 6 Apr 2017 09:37:59 +0200
> Subject: [PATCH 4/5] gnu: Add python-trytond.
>
> * gnu/packages/python.scm (python-trytond, python2-trytond): New variables.

Change this commit message replacing python-trytond with trytond as
discussed earlier. Make a similar change for the commit message
involving python-tryton (the client).
C
C
Catonano wrote on 16 May 2017 20:36
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDwXQ-crQ2F3pABn7BH89iZpb-98aLfq-6avGnBzMF7xBA@mail.gmail.com
2017-05-16 19:12 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (8 lines)
>
> Sure!
>
> tryton, and tryton related packages (especially the server side modules,
> GNU Health, etc.) are numerous and complicated enough to deserve their
> own separate file. You can put them in gnu/packages/tryton.scm.
>

Note taken. I will.

For all practical purposes, I think it's best to assume that there is no
Toggle quote (7 lines)
> python3 genshi package. Instead, we should simply package
> python2-genshi, and let the authors fix their python3 package. In any
> case, tryton needs only python2-genshi. So, there is no urgent need for
> the python3 genshi package. I guess, this also means that there will be
> no python3 relatorio package.
>

I'm afraid you're right.
Sigh. I devolved way too much effort in packaging Genshi :-/



Toggle quote (10 lines)
> >> > + (arguments
> >> > + `(#:phases
> >> > + (modify-phases %standard-phases
> >> > + (add-before 'check 'preparations
> >> > + (lambda* _
>
> Since you're not using any of `lambda*' features, you can just use
> `lambda' here.
>

note taken



Actually, this is not a big deal. We'll leave it as it is. If necessary,
Toggle quote (3 lines)
> I'll fix it before pushing.
>

Thanks


Toggle quote (27 lines)
>
> > diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> > index 57a67de41..f1ef53e1a 100644
> > --- a/gnu/packages/python.scm
> > +++ b/gnu/packages/python.scm
> > @@ -14622,3 +14622,25 @@ substitute for redis.")
> >
> > (define-public python2-fakeredis
> > (package-with-python2 python-fakeredis))
> > +
> > +(define-public python-sql
> > + (package
> > + (name "python-sql")
> > + (version "0.8")
> > + (source
> > + (origin
> > + (method url-fetch)
>
> ...
>
> > + (uri (pypi-uri
> > + "python-sql"
> > + version))
>
> Could you put these on the same line?
>

[...]


Toggle quote (9 lines)
> > + (propagated-inputs
> > + `(("lxml" ,python2-lxml)
> > + ("genshi" ,python2-genshi)))
>
> Use full names here, including the python version in the package name. I
> mean the full name of "lxml" is "python2-lxml", not "python-lxml". Make
> similar changes wherever applicable.
>

Ouch !
I owe you an apology, here

I mistakenly sent you the same patch file as before

I'm sorry :-/



Toggle quote (5 lines)
>
> Also, in several places, there was a typo saying "pyton" instead of
> "python". Please fix those.
>

Gosh.
My keyboard si defective. I've been pleading with my technician for months
now.
I try to pay attention but more errors slip than I'd like
Sorry :-/


Toggle quote (9 lines)
>
> > * gnu/packages/python.scm (python-trytond, python2-trytond): New
> variables.
>
> Change this commit message replacing python-trytond with trytond as
> discussed earlier. Make a similar change for the commit message
> involving python-tryton (the client).
>

Give me me some time to mourn my Genshi package.
I will send a new series (really, this time) soonish

Thanks
Attachment: file
C
C
Catonano wrote on 16 May 2017 20:41
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDwXbMXdE4JmEN+Qu_f5jHK3qCsoEQ=8cZrQcgY4SX8Eyw@mail.gmail.com
2017-05-16 19:12 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (5 lines)
>
> In any
> case, tryton needs only python2-genshi.


Out of curiosity: how can you say this ?
The Fedora package uses both Genshi and Relatorio with Python 3
Attachment: file
A
A
Arun Isaac wrote on 17 May 2017 07:54
(name . Catonano)(address . catonano@gmail.com)(address . 26401@debbugs.gnu.org)
9ad1f5d3.AEEAKq6kKpgAAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZG-Wd@mailjet.com
Toggle quote (5 lines)
>> In any case, tryton needs only python2-genshi.
>
> Out of curiosity: how can you say this ?
> The Fedora package uses both Genshi and Relatorio with Python 3

I was looking at the Arch Linux packages in the AUR as a reference. Arch
has tryton packaged with python 2. But, I just checked the "Programming
Language" metadata in the setup.py of the tryton and trytond source
tarballs. It seems that tryton supports python 2.7, while trytond
supports python 2.7 and 3.5.

So, yes, you're right. At least for trytond, we could use python
3.5. But, considering the complexity of packaging (patching and all)
genshi for python 3.5, I think we should just wait for the python3.5
genshi to be properly ready and use python2 in the meantime. WDYT?
C
C
Catonano wrote on 17 May 2017 09:45
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDw3uwKwAKzCj88gQcOW=uLs+4F4ULnRCbQc+gVB_SaRnA@mail.gmail.com
2017-05-17 7:54 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (18 lines)
>
> >> In any case, tryton needs only python2-genshi.
> >
> > Out of curiosity: how can you say this ?
> > The Fedora package uses both Genshi and Relatorio with Python 3
>
> I was looking at the Arch Linux packages in the AUR as a reference. Arch
> has tryton packaged with python 2. But, I just checked the "Programming
> Language" metadata in the setup.py of the tryton and trytond source
> tarballs. It seems that tryton supports python 2.7, while trytond
> supports python 2.7 and 3.5.
>
> So, yes, you're right. At least for trytond, we could use python
> 3.5. But, considering the complexity of packaging (patching and all)
> genshi for python 3.5, I think we should just wait for the python3.5
> genshi to be properly ready and use python2 in the meantime. WDYT?
>

I know that the Guix poliicy is to let upstream do its homework.

But in this case I would keep the patched Genshi

In fact, if you read the most recent thread in the Genshi google group:


you can deduce that:


1. the patches have been used by mainstream distros for almost 2 years
now, if I understand correctly
2. the development of Genshi is stalled. The last contribution (adding
travis) was 2 years ago

what is being deployed by other distros already is, substantially, the new
Genshi release

And unless someone steps up in maintaning the project, there won't be a
formal release anytime soon
Attachment: file
A
A
Arun Isaac wrote on 18 May 2017 19:49
(name . Catonano)(address . catonano@gmail.com)
ecc4ab1c.ADsAALmm2EMAAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZHd6n@mailjet.com
Toggle quote (21 lines)
> I know that the Guix poliicy is to let upstream do its homework.
>
> But in this case I would keep the patched Genshi
>
> In fact, if you read the most recent thread in the Genshi google group:
>
> https://groups.google.com/forum/#!forum/genshi
>
> you can deduce that:
>
> 1. the patches have been used by mainstream distros for almost 2 years
> now, if I understand correctly
> 2. the development of Genshi is stalled. The last contribution (adding
> travis) was 2 years ago

> what is being deployed by other distros already is, substantially, the new
> Genshi release
>
> And unless someone steps up in maintaning the project, there won't be a
> formal release anytime soon

Oh, I thought the next genshi release was just around the corner. I
didn't realize that development was stalled. Ok, then. If other distros
are using these patches without problems, let's also have python3 genshi
and relatorio packages.

But, let's build trytond with python2. GNU Health still needs trytond
3.8, and trytond 3.8 only supports python2.
C
C
Catonano wrote on 18 May 2017 20:03
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDxtrAXYA7ofhsWa4_jpGUpT5Lb8m5im0J_HA8OwYoxk_g@mail.gmail.com
2017-05-18 19:49 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (32 lines)
>
> > I know that the Guix poliicy is to let upstream do its homework.
> >
> > But in this case I would keep the patched Genshi
> >
> > In fact, if you read the most recent thread in the Genshi google group:
> >
> > https://groups.google.com/forum/#!forum/genshi
> >
> > you can deduce that:
> >
> > 1. the patches have been used by mainstream distros for almost 2 years
> > now, if I understand correctly
> > 2. the development of Genshi is stalled. The last contribution (adding
> > travis) was 2 years ago
>
> > what is being deployed by other distros already is, substantially, the
> new
> > Genshi release
> >
> > And unless someone steps up in maintaning the project, there won't be a
> > formal release anytime soon
>
> Oh, I thought the next genshi release was just around the corner. I
> didn't realize that development was stalled. Ok, then. If other distros
> are using these patches without problems, let's also have python3 genshi
> and relatorio packages.
>
> But, let's build trytond with python2. GNU Health still needs trytond
> 3.8, and trytond 3.8 only supports python2.
>

Ok

I'll send you a new version of my patches bundle soonish.

Let's say tomorrow

Thanks !
Attachment: file
C
C
Catonano wrote on 20 May 2017 09:39
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401@debbugs.gnu.org)
CAJ98PDxsJxcUQuJ_8vh+vGiNJg=jUr+n83HZgC9yufykG7ZEQQ@mail.gmail.com
So, here I am

2017-05-18 19:49 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (10 lines)
>
> Oh, I thought the next genshi release was just around the corner. I
> didn't realize that development was stalled. Ok, then. If other distros
> are using these patches without problems, let's also have python3 genshi
> and relatorio packages.
>
> But, let's build trytond with python2. GNU Health still needs trytond
> 3.8, and trytond 3.8 only supports python2.
>

I though about this a bit more

Tryton is an autonomous framework, it can be used without GNUHealth and
with no relation to it

Someone might want to use it with python3.

I myself could be involved in a project that uses Trytond and has no
relationship whatsoever with GNUHealth.
This should be in september.

When and if I will package GNUHealth, we'll see how to arrange things

It might depend on python2-trytond or I might wait for a newer version that
depends on a current Tryton

So for now I send this as it was, with some corrections.

Please let me know
Thanks
Attachment: file
Attachment: series.patch
A
A
Arun Isaac wrote on 22 May 2017 23:13
(name . Catonano)(address . catonano@gmail.com)(address . 26401@debbugs.gnu.org)
c943397e.AEQAKqVSfPcAAAAAAAAAAAO8YckAAAACwQwAAAAAAAW9WABZI1SH@mailjet.com
Toggle quote (5 lines)
> Tryton is an autonomous framework, it can be used without GNUHealth and
> with no relation to it
>
> Someone might want to use it with python3.

Ok, fair enough. Let's build trytond with python3.

I have made many small improvements to your patchset. I think it is ready
to be pushed. But, do verify, and let me know. I could have missed
something or removed something you consider important. Please find the
new patchset attached.
Attachment: series.patch
I removed python2-trytond. When we want to package trytond 3.8 (for GNU
Health), we will simply create a variable `trytond-3.8' which inherits
from `trytond' and adds an argument to build against python2.
A
A
Arun Isaac wrote on 27 May 2017 16:21
(name . Catonano)(address . catonano@gmail.com)(address . 26401-done@debbugs.gnu.org)
c550bc84.AEMAKvi84IsAAAAAAAAAAAPFaP0AAAACwQwAAAAAAAW9WABZKYuO@mailjet.com
Pushed the final patchset with a few more minor corrections...! Thanks!
Closed
C
C
Catonano wrote on 27 May 2017 16:38
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 26401-done@debbugs.gnu.org)
CAJ98PDyH_MRDuDTB45ETkwo6-4JPBW3v5gTK06cXkx9i0rSJAA@mail.gmail.com
2017-05-27 16:21 GMT+02:00 Arun Isaac <arunisaac@systemreboot.net>:

Toggle quote (4 lines)
>
> Pushed the final patchset with a few more minor corrections...! Thanks!
>

thank you Arun, sorry or the delay in my answer, I was caught up in some
pressing activities !

Thanks !
Attachment: file
Closed
?