[PATCH 2/2] gnu: Add dovecot-libsodium-plugin.

  • Done
  • quality assurance status badge
Details
2 participants
  • contact.ng0
  • Ludovic Courtès
Owner
unassigned
Submitted by
contact.ng0
Severity
normal
C
C
contact.ng0 wrote on 28 Feb 2017 12:11
(address . guix-patches@gnu.org)(name . ng0)(address . contact.ng0@cryptolab.net)
20170228111147.5794-2-contact.ng0@cryptolab.net
From: ng0 <contact.ng0@cryptolab.net>

* gnu/packages/mail.scm (dovecot-libsodium-plugin): New variable.
---
gnu/packages/mail.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 47b4e7184..c34efac59 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1190,6 +1190,48 @@ How it works:
@end enumerate\n")
(license agpl3))))
+(define-public dovecot-libsodium-plugin
+ (let ((commit "044de73c01c35385df0105f6b387bec5d5317ce7")
+ (revision "1"))
+ (package
+ (name "dovecot-libsodium-plugin")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "13h07l7xy713zchnj2p9fhvq7fdl4zy1ai94li3ygkqjjj8hrgas"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("dovecot" ,dovecot)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)))
+ (arguments
+ `(#:tests? #f ;No tests exist.
+ #:configure-flags (list (string-append "--with-dovecot="
+ (assoc-ref %build-inputs "dovecot")
+ "/lib/dovecot"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
+ (synopsis "Libsodium password hashing schemes plugin for Dovecot")
+ (description
+ "@code{dovecot-libsodium-plugin} provides libsodium password
+hashing schemes plugin for @code{Dovecot}.")
+ (license gpl3+))))
+
(define-public isync
(package
(name "isync")
--
2.12.0
L
L
Ludovic Courtès wrote on 14 Mar 2017 10:22
(address . contact.ng0@cryptolab.net)(address . 25897@debbugs.gnu.org)
8760jcp60n.fsf@gnu.org
contact.ng0@cryptolab.net skribis:

Toggle quote (4 lines)
> From: ng0 <contact.ng0@cryptolab.net>
>
> * gnu/packages/mail.scm (dovecot-libsodium-plugin): New variable.

Applied, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 14 Mar 2017 10:22
control message for bug #25897
(address . control@debbugs.gnu.org)
874lywp60f.fsf@gnu.org
tags 25897 fixed
close 25897
?