[PATCH] gnu: Add emacs-pretty-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Kost
  • contact.ng0
Owner
unassigned
Submitted by
contact.ng0
Severity
normal
C
C
contact.ng0 wrote on 14 Feb 2017 19:38
(address . guix-patches@gnu.org)(name . ng0)(address . contact.ng0@cryptolab.net)
20170214183855.22441-1-contact.ng0@cryptolab.net
From: ng0 <contact.ng0@cryptolab.net>

* gnu/packages/emacs.scm (emacs-pretty-mode): New variable.
---
gnu/packages/emacs.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index df7f7869d..88417e65f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3778,3 +3778,23 @@ customizable by the user.")
Additionally it can display the number of unread emails in the
mode-line.")
(license license:gpl3+)))
+
+(define-public emacs-pretty-mode
+ (package
+ (name "emacs-pretty-mode")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/akatov/pretty-mode/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fan7m4vnqs8kpg7r54kx3g7faadkpkf9kzarfv8n57kq8w157pl"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/akatov/pretty-mode")
+ (synopsis "Redisplay parts of the buffer as Unicode symbols")
+ (description
+ "Emacs minor mode for redisplaying parts of the buffer as pretty symbols.")
+ (license license:gpl3+)))
--
2.11.1
A
A
Alex Kost wrote on 16 Feb 2017 10:48
control message for bug #25726
(address . control@debbugs.gnu.org)
87lgt6wjnz.fsf@gmail.com
tags 25726 fixed
close 25726
A
A
Alex Kost wrote on 16 Feb 2017 10:53
Re: bug#25726: [PATCH] gnu: Add emacs-pretty-mode.
(address . contact.ng0@cryptolab.net)(address . 25726@debbugs.gnu.org)
87h93uwjg6.fsf@gmail.com
contact.ng0@cryptolab.net (2017-02-14 18:38 +0000) wrote:

Toggle quote (7 lines)
> From: ng0 <contact.ng0@cryptolab.net>
>
> * gnu/packages/emacs.scm (emacs-pretty-mode): New variable.
> ---
> gnu/packages/emacs.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)

Applied as e967dd9, thanks!

--
Alex
?