segfault for non-root user

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Myles English
Owner
unassigned
Submitted by
Myles English
Severity
normal
M
M
Myles English wrote on 27 Apr 2016 22:44
(address . bug-guix@gnu.org)
874mam2355.fsf@gmail.com
Hello,

Just installed binary x86-64 nix on Arch Linux as per instructions here:


The install for root when well and the hello sample package installed
fine. Then I went to setup my user as described here:


but got a segfault at:

$ guix package -i glibc-locales

and in fact even just

$ guix

I don't know if this backtrace is useful but here it it:

» coredumpctl gdb /gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash
PID: 20982 (guix)
UID: 1000 (myles)
GID: 1000 (myles)
Signal: 11 (SEGV)
Timestamp: Wed 2016-04-27 21:19:50 BST (7min ago)
Command Line: /gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash /usr/local/bin/guix
Executable: /gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash
Control Group: /user.slice/user-1000.slice/session-c1.scope
Unit: session-c1.scope
Slice: user-1000.slice
Session: c1
Owner UID: 1000 (myles)
Boot ID: fe0b4d463dfb4886a15e7520cae37405
Machine ID: 2068a1f86eccfef4ce4bdf96000002f2
Hostname: bill
Coredump: /var/lib/systemd/coredump/core.guix.1000.fe0b4d463dfb4886a15e7520cae37405.20982.1461788390000000000000.lz4
Message: Process 20982 (guix) of user 1000 dumped core.
Stack trace of thread 20982:
#0 0x0000000000000000 n/a (n/a)

GNU gdb (GDB) 7.11
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash...(no debugging symbols found)...done.

warning: core file may not match specified executable file.
[New LWP 20982]

warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Core was generated by `/gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42/bin/bash /usr/local/bin'.
---Type <return> to continue, or q <return> to quit---
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x0000000000000000 in ?? ()
(gdb) bt
#0 0x0000000000000000 in ?? ()
#1 0x00007f36f1c6e4e5 in _dl_vdso_vsym () from /usr/lib/libc.so.6
#2 0x00007f36f1bf9827 in time () from /usr/lib/libc.so.6
#3 0x00007f36f27c1a68 in _dl_relocate_object ()
from /gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22/lib/ld-linux-x86-64.so.2
#4 0x00007f36f27b9df5 in dl_main () from /gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22/lib/ld-linux-x86-64.so.2
#5 0x00007f36f27cc355 in _dl_sysdep_start ()
from /gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22/lib/ld-linux-x86-64.so.2
#6 0x00007f36f27bac7a in _dl_start ()
from /gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22/lib/ld-linux-x86-64.so.2
#7 0x00007f36f27b6c48 in _start () from /gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22/lib/ld-linux-x86-64.so.2
#8 0x0000000000000002 in ?? ()
#9 0x00007fffb8c00cba in ?? ()
#10 0x00007fffb8c00cfb in ?? ()
#11 0x0000000000000000 in ?? ()
(gdb)

Myles
L
L
Ludovic Courtès wrote on 28 Apr 2016 14:00
(name . Myles English)(address . mylesenglish@gmail.com)(address . 23389@debbugs.gnu.org)
87oa8uhrig.fsf@gnu.org
Myles English <mylesenglish@gmail.com> skribis:

Toggle quote (17 lines)
> Just installed binary x86-64 nix on Arch Linux as per instructions here:
>
> http://www.gnu.org/software/guix/manual/guix.html#Binary-Installation
>
> The install for root when well and the hello sample package installed
> fine. Then I went to setup my user as described here:
>
> http://www.gnu.org/software/guix/manual/guix.html#Application-Setup
>
> but got a segfault at:
>
> $ guix package -i glibc-locales
>
> and in fact even just
>
> $ guix

Is LD_LIBRARY_PATH or LD_PRELOAD set in your environment?

What happens if you run:

env -i `type -P guix` --help

What does “info files” say in GDB?

Thank you for the bug report!

Ludo’.
M
M
Myles English wrote on 29 Apr 2016 12:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 23389@debbugs.gnu.org)
87inz0ras5.fsf@gmail.com
Ludo’,

Ludovic Courtès writes:

Toggle quote (21 lines)
> Myles English <mylesenglish@gmail.com> skribis:
>
>> Just installed binary x86-64 nix on Arch Linux as per instructions here:
>>
>> http://www.gnu.org/software/guix/manual/guix.html#Binary-Installation
>>
>> The install for root when well and the hello sample package installed
>> fine. Then I went to setup my user as described here:
>>
>> http://www.gnu.org/software/guix/manual/guix.html#Application-Setup
>>
>> but got a segfault at:
>>
>> $ guix package -i glibc-locales
>>
>> and in fact even just
>>
>> $ guix
>
> Is LD_LIBRARY_PATH or LD_PRELOAD set in your environment?

This was set:

LD_LIBRARY_PATH=/home/myles/GNUstep/Library/Libraries:/usr/lib

so I uninstalled GNUstep and rebooted, LD_LIBRARY_PATH is unset and this
works:

$ guix package -i glibc-locales

Toggle quote (4 lines)
> What happens if you run:
>
> env -i `type -P guix` --help

$ env -i `type -P guix` --help
zsh: bad option: -P
Usage: env [OPTION]... [-] [NAME=VALUE]... [COMMAND [ARG]...]
Set each NAME to VALUE in the environment and run COMMAND.

Mandatory arguments to long options are mandatory for short options too.
-i, --ignore-environment start with an empty environment
-0, --null end each output line with NUL, not newline
-u, --unset=NAME remove variable from the environment
--help display this help and exit
--version output version information and exit

A mere - implies -i. If no COMMAND, print the resulting environment.

GNU coreutils online help: http://www.gnu.org/software/coreutils/
or available locally via: info '(coreutils) env invocation'

Toggle quote (2 lines)
> What does “info files” say in GDB?

N/A

Toggle quote (2 lines)
> Thank you for the bug report!

Thank you for the help! 'Bug' closed?

Myles

P.S. now firefox gives me a segfault, I think there are other issues here.
L
L
Ludovic Courtès wrote on 29 Apr 2016 14:39
(name . Myles English)(address . mylesenglish@gmail.com)
878tzwr3ln.fsf@gnu.org
tags 23389 notabug
close 23389
thanks

Myles English <mylesenglish@gmail.com> skribis:

Toggle quote (32 lines)
> Ludovic Courtès writes:
>
>> Myles English <mylesenglish@gmail.com> skribis:
>>
>>> Just installed binary x86-64 nix on Arch Linux as per instructions here:
>>>
>>> http://www.gnu.org/software/guix/manual/guix.html#Binary-Installation
>>>
>>> The install for root when well and the hello sample package installed
>>> fine. Then I went to setup my user as described here:
>>>
>>> http://www.gnu.org/software/guix/manual/guix.html#Application-Setup
>>>
>>> but got a segfault at:
>>>
>>> $ guix package -i glibc-locales
>>>
>>> and in fact even just
>>>
>>> $ guix
>>
>> Is LD_LIBRARY_PATH or LD_PRELOAD set in your environment?
>
> This was set:
>
> LD_LIBRARY_PATH=/home/myles/GNUstep/Library/Libraries:/usr/lib
>
> so I uninstalled GNUstep and rebooted, LD_LIBRARY_PATH is unset and this
> works:
>
> $ guix package -i glibc-locales

Great.

Toggle quote (7 lines)
>> What happens if you run:
>>
>> env -i `type -P guix` --help
>
> $ env -i `type -P guix` --help
> zsh: bad option: -P

Then something like:

env -i `which guix` --help

Anyway, the rest of your message confirms my intuition.

Thanks,
Ludo’.
?