Show example for GuixSD config.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Evan Rowley
Owner
unassigned
Submitted by
Evan Rowley
Severity
normal
E
E
Evan Rowley wrote on 28 Jun 2015 16:22
(address . bug-Guix@gnu.org)
CAMhuX2A1M8YE1nG6jFMP7gpHAsoRMiVgfGNw7CT9kFNZdVa17w@mail.gmail.com
Hello

I'm very interested in running a GuixSD system. I'm currently setting
one up now, and am hoping someone here would be kind enough to share
their /etc/config.scm with me. Particularly, I'm looking for examples
of how a system with multiple partitions would be defined in the
config.scm file.

My Partitions
1. bios_grub 10M
2. /boot 500M
3. /swap 16.5G
4. /root 50G
5. /usr 50G
6. /var 50G
7. /home 50G

This installation is for a 250GB hard disk on a SuperMicro H8DGU-F
motherboard with an AMD Opteron 6128 CPU and 8GB of ECC RAM. Let me
know if there is anything anyone wants tested about this setup
(assuming I can get it online)

--
- EJR
L
L
Ludovic Courtès wrote on 29 Jun 2015 10:46
(name . Evan Rowley)(address . rowley.evan@gmail.com)(address . bug-Guix@gnu.org)
87oajyq4v3.fsf@gnu.org
Hello,

Evan Rowley <rowley.evan@gmail.com> skribis:

Toggle quote (15 lines)
> I'm very interested in running a GuixSD system. I'm currently setting
> one up now, and am hoping someone here would be kind enough to share
> their /etc/config.scm with me. Particularly, I'm looking for examples
> of how a system with multiple partitions would be defined in the
> config.scm file.
>
> My Partitions
> 1. bios_grub 10M
> 2. /boot 500M
> 3. /swap 16.5G
> 4. /root 50G
> 5. /usr 50G
> 6. /var 50G
> 7. /home 50G

I’m using a separate encrypted /home and a swap partition, so the
declaration looks like this:

Toggle snippet (30 lines)
(operating-system
(host-name "pluto")
(timezone "Europe/Paris")
(locale "en_US.utf8")

(bootloader (grub-configuration
(device "/dev/sda")))

(mapped-devices (list (mapped-device
(source "/dev/sda3")
(target "home")
(type luks-device-mapping))))

(file-systems (cons* (file-system
(device "root")
(title 'label)
(mount-point "/")
(type "ext3"))
(file-system
(device "/dev/mapper/home")
(mount-point "/home")
(type "ext3"))
%base-file-systems))

(swap-devices '("/dev/sda4")) ;XXX: LABEL=swap

;; ...
)

Normally you just need to add extra ‘file-system’ declarations for /var
and /boot in there, and you’re done.

/usr doesn’t make sense on GuixSD because that directory is not used at
all.

HTH,
Ludo’.

PS: Please use guix-devel@gnu.org for discussions; bug-guix@gnu.org goes
to the bug tracker at http://bugs.gnu.org/guix.
L
L
Ludovic Courtès wrote on 29 Jun 2015 10:47
bug
(address . request@debbugs.gnu.org)
87k2umq4u0.fsf@gnu.org
tag 20920 notabug
close 20920
thanks
?