<ncursesw/ncurses.h> not provided by the ncurses library

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Ludovic Courtès
Owner
unassigned
Submitted by
???
Severity
normal
?
(address . bug-guix@gnu.org)
87ioiloq4f.fsf@gmail.com
Hi, gtypist check and use ncurses header from that location,
perhaps we should make a symlink in ncurses just as nixpkgs does.

And here is my patch for gtypist:
From 4cfd5ede203eb3a105a7396ccf784f756150f90c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Tue, 11 Nov 2014 20:34:22 +0800
Subject: [PATCH] gnu: Add GNU Typist.

* gnu/packages/games.scm (gtypist): New variable.
---
gnu/packages/games.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index df24c0d..5759c07 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -462,3 +462,27 @@ you control to bounce a ball around the game zone destroying blocks with a
proton ball. Each block carries a different point value. The more blocks you
destroy, the better your score. The person with the highest score wins.")
(license (x11-style "file://COPYING" "Very similar to the X11 licence."))))
+
+(define-public gtypist
+ (package
+ (name "gtypist")
+ (version "2.9.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gtypist/gtypist-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0xzrkkmj0b1dw3yr0m9hml2y634cc4h61im6zwcq57s7285z8fn1"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "http://www.gnu.org/software/gtypist/")
+ (synopsis "Universal typing tutor")
+ (description
+ "Typist is a typing tutor package built using Curses. The package has
+tutorials, drills, and practice sessions to learn touch typing. The emphasis
+is on the US computer keyboard layout, but lessons for Dvorak and other
+keyboard types and languages are also included. The program also has Native
+Language Support and is distributed with messages in many different languages.")
+ (license gpl3+)))
--
1.9.2
L
L
Ludovic Courtès wrote on 11 Nov 2014 17:53
(name . ???)(address . iyzsong@gmail.com)(address . 19018@debbugs.gnu.org)
87vbmlhe5n.fsf@gnu.org
??? <iyzsong@gmail.com> skribis:

Toggle quote (3 lines)
> Hi, gtypist check and use ncurses header from that location,
> perhaps we should make a symlink in ncurses just as nixpkgs does.

I wonder what the Right Thing is. The ‘ncurses’ package explicitly
passes --includedir=$out/include because that’s what all the packages we
have so far expect.

If it turns out that a non-negligible number of packages expect headers
to be under $out/include/ncursesw, then I agree that we should make a
symlink.

In the meantime, since ncurses is a core package, could you just patch
gtypist (in a ‘snippet’) to use the right headers?

(BTW, make sure to add a copyright line for you in the package.)

Thanks in advance!

Ludo’.
L
L
Ludovic Courtès wrote on 10 Jun 2015 10:16
close
(address . request@debbugs.gnu.org)
87fv60htbd.fsf@gnu.org
tag 19018 wontfix
close 19018
thanks
?